none
RegSvr32 Error Messages

    Question

  • Was taking the advice from a "related topic"  question, and pulled up the command window as an elevated administrator.  I typed in the following,

    "regsvr32 wuaueng1.dll"

    "regsvr32 wucltui.dll"

    "regsvr32 wuweb.dll"

    In each instance, I received an error message that read "The module "wuaueng1.dll" failed to load.  Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.  The specific module could not be found.

    These were the only three that I received error messages.  The the others were successful.

    Help?

    Friday, November 23, 2012 8:51 AM

Answers

  • Was taking the advice from a "related topic" question

    Make sure the binary is stored at the specified path... The specific module could not be found. 

    Such is the challenge with using ancient advice...  Did you look in C:\Windows\System32 and see if those files exist?

    "regsvr32 wuaueng1.dll"

    This DLL was deprecated by the WUAgent v.7.6. The message is correct. The DLL no longer exists.

    "regsvr32 wucltui.dll"

    The current instance of this file is named wucltux.dll. It was renamed in the WUAgent v7.6.

    "regsvr32 wuweb.dll"

    The current instance of this file is named wuwebv.dll. It was renamed in the WUAgent v7.6.

    Which is why I prefer the command of this form: for %%f in (wu*.dll) do regsvr32 %%f


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Friday, November 23, 2012 5:54 PM
    Moderator