none
File copy using Group Policy

    Question

  • Hi Everyone,

     I'm trying to copy a file using group policies (Group Policy’s Computer Configuration | Preferences | Windows Settings | Files section ). So far I haven't had any luck. The file I'm trying to copy is an .exe file, I'm wondering if that could be the problem. Also in my test environment there are no other policies being applied to the test OU.

    Thanks,

    Rick

    Wednesday, April 24, 2013 2:05 PM

All replies

  • Am 24.04.2013 16:05, schrieb R. Morgan:
    > Group Policy’s Computer Configuration
     
    What file? Source path = Network? Then verify the computer account (or
    "domain computers") has at least read permissions on share and NTFS level...
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, April 24, 2013 2:36 PM
  • Martin,

    Will the folder be created on the target computer or should I create the folder first? As you recommended I gave full permission to domain computers and full permission to NTFS and Share.

    I'll let you know what happens.

    -Rick

    Wednesday, April 24, 2013 2:54 PM
  • Not much to report, still not working.
    Wednesday, April 24, 2013 3:49 PM
  • Post a screen shot of the configuration of this policy. block out any sensitive info

    Then we can help

    Wednesday, April 24, 2013 4:46 PM
  • Event ID 4098

    The computer '' preference item in the 'MistDesktopIcon {DEC9136D-99C5-4C97-B283-99EEB85B48F1}' Group Policy object did not apply because it failed with error code '0x80070003 The system cannot find the path specified.' This error was

    The path is good, if I copy it from "Source file" below and paste to "my compter" address bar Mist app will run.

    Thanks for your help

    Wednesday, April 24, 2013 5:50 PM
  •  
    > The path is good, if I copy it from "Source file" below and paste to
    > "my compter" address bar Mist app will run.
     
    That doesn't proof anything, unfortunately - you access the file with
    YOUR account, not with the computer account... Refer to my post above
    and check ACLs on the source...
    "psexec -s cmd" can help to check whether the computer can access the
    source fle.
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, April 24, 2013 6:34 PM
  • Hi,

    Please also check the similar thread:

    Group policy preference file copy error 80070003        

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/bacee815-fee2-4ca5-bd34-37524fb95cf8

    Regards.


    Vivian Wang
    TechNet Community Support

    Thursday, April 25, 2013 9:44 AM
    Moderator
  • Thanks for your help; I have about 20 laptops that need the app installed so I'll do it the primitive way (copy & paste) . The GP setting seems like it will be very handy, I’ll wait until MS experts figure it out. I just need to get the app installed and know I’ll spend too much time trying to figure it out.

    Thanks again,

    Rick

    Thursday, April 25, 2013 12:39 PM
  • In GPP file copies, in the Destination File field you must specify the filename, which does not appear to be the case in your screenshot.

    • Edited by zxxzxx Sunday, April 28, 2013 2:07 PM Typo.
    Sunday, April 28, 2013 2:06 PM
  • Am 28.04.2013 16:06, schrieb zxxzxx:
    > In GPP file copies, in the *Destination File *field you must specify
    > the filename, which does not appear to be the case in your screenshot.
    >
     
    No. If you finish it with a \, it is assumed to be a direcory, AFAIK.
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Sunday, April 28, 2013 8:20 PM
  • I tested this for GPP Files only and found:

    If the path specified in the Destination File doesn't exist, and the path ends in a /, you receive the following error:

    '0x8007007b The filename, directory name, or volume label syntax is incorrect.'

    If the path specified in the Destination File does exist, and the path ends in a /, you receive the following error:

    '0x80070003 The system cannot find the path specified.'

     

    If the path specified in the Destination File does exist, and the path ends in a filename (with or without an extension), then GPP Files will copy the file to the path successfully. (If you didn't specify a filename, then the file is copied over and renamed.)

     

    The help file states:

    Destination file

    Type the location to which to copy a file or the location of the file to be
    modified. This location can be a fully qualified UNC path or a path on a local
    or mapped drive from the perspective of the client. Parent folders are created
    as necessary. You must include the file name, and you can change the file name
    by providing a different name for it than specified in the Source file(s)
    field.

     

    zxx

     

     

     

    Friday, May 03, 2013 6:23 PM
  • Am 03.05.2013 20:23, schrieb zxxzxx:
    > If the path specified in the Destination File does exist, and the path
    > ends in a filename (with or without an extension), then GPP Files will
    > copy the file to the path successfully. (If you didn't specify a
    > filename, then the file is copied over and renamed.)
     
    Thanks for clarification - now I remember ;-) You can use a directory as
    the target name if the source contains wildcards. But I'm not a friend
    of GPP Files anyway, so my knowledge about specific behaviour of that
    extension is somewhat limited...
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Sunday, May 05, 2013 5:06 PM