none
Scheduled Backup not Running

    Question

  • Using Windows Server Backup I setup a scheduled backup on Server 2008 R2 running Exchange 2010.  It ran as scheduled until 5 days ago.

    The backup stopped running nightly.  Each day the backup management screen shows that a backup is scheduled for that night, but the scheduled backup does not run.  When I check each day, the next scheduled backup is shown as the backup for the evening to come; the last scheduled backup that ran successfully was shown as the last backup.

    Even though backups are not running, there are no unsuccessful backup attempts listed in the recent backups list at the top of the utility.  There are also not any failed backups in the event logs.

    Any help would be greatly appreciated!

    Thursday, December 08, 2011 3:58 PM

Answers

  • I finally figured this out.  The problem is caused by too may tasks in the task queue.  Check the local task scheduler history (Task Scheduler > Microsoft > Windows > Backup > History tab) for Event ID 131 - "Task Scheduler failed to start task "%1" because the number of tasks in the task queue exceeds the quota currently configured to %2%. Reduce the number of running tasks or increase the configured queue quota.".  To resolve this edit the following registry key: HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Schedule\Configuration\TasksInMemoryQueue and increase the value (The default value is 64).  I set mine to 200 (Hex c8) and have not had a backup failure since.

    Also see: http://technet.microsoft.com/en-us/library/dd363733(v=ws.10).aspx

    Caution: Incorrectly editing the registry can corrupt your system. Back up valued data before making changes to the registry.

    • Marked as answer by eclipse124 Thursday, April 19, 2012 12:57 PM
    Thursday, April 19, 2012 12:57 PM

All replies

  • Hi,

     

    Is the backup configured to backup to network share or to local disk\volume ?

     

    If it was for network share, did the password for the user change (the user account under which the backup was configured) ?

     

    Try to reconfigure the scheduled backup, if the account password was changed, it might fix the issue.

     

    Best regards,

    Jeff Ren


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 09, 2011 2:45 AM
    Moderator
  • The backup location is not a share, it's an attached USB drive.  The backup runs when started manually.  I have rebooted the server this AM and we'll see if the job runs tonight.
    Friday, December 09, 2011 1:03 PM
  • The job ran successfully Friday night, Saturday night but nothing last (Sunday) night.  No unsuccessful atempts or errors in the events.  Any ideas?
    Monday, December 12, 2011 4:10 PM
  • Can you upload the backup logs?

     


    Sumesh P - Microsoft Online Community Support
    Monday, December 19, 2011 9:41 AM
    Moderator
  • There are no logs available when it does not run.  Below is the setup in entered into the task scheduler when setup through the GUI.  Ran fine on the 17th but nothing for the 18th or 19th.

    %windir%\System32\wbadmin.exe start backup -templateId:{e31d203f-b2e1-432d-b841-ddc2727f5910} -quiet

    Tuesday, December 20, 2011 1:39 PM
  • Can you do an adhoc backup using the above command line?

     

    Thanks

    Rena


    This posting is provided "AS IS" with no warranties, and confers no rights
    Wednesday, December 21, 2011 6:39 AM
    Moderator
  • Yes, the backup runs when I run the above adhoc from the cmd line.
    Wednesday, December 21, 2011 1:03 PM
  • I'm not getting any errors when running the backup.  When the scheduled backup fails to run there is no events, logs or errors generated.
    Wednesday, December 21, 2011 2:23 PM
  • Its possible that it is a task scheduler property to not start the next task if the previous task has not completed. Is your backup long-running?

    Thanks

    Rena


    This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, December 22, 2011 4:11 AM
    Moderator
  • Dont you see any logs at C:\Windows\Logs\WindowsServerBackup  ?

     

     


    Sumesh P - Microsoft Online Community Support
    Thursday, December 22, 2011 9:31 AM
    Moderator
  • what if you remove the -quiet option, does it show up with any prompt?

    Does the task option require a user to be logged in?

    What if you create a new task with the same parameters?

     


    Sumesh P - Microsoft Online Community Support
    Thursday, December 22, 2011 9:35 AM
    Moderator
  • No prompt when removing the -quiet option.  The task does not require a user to be logged in.  Same condition if I create a new task.  The problem is intermittent.
    Wednesday, December 28, 2011 1:05 PM
  • Yes, there are logs with a .etl extension.  What is a good reader to open these files?
    Wednesday, December 28, 2011 1:27 PM
  • No, I don't see anything that would stop the task from running.  The problem is intermittent, some evenings it runs without error other times it does not run at all with no unsuccessful backup attempts listed in the recent backups list at the top of the utility.  There are also no failed backups in the event logs.
    Wednesday, December 28, 2011 1:30 PM
  • Can you start a debug trace before the backup task and send me the resultant logs?

     You can run the below as a batch file before the backup starts.

    @echo off
    ECHO These commands will enable tracing:
    @echo on
    logman create trace base_stor -ow -o c:\base_stor.etl -p "Microsoft-Windows-Backup" 0xffffffffffffffff 0xff -nb 16 16 -bs 1024 -mode 0x2 -max 2048 -ets
    @echo off
    echo
    ECHO Reproduce your issue and enter any key to stop tracing
    @echo on
    pause
    logman stop base_stor -ets
    @echo off
    echo Tracing has been captured and saved successfully at c:\base_stor.etl
    


    Sumesh P - Microsoft Online Community Support
    Monday, January 02, 2012 5:48 AM
    Moderator
  • Any solution to this.  I am having exact same intermittent problem.  Backup task does not trigger and there are no events, logs or errors. 
    Tuesday, January 10, 2012 9:09 PM
  • Are you specifically seeing this problem when the Admin/Backup-operator is Logged-Off?

     

    Thanks

    Rena


    This posting is provided "AS IS" with no warranties, and confers no rights
    Monday, January 16, 2012 5:25 AM
    Moderator
  • In my case problem is happening regardless of admin being logged in or off. 

    Task properties has "run whether user is logged on or not" selected but greyed out.

    Tuesday, January 17, 2012 8:30 PM
  • In my experience, backups are shown in the interface as successful even if they actually failed.

    Use Powershell to get more details about your backup job outcome:

    Get-WBJob -previous 1

    This will show if it completed successfully, what was included in the backups and the location of the backup logs that might be helpful in troubleshooting.

    Also check that there is plenty of free space on your destination backup disk. wbadmin has some glitches in space management. Try deleting the old backup copies with diskshadow.exe command prior to running the backup task.

    Tuesday, January 17, 2012 10:53 PM
  •  

    Can you check whether VDS service is started ? If not, try to start it and then check.

    Also refer below link this may be helpful:

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/640e24c5-dcf9-485f-a9ef-728b2774a02e/

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/34c940c4-0855-41f2-92df-e4d831c30b53/

    http://serverfault.com/questions/210857/backup-fails-to-start


    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, January 20, 2012 5:51 AM
    Moderator
  • No, we keep the admin logged in but locked.  I have tested both logged in and locked and logged off.  Same issue regardless.
    • Edited by eclipse124 Friday, January 20, 2012 2:08 PM
    Friday, January 20, 2012 2:07 PM
  • These all seem to point to the VDS service.  I check the server and the service was set to manual and not started.  I set the service to automatic and started it.  Do you know of any issues with having VDS started all the time?

    Sunday, Monday and Tuesday the backup did not run.  Without making any changes the backup ran successfully Wednesday and Thursday.  Again when the backups do not run there are no unsuccessful backup attempts listed in the Recent Backups List at the top of the utility.  There are also no failed backups in the event logs.

    We'll see how it runs tonight and this weekend with VDS set to automatic and started.


    • Edited by eclipse124 Friday, January 20, 2012 2:35 PM
    Friday, January 20, 2012 2:34 PM
  • Hi,

     

    If it is exchange backup on clusters. Please check the exchange resources and confirm.

     

    Any chance  resource is moved to passive node, backup will not run and doesn't through any alerts or events.

     

    Thanks,

    Dev 

    Tuesday, January 24, 2012 1:03 PM
  • Setting VDS to automatic start made no difference.

    The backup is not on a cluster.

    Any other ideas?  This is becoming a real headache!

    • Marked as answer by eclipse124 Thursday, April 19, 2012 12:57 PM
    • Unmarked as answer by eclipse124 Thursday, April 19, 2012 12:57 PM
    Wednesday, February 22, 2012 2:16 PM
  • I finally figured this out.  The problem is caused by too may tasks in the task queue.  Check the local task scheduler history (Task Scheduler > Microsoft > Windows > Backup > History tab) for Event ID 131 - "Task Scheduler failed to start task "%1" because the number of tasks in the task queue exceeds the quota currently configured to %2%. Reduce the number of running tasks or increase the configured queue quota.".  To resolve this edit the following registry key: HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Schedule\Configuration\TasksInMemoryQueue and increase the value (The default value is 64).  I set mine to 200 (Hex c8) and have not had a backup failure since.

    Also see: http://technet.microsoft.com/en-us/library/dd363733(v=ws.10).aspx

    Caution: Incorrectly editing the registry can corrupt your system. Back up valued data before making changes to the registry.

    • Marked as answer by eclipse124 Thursday, April 19, 2012 12:57 PM
    Thursday, April 19, 2012 12:57 PM
  • Thank you for sharing your tip!

    Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, April 19, 2012 1:07 PM
  • Extremely helpful - thank-you! Regards Stan
    Tuesday, September 02, 2014 9:53 AM