none
Server Manager cannot connect, WinRM client cannot process the request, Error number: -2144108316 0x803380E4

    Question

  • 1. Following error occurs when using Server Manager on Windows 7 Ultimate SP1 (client01):

    Server Manager cannot connect to server01 Click
    Retry to try to connect again.

    Connecting to remote server failed with the following error
    message : The WinRM client cannot process the request. If
    the authentication scheme is different from Kerberos, or if
    the client computer is not joined to a domain, then HTTPS
    transport must be used or the destination machine must be
    added to the TrustedHosts configuration settings. Use
    winrm.cmd to configure TrustedHosts. Note that computers
    in the TrustedHosts list might not be authenticated. You can
    get more information about that by running the following
    command: winrm help config. For more information, see the
    about_Remote_Troubleshooting Help topic.


    2. Following error occurs from the client01 command prompt:

    winrm identify -remote:server01
    WSManFault
        Message = The WinRM client cannot process the request. If the authentication scheme is different from Kerberos, or if the client
     computer is not joined to a domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts
    configuration setting. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated.
    You can get more information about that by running the following command: winrm help config.

    Error number:  -2144108316 0x803380E4
    The WinRM client cannot process the request. If the authentication scheme is different from Kerberos, or if the client computer is not
    joined to a domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts configuration
    setting. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated. You can
    get more information about that by running the following command: winrm help config.

    >Following section has been updated.

    3. Have looked at the following relevent articles:
    http://technet.microsoft.com/en-us/library/dd759202.aspx
    http://technet.microsoft.com/en-us/library/dd347642.aspx
    http://msdn.microsoft.com/en-us/library/aa384372(VS.85).aspx
    http://www.petri.co.il/2008-r2-server-core-enable-remote-management.htm

    4. Steps to reproduce

    i) Download R2 with SP1 (64 bit) trial:
    http://technet.microsoft.com/en-us/evalcenter/ee175713.aspx

    ii) Install virtualisation software such as VMware Player
    http://www.vmware.com/products/player/

    iii) Create a new virtual machine
    Point to the downloaded R2 iso file:
    7601.17514.101119-1850_x64fre_server_eval_en-us-GRMSXEVAL_EN_DVD.iso
    The default settings should be fine for the remaining screens.

    iv) Allow Server Manager Remote Management
    Once logged into R2:
    sconfig
    select 4 to configure remote management
    - select 2 to enable Windows Powershell (requires restart)
    - select 3 to Allow Server Manager Remote Management
    - select 5 to return to main menu
    select 13 to exit to command line

    v) Install Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d

    vi) Enable Server Manager
    Control Panel, Turn Windows Features on or off, tick: Server Manager.

    vii) Launch Server Manager
    Attempt to connect to the IP address shown by ipconfig on the server.


    Additional troubleshooting steps taken:
    Remote desktop works fine once enabled in sconfig.
    Same problem occurs in full (none core) version of R2

    What have I missed to get Server Manager working?
    server01 is running 2008 R2 SP1 with the latest Windows Updates.


    Monday, May 16, 2011 6:39 AM

All replies

  • raymov, I feel your pain.  I have the exact same problem.  I can connect to local machines via RDP and then run Server Manager... but that requires opening up way too many security holes.  I am unable to run Server Manager remotely to any of our Windows Server 2008 R2 host or virtual machines.  Server Core, Full Insstall, nothing seems to matter.  Can't even go from one server to another on the same subnet.

    Anyone able to assist or point to more resources here?

    ...jeff

    Tuesday, May 31, 2011 4:26 PM
  • I can't offer any advice to you because I use Server Manager to connect to other remote servers without difficulty, even to a Hyper-V Server 2008 server.
     
    Tom Mason

    raymov, I feel your pain.  I have the exact same problem.  I can connect to local machines via RDP and then run Server Manager... but that requires opening up way too many security holes.  I am unable to run Server Manager remotely to any of our Windows Server 2008 R2 host or virtual machines.  Server Core, Full Insstall, nothing seems to matter.  Can't even go from one server to another on the same subnet.

    Anyone able to assist or point to more resources here?

    ...jeff

    Saturday, June 04, 2011 1:42 AM
  • Hi,

    Since this is also occuring in full Server, I would recommend posting to the management forum and seeing what the Server Manager experts say.


    Andrew

    • Proposed as answer by chma1 Thursday, June 05, 2014 9:51 PM
    Thursday, June 30, 2011 12:57 AM
    Owner
  • I had the same problems and thought I had done everything needed from a command line but still nothing worked.  I used c:\windows\system32\sconfig enabled remote management and then everything worked fine.
    Friday, September 02, 2011 3:45 AM

  • 1. Following error occurs when using Server Manager on Windows 7 Ultimate SP1 (client01):

    Server Manager cannot connect to server01 Click
    Retry to try to connect again.

    Connecting to remote server failed with the following error
    message : The WinRM client cannot process the request. If
    the authentication scheme is different from Kerberos, or if
    the client computer is not joined to a domain, then HTTPS
    transport must be used or the destination machine must be
    added to the TrustedHosts configuration settings. Use
    winrm.cmd to configure TrustedHosts. Note that computers
    in the TrustedHosts list might not be authenticated. You can
    get more information about that by running the following
    command: winrm help config. For more information, see the
    about_Remote_Troubleshooting Help topic.


    2. Following error occurs from the client01 command prompt:

    winrm identify -remote:server01
    WSManFault
        Message = The WinRM client cannot process the request. If the authentication scheme is different from Kerberos, or if the client
     computer is not joined to a domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts
    configuration setting. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated.
    You can get more information about that by running the following command: winrm help config.

    Error number:  -2144108316 0x803380E4
    The WinRM client cannot process the request. If the authentication scheme is different from Kerberos, or if the client computer is not
    joined to a domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts configuration
    setting. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated. You can
    get more information about that by running the following command: winrm help config.

    >Following section has been updated.

    3. Have looked at the following relevent articles:
    http://technet.microsoft.com/en-us/library/dd759202.aspx
    http://technet.microsoft.com/en-us/library/dd347642.aspx
    http://msdn.microsoft.com/en-us/library/aa384372(VS.85).aspx
    http://www.petri.co.il/2008-r2-server-core-enable-remote-management.htm

    4. Steps to reproduce

    i) Download R2 with SP1 (64 bit) trial:
    http://technet.microsoft.com/en-us/evalcenter/ee175713.aspx

    ii) Install virtualisation software such as VMware Player
    http://www.vmware.com/products/player/

    iii) Create a new virtual machine
    Point to the downloaded R2 iso file:
    7601.17514.101119-1850_x64fre_server_eval_en-us-GRMSXEVAL_EN_DVD.iso
    The default settings should be fine for the remaining screens.

    iv) Allow Server Manager Remote Management
    Once logged into R2:
    sconfig
    select 4 to configure remote management
    - select 2 to enable Windows Powershell (requires restart)
    - select 3 to Allow Server Manager Remote Management
    - select 5 to return to main menu
    select 13 to exit to command line

    v) Install Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d

    vi) Enable Server Manager
    Control Panel, Turn Windows Features on or off, tick: Server Manager.

    vii) Launch Server Manager
    Attempt to connect to the IP address shown by ipconfig on the server.


    Additional troubleshooting steps taken:
    Remote desktop works fine once enabled in sconfig.
    Same problem occurs in full (none core) version of R2

    What have I missed to get Server Manager working?
    server01 is running 2008 R2 SP1 with the latest Windows Updates.


    PleaseTry running this:


            PSH> winrm set winrm/config/client `@`{TrustedHosts=`"`*`"`}

    Sounds like you need to open up the client connection permissions.

    You may not want to open it up to anywhere though.

    Something like this should also work:

          PSH> winrm set winrm/config/client
          `@`{TrustedHosts=`"server1_IP,server2_IP"`}


    Monday, September 12, 2011 8:41 PM
    • Edited by James_Hill Tuesday, June 05, 2012 11:59 PM
    • Proposed as answer by James_Hill Tuesday, June 05, 2012 11:59 PM
    Tuesday, June 05, 2012 11:58 PM
  • Do you have a proxy in place?

    What does this say?:

    netsh winhttp show proxy

    Monday, August 06, 2012 3:25 PM
  • I got an error when connecting using remote to an exchange server 2010 in a non-trusted forest from one of my windows 7 client machine.

    "Connecting to remote server failed with the following error message : WinRM cannot process the request. The following error occured while using Kerberos authentication: There are currently no logon servers available to service the logon request."

    This occurs when remoting session with exchange server config.

    "$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://server-ex10/PowerShell/ -Authentication Kerberos -Credential $cred"

    I have tried (TrustedHosts=*) in winrm/config/client. I am suspecting the issue is due to kerberos authenticaton.

    Interesting fact is that I am able to connect from another client machine(non-trusted) with same configuration.So it seems the problem is with some settings in client machine. 



    Thursday, May 02, 2013 11:53 AM