none
Windows Media Player cannot find the file. If you are trying to play, burn, or sync an item that is in your library, the item might point to a file that has been moved, renamed, or deleted.

    Question

  • I have set up WMS on windows server 2008R2 and created an on demand publishing point.  I also gave it a static IP Address and port for the http protocol. I also opened up the the port with outbound/inbound rules in windows firewall on the server as well.  I am trying to access a wmv file over http from my dev machine to my server.  It seems it can access the file, but does not play, displaying the error in the title.

    Suggestions? Questions?

    Thanks,


    Learn Like a Sponge

    Monday, June 18, 2012 11:50 PM

Answers

All replies

  • What is the error?  You might do a network trace with Network Monitor (http://www.microsoft.com/en-us/download/details.aspx?id=4865) to see what the server is actually responding with.  Additionally, make sure that you don't have something else like IIS also listening on port 80.
    Tuesday, June 19, 2012 2:32 PM
  • The error is the title of the thread "Windows Media Player cannot find the file. If you are trying to play, burn, or sync an item that is in your library, the item might point to a file that has been moved, renamed, or deleted" when I try to access the file through http://someipaddress:port/mydirectory/myfile.wmv.  Also, I am using a brand new static IP address and using port 1450.  While IIS is on the same box, it is using another IP address. 

    I will try the network monitory and see if I can find anything as well.


    Learn Like a Sponge

    Tuesday, June 19, 2012 4:26 PM
  • So are you using http://someipaddress:1450/mydirectory/myfile.wmv?  Still, getting a network trace would help a lot.
    Tuesday, June 19, 2012 4:59 PM
  • Make sure you enable one or more of the control protocols.  You can only enable HTTP if IIS or other webservers are not already bound to port 80.  Go to the Windows Media Services MMC snapin.  Go to the properties tab for the server.  Under Control Protocol, enable one or more of the protocol plugins.  You may have to set the properties to valid values before enabling these protocol plugins.
    Monday, June 10, 2013 3:43 PM