none
remote desktop config options are missing/greyed out

    Question

  • Hi please look at this post as i am having the same problems and was wandering if anyone found a fix or knows a fix for it.

     

    http://social.technet.microsoft.com/Forums/en/windowsserver2008r2networking/thread/b8c0dfa3-3283-4cd9-a9d0-540d77c7de97

     

    i also upgraded the server from std to ent using the method mentioned in the post

    when you click on configure remote desktop you get a very blank screen and no options to allow remote access which you would normally get ( from any pc/selected PC's etc)

     

    Thanks

     


    Tuesday, July 05, 2011 12:24 PM

Answers

All replies

  • Hello,

    When options are greyed out this useally is triggered by the of group policies. Please review your domain and local group policies.


    regards Robert Maijen
    Tuesday, July 05, 2011 1:58 PM
  • Hi I am 100% this is not a GPO.

     

    its not so much greyed out but it is totally missing.

     

    you can click configure remote desktop but the box that appears is missing half the information it should have ( i can post a screen shot or send one if needed).

    and i am pretty sure its realted to the dism upgrade

    Many Thanks

     

    Tuesday, July 05, 2011 2:06 PM
  • Hi,

     

    For remote desktop config options are missing issue. Whether you are using Windows server 2008 R2 or not. Is it Windows 7 Basic, Windows 7 Home Premium or what?

     

    For remote desktop config options greyed out issue. According to your description, I understand that you right-click Computer icon, choose Properties and click the Remote tab, the option "Allow users to remotely connect to this computer" may be dimmed or greyed out. This may happens due to a Policy setting. Please double check it.

     

    Please follow these steps to check the issue:

    Click Start, Run. Type GPEDIT.MSC and press Enter. Navigate to:

    Computer configuration | Administrative Templates | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Connections

    In the right-pane, double-click Allow users to connect remotely using Terminal Services, set it to Not configured.

     

    Regards,

    Dollar Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

     


    Technology changes life……
    Wednesday, July 06, 2011 2:50 AM
  • Hi,

    Whether this issue still exists. Looking forward to your feedback.


    Technology changes life……
    Wednesday, July 13, 2011 3:23 AM
  • Hi

    when we did the upgrade following this atricle

    http://blogs.technet.com/b/server_core/archive/2009/10/14/upgrading-windows-server-2008-r2-without-media.aspx

     

    we used the default KMS key for server 2008 r2 and this is what caused the problem

    the resolution is to then manually change the product key to a valid licensed version restart the server and all features are back again.

    Many Thanks

    • Marked as answer by IPS Group Wednesday, July 13, 2011 8:48 AM
    Wednesday, July 13, 2011 8:47 AM
  • Ok, thank you for your feedback.


    Technology changes life……
    Thursday, July 14, 2011 3:00 PM
  • I had this very same problem after upgrading to Enterprise from Standard using the DISM. The upgrade would not procede without a Generic KMS key. After upgrading I input the valid MAK key through the GUI but still had a problem with Remote Desktop settings missing.

    In order to get the remote desktop settings back I had to input the valid MAK key via command line.

     

    Here are the commands:

    cscript c:\windows\system32\slmgr.vbs -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

     cscript C:\windows\system32\slmgr.vbs /ato


    Jacen
    • Proposed as answer by dob_1974 Monday, April 23, 2012 12:40 AM
    Wednesday, December 14, 2011 9:04 PM
  • I had this very same problem after upgrading to Enterprise from Standard using the DISM. The upgrade would not procede without a Generic KMS key. After upgrading I input the valid MAK key through the GUI but still had a problem with Remote Desktop settings missing.

    In order to get the remote desktop settings back I had to input the valid MAK key via command line.

     

    Here are the commands:

    cscript c:\windows\system32\slmgr.vbs -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

     cscript C:\windows\system32\slmgr.vbs /ato


    Jacen
    I had the same problem, changing the key through the GUI did not work but after using the commands its working, thanks a lot
    Wednesday, June 20, 2012 9:10 AM