locked
The reference assembly is not installed on your system

    Question

  • I'm working with windows 2008 64bit with IIS7.
    I attempted to install the SMTP feature, but something happened during the installation that cause the whole thing to fail. Normally this isn't a big deal. But now when I try to manage my websites using the Server Manager, none of the roles or features load (they show up as "error") and the error details reveals the following message:

    "Unexpected error refreshing Server Manager: the referenced assembly is not installed on your system.
    (Exception from HRESULT: 0x800736B3)"

    I'm no expert in servers and how to diagnose them, and I've been searching and trialing for hours on end. It seems like this issue is so new that no one has ever encountered it except in reference to asp.net applications on IIS6.

    Can anybody help me? I'm under a lot of pressure to make this website live before tomorrow and this is the only thing holding me back.

    Much appreciated.
    Friday, March 27, 2009 5:03 AM

All replies

  • Hello Auriion,
    Can you confirm if this is still happening? If so, can you provide more information?
    Is IIS running? Will the server serve a pages? Can you check the Events Viewer (eventvwr.msc from the command prompt) for more info?

    Thanks
    -Raúl
    Tuesday, June 02, 2009 11:32 PM
  • I'm having an identical issue with a Server 2008R2 installation. 

    My server was just setup as a Domain Controller, and I successfully promoted it.  I had recently installed AV and VNC, and then I went into Roles and tried to add the DHCP server role to this server.  The wizard finished, but at the end it said that it had failed to install.

    Now when I go into Server Manager, I have an error at the bottom that the refresh failed.  It's the exact same as Auriion's above, HRESULT: 0x800736B3.

    For me, there is no DHCP service installed.  In the Event log, I'm seeing about 1000 Windows Error Reporting Event 1001's in the Application Event log.

    Fault bucket , type 0
    Event Name: WindowsWcpOtherFailure3
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: 6.1.7600
    P2: base\wcp\componentstore\csd_core.cpp
    P3: CCSDirect::GetDeploymentClosureStatus
    P4: 616
    P5: c0150004
    P6: 0x4ca3cdb2
    P7:
    P8:
    P9:
    P10:

    Attached files:
    C:\Windows\Logs\CBS\CBS.log
    C:\Windows\servicing\Sessions\Sessions.xml
    C:\Windows\winsxs\poqexec.log
    C:\Windows\System32\LogFiles\Scm\SCM.EVM
    C:\Windows\Logs\CBS\FilterList.log

    These files may be available here:


    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 6ea93d3c-5214-11df-b755-3e827d9ff860
    Report Status: 0

    Tuesday, April 27, 2010 5:37 PM
  • Hi,
     
    Looking at the error code:
     
    # as an HRESULT: Severity: FAILURE (1), Facility: 0x7, Code 0x36b3
    # for hex 0x36b3 / decimal 14003 :
    SQL_14003_severity_16 sql_err
    # You must supply a publication name.
    ERROR_SXS_ASSEMBLY_NOT_FOUND winerror.h
    # The referenced assembly is not installed on your system.
    # 2 matches found for "0x800736B3"
     
    It would seem that there is a problem with the installation of the OS.
    Is it possible to reinstall the OS, update, and then try installing roles?
     
     

    -- Mike Burr
    Saturday, June 19, 2010 7:08 PM