none
This operation has been cancelled due to restrictions in effect on this computer. Please contact your systems administrator

    Question

  • Here is our environment:  Windows Server 2008 x86 SP2 Terminal Server running Citrix XenApp5.0 with Office 2007 installed.  We have a Group Policy to restrict users from access the server's C:\ drive.  When our users open or save a Microsoft Word, Excel, etc. document they are presented with the following error.  "This operation has been cancelled due to restrictions in effect on this computer.  Please contact your systems administrator."  When our users click on the OK button it allows them to open or save the document.    If I remove the restriction to C:\ from our Group Policy, then everything is working fine.  Please tell me how to fix this problem. Thanks.
    Wednesday, April 20, 2011 5:55 PM

Answers

  • Hi,

    This is by design. Please refer to the following article.

    Error: This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator
    http://support.citrix.com/article/CTX123187

    Brent
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, April 25, 2011 1:54 AM
    Moderator

All replies

  • Hi,

    This is by design. Please refer to the following article.

    Error: This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator
    http://support.citrix.com/article/CTX123187

    Brent
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, April 25, 2011 1:54 AM
    Moderator
  • Hi richard,

    I think the problem you have it is because by default, the working directory of MS Office is on C: drive. Change it to the user's home folder and you should not have the message again.


    " Never panic before reboot ! "

    Tuesday, April 26, 2011 12:43 AM
  • Hi,

     

    I have the same problem with MS excel 2010 and Citrix xenapp 6, i have applied what are mentionned on this article http://support.citrix.com/article/CTX123187, but not working. 

    Any idee ?

     

     


    frederic
    Thursday, September 01, 2011 1:04 PM
  • With Office, I got rid of the same error by adding Documents in Group Policy to:  Windows Components/Windows Explorer/Common Open File Dialog but I´m still fighting with the Internet Explorer occuring the same error when trying to download something.

    • Proposed as answer by CuiZinieR Thursday, February 20, 2014 5:14 AM
    Wednesday, February 22, 2012 12:29 PM
  • I'm not sure this is entirely the fix you are looking for but it might help someone:

    "This operation has been cancelled due to restrictions in effect on this computer"

    • Proposed as answer by TheXternal Monday, June 11, 2012 3:31 PM
    Monday, June 11, 2012 3:31 PM
  • I am having the same issue as I also prevent users from seeing the C: drive by setting the NoDriveView and NoDrive registry keys. For me though, opening/saving a file directly in Word 2007 is fine but when I open a Word 2007 attachment  from Outlook and try and save it, then I get the message. I assume this is because the attachment has been saved off to the users temporary files location. I can of course simply hit 'Ok' and save to wherever but it's a real annoyance for ordinary users as it makes them think there is an issue. This is an MS issue not a Citrix one. Has anyone been able to workaround it or or implement view restrictions on the C: drive in another manner?
    • Edited by shocko Wednesday, December 18, 2013 1:05 PM
    Wednesday, December 18, 2013 1:05 PM
  • I opened a case with MS support and they are working on a work around. I'll post back here if I get one ;)
    Thursday, February 20, 2014 7:53 AM
  • I opened a case with MS support and they are working on a work around. I'll post back here if I get one ;)

    Did you ever solve this problem?

    We are still having this issue with our users and we don't want to disable the policy because that would give savy users the chance to browse through the system drive.

    Tuesday, March 25, 2014 2:04 PM
  • Hi Jeffery,

    Unfortunately, I could not work around this and MS said it was by design. I even tried some clever stuff with symbolic link s but to no avail. I simply ended up informing my users to ignore the message and continue. i don't want anyone to be able to browse the C: drive so I'm leaving the NoViewOnDrives registry key in place. However, there is one possible workaround but for me , it didn't suit:

    Also, I'd recommend forcing all attachments to open in read-only mode http://support.microsoft.com/kb/953621 

    Annoying but you can't have everything i guess :(


    • Edited by shocko Tuesday, March 25, 2014 5:07 PM
    Tuesday, March 25, 2014 5:06 PM