locked
Windows Server 2008 Network speed is too slow

    Question

  • We have a network of 11 computers that are using Visa Business SP1 as the operating system and the main server is running Windows Server 2008 SP1. The network is running using gigabit switch and are suing cat 5e cables to connect in between. All the desktop computers have a Intel Quad core processor and they all have gigabit NIC cards. The server also is running on a quad core processor and it has a gigabit NIC card.

    The network speed is very slow on the system when we try to transfer files to the server and when we transfer files from the server to domain computers it is faster than before but still very slow. When I try to transfer files with the domain computers the speed is faster about twice the speed of server -> client speed.

    I have done test and I am getting the following speeds

    Client -> Server  = 71Mbps
    Server -> Client = 200Mbps
    Client -> Client = 390Mbps

    Any help relating to this problem is greatly appreciated.
    Wednesday, June 17, 2009 12:18 AM

All replies

  • Hi NiroshanaS,

    What kind of disk configuration do you have in your server?

    Wednesday, June 17, 2009 11:26 AM
  • Hi! aggrovendor,

    Well the server main operating system runs on raid 1 array of two 80 GB drives. And for the file storage I got 3 500GB drives running on Raid 5 array.

    Thanks

    Niro
    Wednesday, June 17, 2009 9:32 PM
  • Please disable any Firewall on the server and check how it works and also follow these links if possible.

    Also try using Robocopy and see what happens 

    se the Robocopy utility that is included with Windows Vista to copy the files. For example, type the following command at a command prompt, and then press ENTER:

    Robocopy source_path destination_path file_name

    http://www.mydigitallife.info/2007/05/07/robocopy-syntax-command-line-switches-and-examples/


    Thanks


    http://technetfaqs.wordpress.com
    Thursday, June 18, 2009 7:06 AM
  • How is your server NIC configured ... link speed is 1Gbps not 100mbps?
    Are the clients using the same switch... e.g. what happens if you plug a client directly into the same server switch backplane? Does the performance stay the same?
    Are you teaming the NIC?

    Regards,
    Mylo
    Thursday, June 18, 2009 11:18 AM
  • Hi Syed,

    I have tried as you said but still the same problem. Thanks for the info.

    When I used robocopy the transfer speed from client -> server was 20Mega Bytes per second. Bit improved but if you do normal network access the speed is still the same.


    Thanks

    Niro
    Friday, June 19, 2009 3:56 AM
  • Hi! Mylo,

    I had the NIC speed set at Auto and then I change it to "1Gbps full Auto" . Once I did that there was issue in the network sharing center it was showing that the server has a limited connectivity even though the network is working. There was a ! icon on the link and X on the internet. So I had to change back to Auto again.

    The clients use the same network switch (linksys SRW2024P). The ports are set at Auto negotiation on the switch with 1000gbps full duplex as the only selection. There is no other option the switch it self to make it to 1000gbps. I have not tried plugging a client to the server directly.

    The NIC is not on teaming.


    Thanks for all the info.

    Niro
    Friday, June 19, 2009 4:12 AM
  • Niro,

    If you have some planned downtime or outside of work hours, try plugging a client directly into the server and use a crossover cable and see whether the performance issue continues. We need to eliminate the switch from the equation/negotiation issues.

    Regards,
    Mylo
    Friday, June 19, 2009 8:59 PM
  • Mylo,

    I did tried using cross over cable and still the same speed. But what I did was I did a firmware update on the HP Server that included the NIC driver update as well. It seems the speed have improved. But not sure until I check it out with the full capacity of the workstations.

    We are using ML350 G5 server. It seems that the driver that comes for the NIC is from Broadcom even thou it is made by HP. I found few web info about the drives from broadcom saying not compatible and causing issues. So that is why I contacted HP to find out if they have any new driver updates. Anyhow once I update the server it seems to run faster.

    But if you have any other suggestions please let me know. And I got a quick question for you as well even thou it is a gigabit network how fast the network actually should work when you have 11 workstations and 2 servers. Basically 13 stations.

    Thanks for all the info.

    Niro
    Sunday, June 21, 2009 10:30 PM
  • Yes you are right I have seen lot of broadcom Nic having the same issues. Kepp posting the issue if its solved or not we are aalways here to help you.

    Thanks


    http://technetfaqs.wordpress.com
    Monday, June 22, 2009 7:26 AM
  • Tcp offload may be causing the problem. Normally OS leaves CRC checks to NIC`s hardware but this may mostly lead to speed loss. Your NIC driver may not work properly with this setting so I can suggest to get the latest drivers for your NIC. Also try to check if this settin is running on your server by this command:

    netsh int tcp show global

    If you want to enable or disable this command

     Enable:  netsh int tcp set global chimney=enabled
      Disable: netsh int tcp set global chimney=disabled

    For more information you can refer to:

    http://www.alacritech.com/Support/FAQs/DisableOffload.aspx


    Ozan Veranyurt MCITP-MCT
    Wednesday, June 24, 2009 2:28 AM
  • Ozan,

    It is actually disabled. And I have the latest drivers for the NIC. Do you think I need to enable it?

    Thanks

    Niro
    Wednesday, June 24, 2009 10:22 PM
  • ahm no. Actually that feature came with server 2008 to increase performance but mostly created some speed loss. in the end maybe trying another brand but broadcom is worth giving a try:)
    Ozan Veranyurt MCITP-MCT
    Saturday, June 27, 2009 3:33 AM
  • Syed, Mylo & Ozan,

    I have done updating the drivers for the NIC on the server 2008 and have tried the network to see how it goes. But by the looks of it the network speed is still the same no change. The tcp global settings on the server is bellow.

    TCP Global Parameters
    ----------------------------------------------
    Receive-Side Scaling State          : enabled
    Chimney Offload State               : disabled
    Receive Window Auto-Tuning Level    : normal
    Add-On Congestion Control Provider  : ctcp
    ECN Capability                      : disabled
    RFC 1323 Timestamps                 : disabled


    And here is the TCP settings on the vista computers.

    TCP Global Parameters
    ----------------------------------------------
    Receive-Side Scaling State          : disabled
    Chimney Offload State               : disabled
    Receive Window Auto-Tuning Level    : highlyrestricted
    Add-On Congestion Control Provider  : none
    ECN Capability                      : disabled
    RFC 1323 Timestamps                 : disabled
    ** The above autotuninglevel setting is the result of Windows Scaling heuristics
    overriding any local/policy configuration.


    Is there a group policy setting I need to change? Or do I have to setup QOS on the network switch?  Any suggestions is greatly appreciated. Thanks

    Niro

    Tuesday, July 07, 2009 12:32 AM
  • Niro,

    Have you tried disabling Receive-Side Scaling on the Windows Server as well?

    Regards,

    Mylo

    Friday, July 10, 2009 9:08 PM
  • Mylo,

    I did disabled the RSS on server but no hope it is still to slow. I even shutdown the server 2003 and just have running server 2008 and vista client to see if the server 2003 is causing a problem. But no change at all. Everything is still the same.

    I think it is a issue Microsoft have to have a look seriously. I can't call support because they don't want to help me unless I pay them. Which is crazy. This a problem with Microsoft software.

    Any ideas please do let me know. Thanks.

    Niro
    Sunday, July 19, 2009 10:29 PM
  • If i see your analysis, when destination is client, file transfer is fast and when your destination is server file transfer is slow.

    If you do file transfer to DC, you will find file transfer is further slow, reason for this is server OS have much more security implemented compare to client OS, apart from that you use RAID on server OS, which mean data are written mulitple times instead single time as with client.

    File transfer is communication between two machines, third machine cannot come into picture except flooding switch with lot of packets.

    If you take example of server 2003 and XP, i am sure that you will find similar behavior.

    Recommendation - check if you have firewall or antivirus app (windows and third party) which inspect incoming and outgoing packets or IPSec service which used to encrypt packet and decrypt packet (adds time for processing).

    Hope this helps.
    Tuesday, July 21, 2009 8:11 PM
  • In my instance to this situation it was Symantec Endpoint. The network features installed by default were causing the problem.

    Thank you
    David
    • Proposed as answer by tvppd Monday, November 23, 2009 3:23 PM
    Tuesday, October 13, 2009 1:28 PM