none
Group Policy drive mappings not applied on Terminal Server 2003

    Question

  • Hello,

    I am encountering an issue where user drive mappings are not applied when logging on to Windows Terminal Server 2003 R2 SP2.

     

    The drives are mapped via User Configuration, Preferences, Windows Settings, Drive Maps in a GPO attached to OU in which user accounts reside.

     

    When a user logs on to the Terminal Server, these drives are not mapped, however a user can manually map a drive via Tools, Map Network Drive. Their home folder defined in Profile tab is mapped OK as well.

     

    I should add that the very same GPO applies and drives map when the same user logs on their Windows 7 PC and also works when the user logs on to another Terminal Server or RDS server rather running Windows Server 2008 R2.

     

    The 2003 Server, has the following items configured in Local Computer Policy.

    Computer Configuration, Administrative Templates, System, User Profiles;

    Enable "Only allow local user profiles"
    Enable "Prevent Roaming Profile changes from propagating to the server"

     

    Our users now have roaming profiles turned off anyway so this is a legacy setting, but I wonder if it may be related?

     

    What areas can I look at to investigate as to why the mappings are not established on the 2003 server?

     

    Regards,

    Wednesday, July 13, 2011 11:15 PM

Answers

  • Hello,

     

    Thank you for your response, I did not configure loopback processing, however I found the cause and solution of my problem which I will share with all who may come across it as well.

     

    It escaped my attention that the GPO in which the drive mappings were configured was established on a 2008 domain controller.

     

    Our 2003 Terminal Server did not have Group Policy Preference Client Side Extensions for Windows Server 2003 (KB943729) installed.

     

    Once I installed these client side extensions, drives mapped fine for our users.

     

    Thank you

    Thursday, July 14, 2011 6:53 AM

All replies

  • Hello,

    did you configure loopback processing for the Terminal servers?

    http://support.microsoft.com/kb/231287

    http://technet.microsoft.com/en-us/library/cc978513.aspx


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Thursday, July 14, 2011 5:50 AM
  • Hello,

     

    Thank you for your response, I did not configure loopback processing, however I found the cause and solution of my problem which I will share with all who may come across it as well.

     

    It escaped my attention that the GPO in which the drive mappings were configured was established on a 2008 domain controller.

     

    Our 2003 Terminal Server did not have Group Policy Preference Client Side Extensions for Windows Server 2003 (KB943729) installed.

     

    Once I installed these client side extensions, drives mapped fine for our users.

     

    Thank you

    Thursday, July 14, 2011 6:53 AM
  • Hi,

     

    Thank you for your reply and the detailed additional feedback on how you were successful in resolving this issue. This solution will benefit many other users who access this forum.

     

    If you have any other questions or concerns, please do not hesitate to post in our forum. It is always our pleasure to be of assistance.

     

    Have a nice day!

     

    Regards,

    Cecilia Zhou

    --------------------------------------------------------------------------------

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

     

     

     

    Monday, July 18, 2011 9:06 AM
  • Thank you so much for this solution. I have an older Citrix Presentation Server farm that this was occurring on but users didn't notice to well after implementing Drive Mapping preferences. I can't imagine the time you saved me from diagnosing this!
    Wednesday, July 18, 2012 3:04 PM