none
wuauserv and svchost taking 100% cpu in sbs2008

    Question

  • Hi All,
    I'm running windows SBS 2008 SP1 version 6.0 which was running fine until a couple of days ago. Now,  svchost kicks in and takes up 100% of the cpu and the service that's using it is wuauserv. If I issue "net stop wuauserv" at the command prompt the service stopps but kicks back in after about an hour.  I've had to disable the winsows update service to keep the server running.

    I've only found updates relating to vista and server 2003 talking about updating wuauserv.dll etc. but I have wuaueng.dll installed.

    Any pointers to a fix for this??

    Thanks in advance
    Derek. J.
    Sunday, April 19, 2009 10:19 AM

Answers

  • This is documented in a rapid-release KB article, and the SBS2008 blog, as well as other threads of this forum. It was an issue caused by a backend defect at M.U. and should be self-resolving as of your WSUS Server synchronization after 9am Monday.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    Wednesday, April 29, 2009 2:47 AM

All replies

  • See if you have a registry key
    "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\OfflineDetectionPending" with a value of 1, if so,
    STOP & disable Windows Update
    Delete the key
    enable & START Windows Update
    Tuesday, April 28, 2009 10:50 PM
  • This is documented in a rapid-release KB article, and the SBS2008 blog, as well as other threads of this forum. It was an issue caused by a backend defect at M.U. and should be self-resolving as of your WSUS Server synchronization after 9am Monday.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    Wednesday, April 29, 2009 2:47 AM