none
Server 2008 R2 Indexing and Adding Libraries to Windows 7.

    Question

  • I’m having trouble adding network folders to windows 7 libraries (w/o making it available offline), the error says it can’t be added b/c the location it’s not indexed but that doesn’t make any sense b/c I have windows search service installed on the server (windows 2008 R2) and the share folder is indexed.

     

    I followed this steps but it keep saying the same thing even thought all the 12.000 documents in that share drive i need are indexed. Any ideas? Thank you!!

    1) On Windows 2008 R2 server, do NOT install the indexing service!  It's a Server 2003 version that is not recognized by Windows 7 clients.  Instead, install the "Windows Search Service" - you can only pick one or the other so make sure you select Windows Search Service - it's one of the roles under File Services.

    2) The install wizard should ask you which folders/drives you want to index - choose any data drive (recommend NOT selecting the system/boot drives) that contains files you want to include in your Windows 7 library on the workstations.  If you missed this during the install, you can go back to CONTROL PANEL and type "indexing" into the search box to find the indexing options and customize it there (exactly the same way you do with Windows 7).

    3) As soon as the drives have been added, you can now include any locations on those drives in your Windows 7 workstation libraries (even before the server finishes indexing).  You will no longer get any warnings that "some locations are not indexed"...everything works as it should!

    Wednesday, July 21, 2010 5:58 PM

Answers

  • I got it to work!

    Follow this steps and make sure the SYSTEM account has full access to the folder you are trying to index, it will start working as soon server 2008 is done indexing that folder and you will be able to add the network folder to windows 7 libraries.

    1) On Windows 2008 R2 server, do NOT install the indexing service!  It's a Server 2003 version that is not recognized by Windows 7 clients.  Instead, install the "Windows Search Service" - you can only pick one or the other so make sure you select Windows Search Service - it's one of the roles under File Services.

    2) The install wizard should ask you which folders/drives you want to index - choose any data drive (recommend NOT selecting the system/boot drives) that contains files you want to include in your Windows 7 library on the workstations.  If you missed this during the install, you can go back to CONTROL PANEL and type "indexing" into the search box to find the indexing options and customize it there (exactly the same way you do with Windows 7).

    3) As soon as the drives have been added, you can now include any locations on those drives in your Windows 7 workstation libraries (even before the server finishes indexing).  You will no longer get any warnings that "some locations are not indexed"...everything works as it should!

    • Marked as answer by Chamita Monday, August 02, 2010 8:07 PM
    Monday, August 02, 2010 8:06 PM

All replies

  • I've got the same problem (share on windows server 2008 r2 with nearly 30000 files). As a test I create a folder on the server 2008 r2 with nearly 100 files - no problems to add the share to a windows 7 library. It seems there is a max size of the indexed remote folder. Anyone has more information about this topic?
    Sunday, July 25, 2010 11:02 AM
  • Hi,

    If you still get the "not indexed" error, please try to disable Firewall on both side to test. Is there any progress? Or as RWendorf suggested, try to create a small shared folder to test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, July 27, 2010 6:18 AM
    Moderator
  • I'm running into the same issue, had had posted about it here:

     

    http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/5f4bc39d-934b-465f-b1c2-1a54bbde1c0d/

     

    So far, no resolution.  In my case, the firewall is off on both computers.  I just tried a smaller folder, and it did add to the library without issue.  

     

    If this works for small shares and not larger shares, I assume there is some bug in windows 7 that is causing the trouble.  Do you have the ability to forward this on to the right people Mervyn, or is there someone else I should contact to report the issue?

    Tuesday, July 27, 2010 1:09 PM
  • Hmm your experciences contradicts what Microsoft is saying they support ....

    Querying Remotely

    Windows can query a remote machine's index for content from shared folders if the querying user has access.
    Windows 7 has remote querying enabled by default. The remote machine must be shared and indexed.

    See the Supported Storage Locations table for details on supported and unsupported locations for querying remotely. 
    The same restrictions that apply to adding storage locations to libraries in Windows 7 also apply to querying a remote computer’s index.

    Supported Storage Locations

    • Fixed local volumes (NTFS/FAT)
    • Shares that are indexed (departmental servers*, Windows 7 home PCs, Vista home PCs)
    • Shares that are available offline (redirected My Documents, Client Side Cache)

    For shares that are indexed on a departmental server, Windows Search works well in workgroups or on a domain server that has similar characteristics to a workgroup server. For example, Windows Search works well on a single share departmental server with the following characteristics:

    • Expected maximum load is four concurrent query requests.
    • Expected indexing corpus is a maximum of one million documents
    • Users directly access the server. That is, the server is not made available through Distributed File System (DFS)
    • Users are not redirected to another server in case of failure. That is, server clusters are not used.

    As far as I know Windows Search services is based on it 's ancestor "Microsoft Index Server" which had no limitations towards number of documents or catalog size.

    What happens if you add more files to the test share with a 100 files ?

    Raymond

     

    Tuesday, July 27, 2010 4:08 PM
  • Hi,

    There is may be a bug, but it shouldn’t relate to the number of files/folders. On my test system, I can add some folders, but cannot add one folder even if I moved all files to other folder, the same error still occur.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, July 29, 2010 7:50 AM
    Moderator
  • I got it to work!

    Follow this steps and make sure the SYSTEM account has full access to the folder you are trying to index, it will start working as soon server 2008 is done indexing that folder and you will be able to add the network folder to windows 7 libraries.

    1) On Windows 2008 R2 server, do NOT install the indexing service!  It's a Server 2003 version that is not recognized by Windows 7 clients.  Instead, install the "Windows Search Service" - you can only pick one or the other so make sure you select Windows Search Service - it's one of the roles under File Services.

    2) The install wizard should ask you which folders/drives you want to index - choose any data drive (recommend NOT selecting the system/boot drives) that contains files you want to include in your Windows 7 library on the workstations.  If you missed this during the install, you can go back to CONTROL PANEL and type "indexing" into the search box to find the indexing options and customize it there (exactly the same way you do with Windows 7).

    3) As soon as the drives have been added, you can now include any locations on those drives in your Windows 7 workstation libraries (even before the server finishes indexing).  You will no longer get any warnings that "some locations are not indexed"...everything works as it should!

    • Marked as answer by Chamita Monday, August 02, 2010 8:07 PM
    Monday, August 02, 2010 8:06 PM
  • Hi - just thought I'd add a bit more to this:

    When you have followed the above instructions, if you had already added the indexed folders to the libraries on your Windows 7 client before you created the index then you must remove them from the libraries and add them in again!

    Windows 7 will then pick up the fact that they are indexed - otherwise, the "some locations are not indexed" message will not go away. 

    Thanks guys, your posts were helpful in getting this sorted and it worked once I removed and re-added the locations.


    • Edited by HadjiMurad Saturday, January 21, 2012 11:06 AM
    Saturday, January 21, 2012 11:05 AM
  • Some further information; adding folders to the windows 7 libraries only works when using Netbios rather than FQDN servernames in the UNC paths.

    So that means:
    Remote index do work with this path: \\DC\FolderLocation
    But they do not if this UNC path is used: \\DC.domain.local\FolderLocation

    Furthermore, if i browse to the FQDN path in explorer and issue a search command from the top-richt search box, then the index on the server is not queried and search is slow. Search commands from the windows 7 client using the index on the server only work if i use the \\Servername\ format.

    • Edited by JasperE Saturday, February 04, 2012 1:19 PM
    • Proposed as answer by Daniel Albrecht Tuesday, November 20, 2012 2:46 PM
    Saturday, February 04, 2012 9:11 AM
  • Has anyone found a solution to the NetBIOS only issue? We have a file server that is referenced in group policy preferences and login scripts using a CNAME. As such, drives are mapped using:

    \\CNAME\\Share$ 

    CNAME is not the NetBIOS/Computer name. We do this so we can easily upgrade or change our files servers by repointing DNS.

    So basically now, I have a fully indexed file server and the users cannot add any folders to their Libraries or leverage indexing for searches.

    Shaun

    • Proposed as answer by urundaburunda Tuesday, April 17, 2012 10:21 PM
    Wednesday, February 08, 2012 7:42 PM
  • Has anyone found a solution to the NetBIOS only issue? We have a file server that is referenced in group policy preferences and login scripts using a CNAME.

    I'd like to know too!

    We use DFS and access the shares using \\domain.local\dfs\files etc.

    cheers

    Tuesday, November 20, 2012 2:49 PM
  • Has anyone found a solution to the NetBIOS only issue? We have a file server that is referenced in group policy preferences and login scripts using a CNAME. As such, drives are mapped using:

    \\CNAME\\Share$ 

    CNAME is not the NetBIOS/Computer name. We do this so we can easily upgrade or change our files servers by repointing DNS.

    So basically now, I have a fully indexed file server and the users cannot add any folders to their Libraries or leverage indexing for searches.

    Shaun

    I've been trying to add files from a share on another server to a local index on Windows 8 and kept running into this issue. After following all the instructions on getting the Windows Search Service installed and indexing that hard drive, I tried to add a location from \\Server\E$ (root of the hard drive) to no avail. Then I created a share to one of the folders in the same hard drive, and adding that to the Libraries finally worked! Perhaps there is an issue with adding hidden shares or shares to the root of a hard drive.
    Tuesday, January 15, 2013 8:51 AM
  • I found this discussion while creating a solution to add indexed network drives to your library.

    Maybe the write up helps other users having the same issue:
    http://www.cloudtec.ch/blog/tech/add-search-indexed-network-share-windows-library.html

    Regards

    Chris

    Sunday, May 19, 2013 12:13 PM