none
Certificate problems: The remote certificate is invalid according to the validation procedure.

    General discussion

  • We have a vendor who has provide a .NET application on a public web server. The error in the subject pops up during checkout, and it's related to a secure smtp connection. We don't manage the server, and it's actually a shared/hosted server that several companies are using, so we'll never have the correct name even if we get the intermediate and root certificates installed. 

    I made a change to what I recall being the web.config file a couple months ago, but after updates last night, the problem is back. I can't seem to track down the setting I added to ignore certificates. 

    Is there a way to permanently stop this error? Can anyone point me in the direction of which file needs to be modified and with what settings? I've been googling for a couple hours, and I haven't found what I'm looking for.

    Thanks

    Thursday, April 25, 2013 6:54 PM

All replies

  • I just inserted the following into the web.config file:

    <system.net> 
             <settings> 
                   <servicePointManager checkCertificateName="false" checkCertificateRevocationList="false"/> 
               </settings> 
    </system.net>

    And this fixes the problem; however, I know in a future update, this will be broken again, so if anyone knows of a permanent solution, I'd sure like to know what it is. Thanks again.

    Thursday, April 25, 2013 7:21 PM
  • Hello,

    for programming questions better ask in the appropriate forum in http://social.msdn.microsoft.com/Forums/en-US/categories


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Friday, April 26, 2013 7:45 AM