none
Mapped Drive - Application Not Found

    Question

  • Dear MSFT Team & Fellow Posters:

     

    I'm using Windows 2008 RTM with all the latest updates.  I've mapped 3 drives using the Windows GUI (i.e. right-click My Computer, Created Mapped Drive, etc..).  Here's my delima:

     

    Two of the mapped driver work fine.  The third mapped drive says:  "T:\ Application Not Found" when I double-click it to open the drive.  if I right-click it and select explore it opens fine.  If I go to START | RUN and type T:\ and click OK it works fine.  Only when I double-click it does it give me the error.

     

    There are NO file in the root of T: but there are folders.  I checked hidden files (both user and system) and there is nothing there.  I searched the T: location for any autorun.inf files and found none.  What could be causing this!?

     

    Any help is MUCH appreciated!

     

    Sincerely,

     

    Joshua

    Monday, March 24, 2008 8:40 PM

Answers

  •  

    Hi Joshua,

     

    I don't think it is a bug. Try to check related registry in your system.

     

    1.    Click Start, point to Run, type regedit, and then click OK.

     

    2.    In Registry Editor, locate the following registry sub-key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

     

    3.    Locate the mapped drive mount point. For example, ##Server_Name#Share_Name (Replace the Server_Name placeholder with the name of the server that hosts the mapped network drive. Replace the Share_Name placeholder with the name of the mapped network drive).

     

    4.    Check whether there is sub-key named shell under '##Server_Name#Share_Name'. If yes, delete it.

     

    If you are not quite sure about it, try to delete the whole '##Server_Name#Share_Name' key of the mapped drive T, then check how it works.

     

     

     

     

     

    Wednesday, March 26, 2008 11:52 AM
    Moderator

All replies

  •  

    Hello,

     

    For there is no autorun files existing, we can confirm that this is issue on the Windows Server 2008.

     

    To narrow down the issue, check how it works if you map the same source (driver T:\) to a new drive letter.

     

    You may also use this tool to fix.

     

    FixDrive ("Open With" dialog appears when double clicking on a mapped network drive in My Computer)

    http://www.winhelponline.com/articles/223/1/Open-With-dialog-appears-when-double-clicking-on-a-mapped-network-drive-in-My-Computer.html

     

    It will enumerate keys under 'HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\##servername#sharename\' and delete improper shell sub keys.

     

    -------------------------

    This response contains a reference to a third party World Wide Web site. Microsoft can make no representation concerning the content of these sites. Microsoft is providing this information only as a convenience to you: this is to inform you that Microsoft has not tested any software or information found on these sites and therefore cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software on the Internet.

    -------------------------

     

    Hope this helps.

    Tuesday, March 25, 2008 10:43 AM
    Moderator
  • Miles,

     

    Thank you for the information.  The FixDrive application didn't resolve the issue.  Do you have an ETA of when this bug will be fixed?  Is there a way I can track this issue specifically?  Thanks.

     

    - Joshua

    Tuesday, March 25, 2008 1:42 PM
  •  

    Hi Joshua,

     

    I don't think it is a bug. Try to check related registry in your system.

     

    1.    Click Start, point to Run, type regedit, and then click OK.

     

    2.    In Registry Editor, locate the following registry sub-key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

     

    3.    Locate the mapped drive mount point. For example, ##Server_Name#Share_Name (Replace the Server_Name placeholder with the name of the server that hosts the mapped network drive. Replace the Share_Name placeholder with the name of the mapped network drive).

     

    4.    Check whether there is sub-key named shell under '##Server_Name#Share_Name'. If yes, delete it.

     

    If you are not quite sure about it, try to delete the whole '##Server_Name#Share_Name' key of the mapped drive T, then check how it works.

     

     

     

     

     

    Wednesday, March 26, 2008 11:52 AM
    Moderator
  • Miles:

     

    You rock!  I deleted that key and now my mapped drive is working properly!  How it got messed up is beyond me.  But it's working now and I'm happy.   Thanks again!

    Wednesday, March 26, 2008 1:57 PM