none
Certificate Error When Using Remote App

    Question

  • I'm doing an emergency deployment of a program using RemoteApp and I'm getting a certificate error on the two WinXP SP3 computers at the remote site.  I can login to the farm through Remote Desktop fine, but as soon as I launch RemoteApp I get a yellow certificate error. 

    The same icon works on a local test system fine and I have it working at another remote site.  The error in more detail states:

    Your remote desktop connection failed because the remote computer cannot be authenticated

    The remote computer could not be authenticated due to problems with its security certificate.  It may be unsafe to proceed.

    Name mismatch

    Requested remote computer:
    <farm.domain.local>

    Name in the certificate from the remote computer
    <servername.domain.local>

    Certificate errors

    The following errors were encountered while validating the remote computer's certificate:

    The server name on the certificate is incorrect.


    And it would not allow me to proceed.  The problem is that I'm not using certificates at all and no certificate warning comes up at my other locations or on the test station.

    Right now, I'm installing a slew of updates.  Could this be the problem?

    According to MS, all RemoteApp requires is Windows XP SP3 and I believe RDC 6.
    Thursday, July 30, 2009 3:52 PM

Answers

  • Hi,

    Can you please check the "authentication level" rdp file property in remote apps. Please add "authentication level:i:2" to custom rdp file settings in Remote App manager.


    Thanks.
    Regards, Rajesh.
    Thursday, July 30, 2009 4:09 PM

All replies

  • Hi,

    Can you please check the "authentication level" rdp file property in remote apps. Please add "authentication level:i:2" to custom rdp file settings in Remote App manager.


    Thanks.
    Regards, Rajesh.
    Thursday, July 30, 2009 4:09 PM
  • Where can I find "authentication level"?
    • Proposed as answer by denwarf Wednesday, November 21, 2012 11:33 PM
    Thursday, July 30, 2009 4:37 PM
  • It is the rdp file property. you have to add the string authentication level:i:2"  to custom rdp file settings in Remote App manager.


    Regards, Rajesh.
    Thursday, July 30, 2009 4:40 PM
  • Okay this worked.  Thanks.  Forgot I had to re-deploy the installation file once I made changes.  Duh!
    Thursday, July 30, 2009 4:57 PM
  • Hi,
    thanks for useful ideas.
    I have similar problem,but the scanario is differ.
    I have One RDS setup with the following details.
    One Server for Hyperv and Holding RDVH role
    One server for AD and certificate server role
    One server for RDS with RDSH role and Webaccess role running.

    Now my problems are
    1)I am unable to get the default background in Windows 7 VM which are assigned as Perssonal and Pooled desktops
    2)I am able to access the applications but I am not able to publish the applications in "RemoteApps and connections" Panel in  win7 Control panel
    3)How could i access the applications.?Let say I have one doc file to open this we need MSword Software with out thatwe can't,I am not going to install the application on the local system,so how could i set the default word software option to open the document?
    4)Also how to remove the error while accessing the internet webpage for RDwebaccess
    "Security certificate is inavlid error whil access the RDWebpage from IE7&IE8??

    Please help...


    Thanks,
    Crew.

    • Proposed as answer by denwarf Wednesday, November 21, 2012 11:36 PM
    Monday, January 04, 2010 8:18 AM
  • This did not work for me.  I had to set the authentication level to 0.  As far as I can tell that is what the level was set to before I installed SP2 at which point the default was changed to level 1.  

    Wednesday, January 20, 2010 4:58 PM
  • Hi Rajesh,

     

    I connecting from my home laptop(Windows server 2008 R2)  to my office desktop running Windows 7 enterprise. I'm also having the same issue. I've added the authentication level:i:2  as you mentioned. But still having the same certificate issue.


    Thanks,

    Kannan

    Monday, May 10, 2010 8:26 AM
  • I am having the same problem. I have Server 2012 Standard setup. RDP works fine. When I go in to RemoteApp and Desktops and enter the web address to our RDS server it comes back with this error:

    There is a problem with this connection's security certificate

    The remote computer cannot be authenticated due to problems with its security certificate.

    Security certificate problems might indicate an attempt to fool you or intercept any data you send to the remote computer.

    Windows cannot continue setting up this connection. Contact your workplace administrator for assistance.

    I checked the Authentication Level in the registry and it is already set to 2. Any ideas?

    Thanks,

    Buddy Farr

    Tuesday, August 06, 2013 4:07 PM
  • The server name on the certificate is incorrect.

    At the windows security authentication window make sure you enter the server name (hostname) instead of trying with the server ip address.

    Thursday, February 06, 2014 3:46 PM
  • I could not find the custom rdp file settings in Remote App manager in rdp file property.

    please guide the path step by step to add this string.


    Thursday, February 06, 2014 3:49 PM