none
Network access to an Hyper-V VM configured with an external virtual switch

    Question

  • Hello,

    I have a machine windows server 2012 (SERVER1) and installed a VM (VM1) with configuration external. VM1 is running a windows server 2012 instance.

    In the VM1, I can access to the network, can ping the host SERVER1 or other machine A (same network). All is correct from the VM1 to external.

    My problem is that from external (other machines A or from the host SERVER1), I can't ping VM1 or see VM1 shares.

    What is missing? My VM1 was configured with external virtual switch and all default settings. 

    Do I need to configure something else in the windows firewall or configure something at network layer?

    Sorry for this simple question, I'm new in Hyper-V.

    Thanks for your help

    Tuesday, November 20, 2012 5:26 PM

Answers

  • By default, Windows Server 2012 (and other Windows operating systems) install with the firewall enabled to block ICMP (ping) requests.  You have to open the firewall ports to allow it.  You say it has shares, that should have opened the correct ports, but, just to make sure, execute the following PowerShell commands on VM1 to open the ports for ping.

    #  Allow ping requests in
    Set-NetFirewallRule –Name “FPS-ICMP4-ERQ-In” –Enabled True
    
    #  Allow ping requests out
    Set-NetFirewallRule –Name “FPS-ICMP4-ERQ-Out” –Enabled True
    


    tim

    Tuesday, November 20, 2012 6:14 PM

All replies

  • By default, Windows Server 2012 (and other Windows operating systems) install with the firewall enabled to block ICMP (ping) requests.  You have to open the firewall ports to allow it.  You say it has shares, that should have opened the correct ports, but, just to make sure, execute the following PowerShell commands on VM1 to open the ports for ping.

    #  Allow ping requests in
    Set-NetFirewallRule –Name “FPS-ICMP4-ERQ-In” –Enabled True
    
    #  Allow ping requests out
    Set-NetFirewallRule –Name “FPS-ICMP4-ERQ-Out” –Enabled True
    


    tim

    Tuesday, November 20, 2012 6:14 PM
  • Thanks for your help. This is working with your command. 
    Tuesday, November 20, 2012 10:43 PM