none
Unable to create system image on 3TB hardrive Windows 7-64 SP1

    Question

  • I am having the same issue as well with my 3TB Seagate (Seagate has stated to get with TS of Microsoft) and I have no issues doing the same backup on my 500G WD HD. I know this has to do with the fact that my Seagate HD is using Advance Formatted Disk and by following the steps described in KB: http://support.microsoft.com/kb/982018 the issue still continues. This is very frustrating and now I have a useless 3TB drive that is unable to do backups b/c of the OS. I hate to spend more on 3rd party software when the OS is suppose to provide the same functionality.

    I've tried everything the KB has stated and also steps from moderates on other posts on this issue.(I have yet to find a post on here having a resolution for anyone)

    1. Ensured Im running SP1

    2. Ran check disk for error on both drives. (even though my hp pavilion is 4 days out of the box and the HD is also new)

    3. install update according to KB 982018

     

    After the hotfix was installed I'm still getting the same output

     

    C:\Windows\system32>Fsutil fsinfo ntfsinfo F:
    NTFS Volume Serial Number :       0x7420b59d20b566b0
    Version :                         3.1
    Number Sectors :                  0x000000002baa0a1f
    Total Clusters :                  0x000000002baa0a1f
    Free Clusters  :                  0x000000002b78d793
    Total Reserved :                  0x00000000000df800
    Bytes Per Sector  :               4096
    Bytes Per Physical Sector :       <Not Supported> <-------
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 4096
    Clusters Per FileRecord Segment : 1
    Mft Valid Data Length :           0x0000000000d00000
    Mft Start Lcn  :                  0x00000000000c0000
    Mft2 Start Lcn :                  0x0000000015d5050f
    Mft Zone Start :                  0x00000000000c0100
    Mft Zone End   :                  0x00000000000cc900
    RM Identifier:        230A744D-C625-11E0-9ECD-101F740C3A98
     

    Any assistance is appreciated

    Cheers
    Sunday, August 14, 2011 4:54 AM

Answers

  • Hi David,

    Did you have found any error message?

    Check if all the files have been created on the hard drive.

    Check the Volume shadow copy service in services window. To check follow these steps:

    i.                    Click Start and type services.msc in the search box

    ii.                  Search for the Volume shadow copy service

    Make sure the start- up type is automatic.  Steps to set the services to automatic

    i.                    Search for the service

    ii.                  Right click on the service

    iii.                If the service is stopped then Start the service

    iv.                 Select Properties

    v.                   And in the Start-up type select Automatic

     

    This  is the most useful post I can find so am taking this for you.

    http://social.technet.microsoft.com/Forums/en/windowsbackup/thread/889b01be-d333-4fc7-b005-e12b7b236ad7

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/444e8ea2-6417-45dc-83d4-f5ae45bbaa02

    

    Thanks,

    Jeff


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    Monday, August 15, 2011 6:23 AM
    Moderator
  • It really seems like there should be a solution for this, but check out the following link. It explains in detail the problem.

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/5d9e2f23-ee70-4d41-8bfc-c9c4068ee4e2/

     

    Here is the section from that article that I am referencing:

    Basically there are two things that could be causing your backup to fail if it is a removable HD.  I am going to save you the trouble of reading this whole thread and catch you up. 

    1.     Your removable HD has bloatware (crapware, extra software, custom bios, etc etc…) that prevents windows from seeing it for what it should be (a removable HD).  When you plugged your disk in did you also get a new CDROM drive also?  Did you install some special software in order to get to the disk?  Encryption software maybe?  Your disk is not going to work.  Stop reading any further and return it.  Don’t feel bad.  Chances are you didn’t know it was going to be that way and the manufacturer did a poor job of telling you about it before you purchased it. Return your drive and go to this site where there is a nice list developing that tracks disks that have been tested:  http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx

     

    2.     Your disk has more than 512 bytes per physical sector.  If it new and large (like 1TB or more) it probably has 4096 bytes per physical sector.  The windows backup software was designed to work with disks that have 512 bytes per physical sector.  Again, don’t feel bad about getting the wrong disk.  I did a quick check of about 10 disks online and couldn’t find a single one where the manufacturer listed the bytes per physical sector in the specs anywhere.  Also, until you have this problem, you will probably never know about the 512 byte design issue.

    Anyhow, now that you do know about it, you can try to fix it using the Microsoft hotfix here:
    http://support.microsoft.com/kb/982018 which adds support for 4096 byte disks to server 2008 and 2008 R2 (and any SBS versions based on them).  Once the hotfix is applied and you reboot, try assigning the removable HD a drive letter and formatting it.   Once that is done you can check to see if the disk is going to work by using fsutil.  Here is an example showing the command line and the result:

    C:\Users\administrator>fsutil fsinfo ntfsinfo f:
    NTFS Volume Serial Number :       0x2ebc529bbc525d81
    Version :                         3.1
    Number Sectors :                  0x000000000e8b4eff
    Total Clusters :                  0x000000000e8b4eff
    Free Clusters  :                  0x000000000e8aa566
    Total Reserved :                  0x0000000000000000
    Bytes Per Sector  :               4096
    Bytes Per Physical Sector :       <Not Supported>
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 4096
    Clusters Per FileRecord Segment : 1
    Mft Valid Data Length :           0x0000000000100000
    Mft Start Lcn  :                  0x00000000000c0000
    Mft2 Start Lcn :                  0x0000000000000002
    Mft Zone Start :                  0x00000000000c0000
    Mft Zone End   :                  0x00000000000cc820
    RM Identifier:        42643033-B240-11E0-9765-3C4A92E16BD6

    You see where it says “Bytes Per Physical Sector:” and the result was “<Not Supported>”?  That means this disk will not work with the backup even though the hotfix is installed.  Some disks don’t report their bytes per physical sector correctly and therefore won’t work.   If you get one that does report 512 or 4096 you should be OK.   

    Btw, if you do find one that works, be kind and add it to the list of drives here:
    http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx with a comment about your test setup and results.

    Tuesday, August 16, 2011 6:34 AM

All replies

  • Hi David,

    Did you have found any error message?

    Check if all the files have been created on the hard drive.

    Check the Volume shadow copy service in services window. To check follow these steps:

    i.                    Click Start and type services.msc in the search box

    ii.                  Search for the Volume shadow copy service

    Make sure the start- up type is automatic.  Steps to set the services to automatic

    i.                    Search for the service

    ii.                  Right click on the service

    iii.                If the service is stopped then Start the service

    iv.                 Select Properties

    v.                   And in the Start-up type select Automatic

     

    This  is the most useful post I can find so am taking this for you.

    http://social.technet.microsoft.com/Forums/en/windowsbackup/thread/889b01be-d333-4fc7-b005-e12b7b236ad7

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/444e8ea2-6417-45dc-83d4-f5ae45bbaa02

    

    Thanks,

    Jeff


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    Monday, August 15, 2011 6:23 AM
    Moderator
  • It really seems like there should be a solution for this, but check out the following link. It explains in detail the problem.

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/5d9e2f23-ee70-4d41-8bfc-c9c4068ee4e2/

     

    Here is the section from that article that I am referencing:

    Basically there are two things that could be causing your backup to fail if it is a removable HD.  I am going to save you the trouble of reading this whole thread and catch you up. 

    1.     Your removable HD has bloatware (crapware, extra software, custom bios, etc etc…) that prevents windows from seeing it for what it should be (a removable HD).  When you plugged your disk in did you also get a new CDROM drive also?  Did you install some special software in order to get to the disk?  Encryption software maybe?  Your disk is not going to work.  Stop reading any further and return it.  Don’t feel bad.  Chances are you didn’t know it was going to be that way and the manufacturer did a poor job of telling you about it before you purchased it. Return your drive and go to this site where there is a nice list developing that tracks disks that have been tested:  http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx

     

    2.     Your disk has more than 512 bytes per physical sector.  If it new and large (like 1TB or more) it probably has 4096 bytes per physical sector.  The windows backup software was designed to work with disks that have 512 bytes per physical sector.  Again, don’t feel bad about getting the wrong disk.  I did a quick check of about 10 disks online and couldn’t find a single one where the manufacturer listed the bytes per physical sector in the specs anywhere.  Also, until you have this problem, you will probably never know about the 512 byte design issue.

    Anyhow, now that you do know about it, you can try to fix it using the Microsoft hotfix here:
    http://support.microsoft.com/kb/982018 which adds support for 4096 byte disks to server 2008 and 2008 R2 (and any SBS versions based on them).  Once the hotfix is applied and you reboot, try assigning the removable HD a drive letter and formatting it.   Once that is done you can check to see if the disk is going to work by using fsutil.  Here is an example showing the command line and the result:

    C:\Users\administrator>fsutil fsinfo ntfsinfo f:
    NTFS Volume Serial Number :       0x2ebc529bbc525d81
    Version :                         3.1
    Number Sectors :                  0x000000000e8b4eff
    Total Clusters :                  0x000000000e8b4eff
    Free Clusters  :                  0x000000000e8aa566
    Total Reserved :                  0x0000000000000000
    Bytes Per Sector  :               4096
    Bytes Per Physical Sector :       <Not Supported>
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 4096
    Clusters Per FileRecord Segment : 1
    Mft Valid Data Length :           0x0000000000100000
    Mft Start Lcn  :                  0x00000000000c0000
    Mft2 Start Lcn :                  0x0000000000000002
    Mft Zone Start :                  0x00000000000c0000
    Mft Zone End   :                  0x00000000000cc820
    RM Identifier:        42643033-B240-11E0-9765-3C4A92E16BD6

    You see where it says “Bytes Per Physical Sector:” and the result was “<Not Supported>”?  That means this disk will not work with the backup even though the hotfix is installed.  Some disks don’t report their bytes per physical sector correctly and therefore won’t work.   If you get one that does report 512 or 4096 you should be OK.   

    Btw, if you do find one that works, be kind and add it to the list of drives here:
    http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx with a comment about your test setup and results.

    Tuesday, August 16, 2011 6:34 AM
  • After trying a couple more options I still had no luck doing my backups. I eventually just boughta 2TB drive and did my backups without issues. I also tried to partition my 3TB drive into 3  1TB volumes and Windows7 automatically set my drive to a 2TB and I was not able to use my last TB. If anyone tries this please know it is a headache but if you have a computer running XP you can reformat the drive to get your 3TB back or make separate partitions without issues. XP doesn't have any issues with drives larger than 2TB.

     

    Cheers.

     

    Saturday, August 27, 2011 3:23 AM
  • Hey guys!

    If you use an IOMEGA HDD with bloatware you can remove the virtual drive with this tool: http://download.iomega.com/english/iomega-encryption-setup-v1.3.zip.

    After setup, click on "CD-Laufwerk" (CD-Drive) and chose "Entfernen" (remove). After this process Windows Backup will work. Hope this is helpfull!


    Monday, August 29, 2011 10:45 AM
  • I have this hotfix installed, and reformatted my 3TB drive, and the BPPS reported by fsutil is 4096, which you say should make it OK for backup so long as the hotfix is installed. The backup still fails with the same error.

    Interestingly enough, running fsutil on my 1TB external drive gives the <Not Supported> error for BPPS in your post, but it works as a backup drive.  So, my experience would point to your statement being backward:  somehow, we want BPPS to be <Not Supported> or 512; "correctly" reporting 4096 is still broken.

    This is further validated by a high-rated post in the thread you link.  I plan to try this solution and update my post here if it works:

    I would also like to add a solution that I found that has worked for my 3TB WD Elements drive. Out of the box this drive did not work with Windows backup at all. WD support actually came through for me on this issue and pointed me to the following solution:

    http://wdc.custhelp.com/app/answers/detail/a_id/6618/session/L3RpbWUvMTMxMzUzNzc5My9zaWQvT1hrMSpJQms%3D

    Basically it consists of formatting the drive with their external drive formatting utility in "Factory Default" mode rather than XP-Compatible mode which (ironically) is how the drive ships. After performing the format, the drive works fine with Windows backup in both Windows 7 and Windows Server, but is incompatible with Windows XP. In my case, this is an acceptable compromise.

    This is how the drive appeared out of the box:

    C:\Windows\system32>fsutil fsinfo ntfsinfo H:
    Bytes Per Sector  :               4096
    Bytes Per Physical Sector :       <Not Supported>
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 4096

    This is how the drive appeared after the "Factory Default" format:

    C:\Windows\system32>fsutil fsinfo ntfsinfo H:
    Bytes Per Sector  :               512
    Bytes Per Physical Sector :       <Not Supported>
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 1024

    Finally, I should point out that this utility will probably not work for drives from manufacturers other than Western Digital as it scans for WD drives specifically on launch and is likely working directly with their drives' firmware. That said, I do believe this should cover all WD drives 2.5TB and larger to correct this issue.

     

    Wednesday, November 30, 2011 3:41 PM