none
Creating a shortcut in Explorer Links for a Sharepoint 2010 library

    Question

  • Dear All,

    We would like to create a shortcut to a Sharepoint 2010 library in the Links folder of the user profile using Group Policy Preference.

    I know that I need to specify the path using "C:\Users\%USERPROFILE%\name of shortcut". The Explorer Link as a choice in GPM is the Favorite Bar and not the Links folder in Windows Explorer. I have trouble to specifie the target I tried this

    http://servername/sharepointsite/library or

    \\servername\DavWWWroot\Sharepoint libary.

    Do I use the second target I get an GP error in event that the specified file cannot be found. Do I use the first one the GPO applies with no errors in event viewer but I don't get the shortcut.

    I have created manually some shortcut from Sharepoint libraries in my Explorer links folder and all this shortcut use the DavWWWroot addressing scheme. So I believe it should be possible to do the same with GP Preferencen.

    Can you help me please?

    Thanks,

    Edy

    Tuesday, October 23, 2012 4:12 PM

Answers

  •  
    > We would like to create a shortcut to a Sharepoint 2010 library in the
    > Links folder of the user profile using Group Policy Preference.
    >
    > I know that I need to specify the path using
    > "C:\Users\%USERPROFILE%\name of shortcut".
    >
     
    If you are adressing the "Links" folder in explorer, this path is
    incomplete:
     
    "C:\Users\%USERPROFILE%\LINKS\name of shortcut"
     Since I don't have Sharepoint at hand, I cannot further assist in
    creating the shortcuts. But if it fails due to GPP not supporting Webdav
    UNC paths, it may be worth a try to pre-create lnk-files and just copy
    them over to the user's link folder.
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Tuesday, October 23, 2012 7:16 PM
  • Hello,

    I was able to resolve the issue based on the idea Martin said. I used the GP Preferences and copied a shortcut file (lnk) to the %USERPROFILE%\Links Folder.

    This worked!

    Thanks,

    Edy

    • Marked as answer by Edy Werder Thursday, October 25, 2012 7:47 PM
    Thursday, October 25, 2012 7:46 PM

All replies

  •  
    > We would like to create a shortcut to a Sharepoint 2010 library in the
    > Links folder of the user profile using Group Policy Preference.
    >
    > I know that I need to specify the path using
    > "C:\Users\%USERPROFILE%\name of shortcut".
    >
     
    If you are adressing the "Links" folder in explorer, this path is
    incomplete:
     
    "C:\Users\%USERPROFILE%\LINKS\name of shortcut"
     Since I don't have Sharepoint at hand, I cannot further assist in
    creating the shortcuts. But if it fails due to GPP not supporting Webdav
    UNC paths, it may be worth a try to pre-create lnk-files and just copy
    them over to the user's link folder.
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Tuesday, October 23, 2012 7:16 PM
  • Hi,

    Regarding the current issue, would you please provide more details about how did you configure the shortcut via GPP. We’d better paste a screen shot in the thread. In addition, regarding  how to configure a shortcut item, I suggest we could refer to the following article.

    Configure a Shortcut Item

    http://technet.microsoft.com/en-us/library/cc753580.aspx

    Best Regards,

    Andy Qi

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Wednesday, October 24, 2012 10:22 AM
  • Hello,

    I was able to resolve the issue based on the idea Martin said. I used the GP Preferences and copied a shortcut file (lnk) to the %USERPROFILE%\Links Folder.

    This worked!

    Thanks,

    Edy

    • Marked as answer by Edy Werder Thursday, October 25, 2012 7:47 PM
    Thursday, October 25, 2012 7:46 PM
  •  
    > I was able to resolve the issue based on the idea Martin said. I used
    > the GP Preferences and copied a shortcut file (lnk) to the
    > %USERPROFILE%\Links Folder.
    >
    > This worked!
    >
     
    Thanks for feedback! Sometimes it's the straight forward solution that
    makes us happy ;-))
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Friday, October 26, 2012 9:34 AM