locked
Login to RD Web access

    Question

  • Hi........ when i turn on the Anonymous authentication in windows 2008 R2 using IIS, i am getting error message while accessing RD web page (https://localhost/RDWeb/Pages/en-US/default.aspx). My goal is to load Remote Apps without getting the sign in page, Just as same as windows 2008......

    any helps would be appreciated.....
    Monday, March 08, 2010 1:40 AM

All replies

  • What error r u getting?  where did you change the anonymous setting? A little more infomation might help us out a bit
    Monday, March 08, 2010 2:02 PM
  • Object reference not set to an instance of an object.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:


    Line 388:                             <td><a id='PORTAL_SIGNOUT' href="javascript:onUserDisconnect()" target="_self"><%=L_SignOutTab_Text%></a></td>
    Line 389:<%
    Line 390:    }
    Line 391:%>
    Line 392:                              <td width="30">&nbsp;</td>
     

    Source File: c:\Windows\Web\RDWeb\Pages\en-US\Default.aspx    Line: 390

    Stack Trace:



    Hi........ Please find the error message above..... When i turn off the anonymous authentication, it works fine in the local intranet without username and password......... But when i access the website externally it asks for user credentials......

    In windows 2008 TS web, it works with windows authentication and the anonymous authentication turned ON

    I am trying to do the same in windows 2008 R2 RDweb.......

    any ideas??
    Tuesday, March 09, 2010 12:30 AM
  • Sorry forget to tell you where i am trying to change the anonymous setting.............

    I am trying to change it in start -> administrative tools -> IIS Manager and then navigate to the default website. When you expand the tree and select "Pages" folder in the left pane. Then in the right pane, double click Authentication and there you will find all types of authentication
    Tuesday, March 09, 2010 12:33 AM
  • You could also take a look at the same setting for "en-US" subfolder, not sure the setting is inherited.
    Tuesday, March 09, 2010 1:40 PM
  • Ramesh,

    On the RDWeb site, enable both Anonymous and Forms Authentication. This is how mine is setup and it works. This will get the users to the main log in page without having to actually log in to the site before hand.

    Implement Web SSO for the auto logon experience:

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/d3e14395-2ad5-4230-baef-80a92efd8aa1/

    http://blogs.msdn.com/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx





    Hope this helps,

    Kristin L. Griffin

    Co-Author of the Windows Server 2008 Terminal Services Resource Kit (and a SUPER BIG fan of the Microsoft RDV Team!!!) 

    I finally started my blog: blog.kristinlgriffin.com
    Tuesday, March 09, 2010 6:34 PM
  • I have checked all the individual folders
    Wednesday, March 10, 2010 10:19 PM
  • Hi Kristin,

    I have already implemented Web SSO and the problem is RDP 7.0 is not working properly. The remote session is crashing sometimes.
    Also i wanted this be to working in RDP 6.0.6001.

    In order to enable Web SSO, the clients need to modify the registry. We cant ask the clients to do this.

    Ultimately my aim is to get rid of the login page and load the remote app programs without user credentials. This is how its been working in windows 2008 server (tsweb) which is implemented using windows authentication method.

    In the same way i am trying to turned ON  windows authentication and anonymous authentication  but its not working in windows 2008 R2 (RDWeb).


    any idea

    Thanks
    Wednesday, March 10, 2010 10:29 PM