none
No Internet Access from guest OS

    Question

  • Hi,

    I have several Hyper-V images running on my machine and I cannot access the Internet from any of them.

    My host is running Server 2008 R2. I have one physical NIC. My guest OSs have been Server 2008/2003 with no luck on either.
    I have tried removing and adding the Hyper-V role.
    I have tried both Network Adapter and Legacy Network Adapter in the guests.
    I am selecting the External option when creating the virtual network.
    The virtual network adapter appears to be created correctly (a second adapter appears with the full set of protocols, etc selected and the original adapter has only the Virtual Network Switch protocol selected) when I add network support through the Hyper-V console.

    I can remote desktop into the guest OSs and access them fine from the host.

    Thoughts? Suggestions?  Need more info?

    Thank you for any help.
    Larry

    Saturday, March 06, 2010 6:03 PM

Answers

  • ok it seems i managed to fix the issue. For the hyper-v virtual adapter settings...i had set it to home network. but my host hardware card was on office network. once i set the virtual one to office network, the gateway was correctly detected and ip auto assigned.

     

    btw in my host adaptor i have all the checkboxes selected. if you only select the  microsoft virtual network switch protocol and unselect everything else then you wont get host internet. So i had to select all the options for the host adapter properties. 

     

    Friday, March 19, 2010 3:58 AM

All replies

  • Hi Larry,

    Can you access to Internet via your host ?
    Do you have a DHCP server on your host ?
    David LACHARI
    Sunday, March 07, 2010 1:14 PM
  • Hi,

     

    David raised a good question, please check whether you can access Internet from your Hyper-V host machine.

     

    By the way, please run ipconfig/all on both the Hyper-V host machine and the VMs and paste the output here. Please also try to ping the some website within the VMs.

     

     

    Best Regards,

    Vincent Hu

     

    Monday, March 08, 2010 6:04 AM
    Moderator
  •  

    Hi sorry to hijack, but i am also having the same issue. This is the first time i am tying our a server os ever.

     

    host: server 2008 R2, build 7600

    Roles: DC, DNS, Remote Desktop, Hyper V

    guest: windows 7 64 ultimate

     

    Network Cards:

    -------------------

    - LAN - virtual network

    - Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)

     

    Hyper-v network setting

    -------------------------

    external, connected to realtek,

    checked = allow management os to share this adaptor

    checked = enable virtual lan id for management os, id:2 (do i need to do this)

     

    Host ipconfig

    ---------------

    Windows IP Configuration


    Ethernet adapter Local Area Connection 3:

       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::8c54:bb15:1df9:b87e%16
       Autoconfiguration IPv4 Address. . : 169.254.184.126
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::d0ce:a691:ceb9:66dc%11
       IPv4 Address. . . . . . . . . . . : 192.168.0.101
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.0.1

    Tunnel adapter isatap.{C14B1C73-2774-4BF9-BBF3-0EFA0B725BDD}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :

    Tunnel adapter Local Area Connection* 11:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :

    Tunnel adapter isatap.{1F58F835-F636-41C7-AE08-E179BAD3F79F}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :


    Guest OS

    -------------


    Windows IP Configuration


    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::70:5e71:de2e:659f%11
       Autoconfiguration IPv4 Address. . : 169.254.184.126
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :


    Tunnel adapter isatap.{5B2D9864-BC44-4862-B141-18E13450FAF6}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :

     

    ------------------------------------------------------------

    So my host Local Area Connection 3 --> is my guest Local Area Connection.

    I access internet from the host using Local Area Connection. typing this reply from host internet

     

    In host Local Area Connection

    -------------------------------------

    checked = microsoft virtual network switch protocol

    ipv4 connectivity: internet access

    ipv6 connectivity: no internet access

     

    In host Local Area Connection 3

    ---------------------------------------

    unchecked = microsoft virtual network switch protocol

    ipv4 connectivity: no internet access

    ipv6 connectivity: no internet access

     

     

     

     

    Friday, March 19, 2010 3:10 AM
  • ok it seems i managed to fix the issue. For the hyper-v virtual adapter settings...i had set it to home network. but my host hardware card was on office network. once i set the virtual one to office network, the gateway was correctly detected and ip auto assigned.

     

    btw in my host adaptor i have all the checkboxes selected. if you only select the  microsoft virtual network switch protocol and unselect everything else then you wont get host internet. So i had to select all the options for the host adapter properties. 

     

    Friday, March 19, 2010 3:58 AM
  •    That is true if you only have one NIC. The recommended setup is to have one NIC dedicated to the host and one or more dedicated to virtual networks only. The NICs used by vms only wil have just the virtual network switch box checked. The one dedicated to the host will have this box unchecked.

     


    Bill
    Friday, March 19, 2010 6:15 AM
  • Hi David,

    Sorry for the slow response, it appears as though I don't have the allerts created correctly in the forums.  Yes I do have Internet access via the host and no I do not have a DHCP server on my host.  However, the problem has gone away.  With no changes made to either the VMs or the host a reboot of the host seems to have resolved the issue. Why didn't I try that first?  <sigh>  :-)

    Thanks,
    Larry

    Wednesday, March 31, 2010 3:24 PM