none
Mouse not captured in remote desktop session

    Pregunta

  • I was able to manage from my R2 box with remote desktop connection manager to remote into hyper-v host server and then manage guests but since  the install of SP1 RC on my box I'm getting this error. Why?

    ENV: Windows Server 2008 R2

    viernes, 11 de febrero de 2011 17:52

Respuestas

  • I`ve just tested the same scenario here, and I can`t reproduce it.

    Can you try to use the mstsc /admin when you connet to your Hyper-V 2008 R2 server?

    Also, check the Applications and Services Logs-->Microsoft-->Windows--> Hyper-V... and see for any relevant information about this behavior.

     

    Regards, 


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    viernes, 11 de febrero de 2011 21:56

Todas las respuestas

  • If you have updated your hyper-v host with sp1, you should also update your VMs with the new version of integration components.


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    viernes, 11 de febrero de 2011 18:02
  • But I didn't. Its only my laptop.

    viernes, 11 de febrero de 2011 18:06
  • "but since  the install of SP1 RC on my box I'm getting this error"

    Where did you install SP1 RC? Are you not able to manage any of your VMs with mouse? 

    Could you try to re-install the IC in your VMs with this error, and see if the error still exist?


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    viernes, 11 de febrero de 2011 18:16
  • Here's the envirnoment:

    1. My laptop (windows 2008 r2 sp1 rc)

    2. Hyper-V Host Server with many guests. (Windows 2008 R2 both host and guest)

    Now, before my laptop was installed with SP1 I was able to use RDC Manager to connect to Hyper-V host and then manage guest with Hyper-V Manager MMC.

    But after the SP1 RC was installed on my Laptop when I do try to Manage guests as above message pops up "Mouse not captured in remote desktop session"

    Integraton services are latest as they both (Host and guest) are same OS versions. So what should I do now?

    viernes, 11 de febrero de 2011 19:16
  • I`ve just tested the same scenario here, and I can`t reproduce it.

    Can you try to use the mstsc /admin when you connet to your Hyper-V 2008 R2 server?

    Also, check the Applications and Services Logs-->Microsoft-->Windows--> Hyper-V... and see for any relevant information about this behavior.

     

    Regards, 


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    viernes, 11 de febrero de 2011 21:56
  • If your integration tools are correctly installed you could try the "detect HAL" trick:

    http://mohsartawi.wordpress.com/2010/05/18/mouse-not-captured-in-remote-desktop-session-in-hyper-v-environment/

    I've used this awhile back, and im pretty sure it was on 2008 R2, so i belive it applies to 2008 R2 too.

    viernes, 11 de febrero de 2011 23:26
  • lunes, 14 de marzo de 2011 16:37
  • Hi,

         The issue has been resolved by the following settings:

    Connect the server  --> Action -->  Click on "Insert integration service setup disk" --> it will take you to installation setup file continue with installation.


    Cheers : Jeriesh
    jueves, 13 de octubre de 2011 14:15
  • Hi,

         The issue has been resolved by the following settings:

    Connect the server  --> Action -->  Click on "Insert integration service setup disk" --> it will take you to installation setup file continue with installation.


    Cheers : Jeriesh

    Hi, so how to fix it when Guest = CentOS
    miércoles, 18 de julio de 2012 7:27
  • windows server 2008 r2(with sp1) can do it ,but windows server 2012 can not capture Mouse in Remote Desktop session (already upgraded integration services from old edtion)
    jueves, 22 de noviembre de 2012 3:21
  • Not so, Aphrodite. I just successfully did it in Win Server 2012. After following the above procedure, the Integration Services Setup started automatically, ran to successful completion, and then I was able to use the mouse.
    viernes, 28 de diciembre de 2012 19:52