none
How to run mstsc.exe in a Remote Desktop Services Server?

    Pregunta

  • Hi All,

    Hereby my question, If installed Remote Desktop Services lately on Windows Server 2008 R2 ofcourse.
    Now everything works fine but I can't figure how to run mstsc.exe. Because for example I want to connect to another
    server in the same network.

    Every time I want to run : mstsc.exe its gives me the following popup :
    "Your administrator has set policy that prevents hte launching of this RDP file. The remote connection cannot be started"

    Can anyone explain how to disable that : "Policy" because I didnt setup any policy's yet.

    I hope someone can explain it so I can use mstsc.exe again :)
    viernes, 06 de noviembre de 2009 13:20

Respuestas

  • Hello,

     

    If the error prompts when you start a MSTSC.EXE from the default.rdp file, please check the following policy settings:

     

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client\Allow .rdp from valid publishers and user’s default .rdp settings

     

    User Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client\Allow .rdp from valid publishers and user’s default .rdp settings

     

    Please check them on both local level and domain OU level.

     

    If any one of them are set to be Disabled, please change it to be Not Configured or Enabled. If they are all left as Not Configured already, please change them to be Enabled. Update the policy by gpupdate /force and check the issue again.

     

    Thanks.

     

    Regards,

    ·         Lionel Chen

    miércoles, 11 de noviembre de 2009 9:29

Todas las respuestas

  • I apologize if my question sounds dumb, but I need a little more info to understand this better. How are you launching mstsc.exe? Are you running the command mstsc.exe from command line or Run box? Or are you clicking an RDP file to launch a connection?

    This error generally comes from RDP app publishing signature validation failure. So I am wondering if there is app publishing somewhere in your scenario.
    miércoles, 11 de noviembre de 2009 0:35
  • Hello,

     

    If the error prompts when you start a MSTSC.EXE from the default.rdp file, please check the following policy settings:

     

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client\Allow .rdp from valid publishers and user’s default .rdp settings

     

    User Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client\Allow .rdp from valid publishers and user’s default .rdp settings

     

    Please check them on both local level and domain OU level.

     

    If any one of them are set to be Disabled, please change it to be Not Configured or Enabled. If they are all left as Not Configured already, please change them to be Enabled. Update the policy by gpupdate /force and check the issue again.

     

    Thanks.

     

    Regards,

    ·         Lionel Chen

    miércoles, 11 de noviembre de 2009 9:29
  • Hello Munindra,

    It is after 3 yrs, but I faced a similar problem now.

    Scenario:

    Windows 7 XenDesktop

    RDP file is on this virtual desktop with necessary connection settings.

    If I run mstsc.exe from [start-> run], I can RDP the servers and PCs -> No problem

    Problem:

    If I try to run the RDP file from the desktop by double clicking, I get the error message as follows and I can not connect:

    [your administrator has set policy that prevents the launching of this RDP file. the remote connection cannot be started.]

    Could you please show me how to get rid of this problem, since you seem to have a specific solution for this problem.

    Best Regards,

    Tom

    jueves, 28 de junio de 2012 1:37