none
Private heartbeat network makes my sql server cannot be connected

    Pregunta

  • I setup a sql server 2008 R2 named instance on a windows server 2008 R2 cluster. Previously the cluster only have one public network, and it works without any problem. After I added a private heartbeat network, I cannot connect to the sql server instance anymore from a remote client machine, until I disable the private network adapter. Anybody can tell me how to set the private heartbeat properly?
    martes, 12 de junio de 2012 8:18

Respuestas

  • hi,

    this is Ok. So the problem should be in the SQL Config check the TCP/ip config in the SQL server make sure it use the SQLCluster named instance IP and not the local node IP's nore the 10.1.1.X 160.86.12.64 / 71

    sql server configuration manager


    Greetings, Robert Smit [MVP] http://robertsmit.wordpress.com/ “Please click "Vote As Helpful" if it is helpful for you and Proposed As Answer”

    • Marcado como respuesta nonno miércoles, 13 de junio de 2012 2:51
    martes, 12 de junio de 2012 13:42
    Moderador

Todas las respuestas

  • Hello, 

    As per below MS article, private heartbeat configuration is recommended. So, please have a look into it.

    http://support.microsoft.com/kb/258750


    Regards, Ravikumar P

    martes, 12 de junio de 2012 10:14
  • Hi,

    what is the IP range that you use for public and the private range. you should not use Ip's in the same subnet for public and private.

    192.168 for public and say 1.1.1 for private.

    also you can change the network connections in SQL in the SQL configuration,


    Greetings, Robert Smit [MVP] http://robertsmit.wordpress.com/ “Please click "Vote As Helpful" if it is helpful for you and Proposed As Answer”

    martes, 12 de junio de 2012 10:19
    Moderador
  • Here's the public IP setting

    • Editado nonno martes, 12 de junio de 2012 10:26
    martes, 12 de junio de 2012 10:23
  • Here's the private setting

    martes, 12 de junio de 2012 10:29
  • hi,

    this is Ok. So the problem should be in the SQL Config check the TCP/ip config in the SQL server make sure it use the SQLCluster named instance IP and not the local node IP's nore the 10.1.1.X 160.86.12.64 / 71

    sql server configuration manager


    Greetings, Robert Smit [MVP] http://robertsmit.wordpress.com/ “Please click "Vote As Helpful" if it is helpful for you and Proposed As Answer”

    • Marcado como respuesta nonno miércoles, 13 de junio de 2012 2:51
    martes, 12 de junio de 2012 13:42
    Moderador
  • My colleague helped me to change the network adapter binding, and it seems working now!

    By the way, I also like to restrict the IP address that the SQL Server will listen. I tried to set it on SQL Server Configuration Manager as below:

    1. Set Listen All to No

    2. Set the SQLCluster named instance IP (160.86.12.66)

    Then I clicked OK, and restarted the SQL Server instance in failover cluster manager. After that, I go back to SQL Server Configuration Manager to check the settings, the Listen All changed back to "Yes". Why can't I set it to "No"?


    • Editado nonno miércoles, 13 de junio de 2012 2:52
    miércoles, 13 de junio de 2012 2:51