none
REVERSE DNS

    Pregunta

  • i set reverse dns on my server. and works on itself.

    nslookup 92.50.56.10 92.50.56.10 is ok

     

    but it doesn't work using root server

    nslookup 92.50.56.10 4.2.2.4 is failed.

    nslookup 92.50.56.10 8.8.8.8 is failed.

    jueves, 14 de abril de 2011 19:30

Todas las respuestas

  • i have a simple server and windows 2008 - 64 bit on it

    i set dns and reverse ptr records configuration on it and it works as long as 2 years.

    after 2 years reverse dns now has problem since 20 days ago. it is automatically failed. but forward dns is now working properly.

    Note: it think reverse dns configuration is ok too. because nslookup is worked localy. but from non-local computer nslookup failed.

    See This:

     

    1- forward dns is ok:

    C:\>nslookup www.akanhost.com
    Server:  UnKnown
    Address:  4.2.2.4

    Non-authoritative answer:
    Name:    akanhost.com
    Address:  92.50.56.10
    Aliases:  www.akanhost.com


    2- reverse dns problem:

    C:\>nslookup 92.50.56.10
    Server:  UnKnown
    Address:  4.2.2.4

    *** UnKnown can't find 92.50.56.10: Non-existent domain

     

    3- reverse dns lookup from my server is ok:

    C:\>nslookup 92.50.56.10 92.50.56.10
    Server:  golband.info
    Address:  92.50.56.10

    Name:    mehrazi1.com
    Address:  92.50.56.10


    4- http://www.mxtoolbox.com/

    ptr:92.50.56.10   is failed

     

    what can i do????

    jueves, 14 de abril de 2011 8:12
  • What do you mean by local and non-local?

    Could you please post the output of ipconfig /all > dnsserver.txt on the DNS server and of ipconfig /all > clientdns.txt on a faulty client?

     

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner

    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration

     


    jueves, 14 de abril de 2011 8:47
  • all client have reverse dns problem. see mxtoolbox.com for ptr.

     

    but dns.txt on server is:

     

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : H1
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC
       Physical Address. . . . . . . . . : 00-13-F7-A7-B2-06
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::fd0b:7b8:a7a0:db19%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 92.50.56.10(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.240
       Default Gateway . . . . . . . . . : 92.50.56.1
       DNS Servers . . . . . . . . . . . : 92.50.56.10
                                           4.2.2.4
                                           4.2.2.2
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{5B4177CF-7AEE-4A2D-AC27-1B2E828CBF0D}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : 6TO4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:5c32:380a::5c32:380a(Preferred)
       Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
       DNS Servers . . . . . . . . . . . : 92.50.56.10
                                           4.2.2.4
                                           4.2.2.2
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 11:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    jueves, 14 de abril de 2011 9:00
  • It seem problem with DNS. Check with your ISP provider.

     

    Thanks

    jueves, 14 de abril de 2011 9:41
  • i know it is dns problem.

    no problem with my isp. because no firewall was run. and isp is mine too.

     

    and when i run nslookup 92.50,56,10 92.50.56.10 from outside is ok.

    but when i run nslookup 92.50.56.10 from outside is not ok.

    jueves, 14 de abril de 2011 9:59
  • Hello again,

       IPv4 Address. . . . . . . . . . . : 92.50.56.10(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.240
       Default Gateway . . . . . . . . . : 92.50.56.1
       DNS Servers . . . . . . . . . . . : 92.50.56.10
                                           4.2.2.4
                                           4.2.2.2

    Don't put 4.2.2.4 and 4.2.2.2 public DNS servers as secondary ones.

    Please use forwarders and add them as forwarders.

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner

    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration

    jueves, 14 de abril de 2011 10:10
  • how to add forwarder?

    can you explain step by step?

    i am not very professional.

     

    jueves, 14 de abril de 2011 11:35
  • Check this article.

    And make sure you install firewall and your dns server protected from DNS Cache Poisoning Attack.

     

    Thanks

    jueves, 14 de abril de 2011 11:41
  • Hi Customer,

        After add 4.2.2.2 and 4.2.2.4 into DNS server forwarders, it should be just keep only 92.50.56.10 DNS server in your server and client IP configure/all result.(4.2.2.2 and 4.2.2.4 need to be removed)

    When you test dns it will show

    C:\>nslookup 92.50.56.10

    Server: golband.info
    Address: 92.50.56.10

    not show

    C:\>nslookup 92.50.56.10
    Server: UnKnown
    Address: 4.2.2.4


    Regards, Rick Tan

    viernes, 15 de abril de 2011 5:37
  • i remove that. still have problem. but nslookup from my server is not my problem. it was ok from first.

    my problem is nslookup from other clients. all clients  has problem.  including:

    http://www.mxtoolbox.com

    http://ping.eu/rev-lookup

    or from my computer.

     

    you can test it from your computer:  please type nslookup 92.50.56.10

     

    viernes, 15 de abril de 2011 6:50
  • nobody knows that?
    viernes, 15 de abril de 2011 6:52
  • Hi Customer,

         It's response from DNS root hints , not from forwarder 4.2.2.2. Please on your DNS server, DNS console --> properties -->Forwarders--> Edit -->4.2.2.2, restart your dns service.

     

    http://network-tools.com/nslook/Default.asp?domain=www.mxtoolbox.com&type=255&server=92.50.56.10&class=255&port=53&timeout=5000&go.x=0&go.y=0


    Regards, Rick Tan
    viernes, 15 de abril de 2011 7:59
  • i set forwarder.

    be careful that mxtoolbox is not mine. it is a lookup site like network tools.

    my problem is not solve.

     

     

    *********************************************************************************************

    i describe my problem again:


    my reverse dns from my server is ok.   ---->  means when i type "nslookup 92.50.56.10" on my server it is ok. (means my ptr records is ok on my server)

    but when i type "nslookup 92.50.56.10" on all other clients it is not ok.

     

    i set  4.2.2.4 and 4.2.2.2 as a forwarder. and remove these two from my my server tcpip ---> properties ---> dns

    but my problem is still exists.

    ***********************************************************************************************


     

     

    viernes, 15 de abril de 2011 11:20
  • Are you sure that you control your address space?  A lot of the time you'll have to have your internet service provider add a reverse entry for you.  Also it can take some time up to 48 hours for a new entry to fully propagate.
    viernes, 15 de abril de 2011 13:33
  • i set reverse dns on my server. and works on itself.

    nslookup 92.50.56.10 92.50.56.10 is ok

     

    but it doesn't work using root server

    nslookup 92.50.56.10 4.2.2.4 is failed.

    nslookup 92.50.56.10 8.8.8.8 is failed.


    I looked up  92.50.56.10 and got a failure, too. Where did you create this, on your server or through the ISP as Michael stated? Did you ask your ISP, who owns the IP block, to create a PTR entry for whatever FQDN name you want it to show up as?

    If you created it on your server, is your server authoritive for the  92.50.56.0/24 IP block? You would have had to do that with their help in assigning and delegating the IP block to your hostname servers.

    Try running nslookup using your own internal server instead of 4.2.2.4 or 8.8.8.8. Does it work? If you created it on your server, it should work. If it doesn't using an internet DNS such as 4.2.2.2, then it won't unless you're delegated, or you had your ISP take care of it.

    When I need a reverse name for my public IPs, I have to submit a ticket with a request for the name to the specific IP address. Did you do that, too?

     

    Ace

     

     


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    viernes, 15 de abril de 2011 15:00
  • i set forwarder.

    be careful that mxtoolbox is not mine. it is a lookup site like network tools.

    my problem is not solve.

     

     

    *********************************************************************************************

    i describe my problem again:


    my reverse dns from my server is ok.   ---->  means when i type "nslookup 92.50.56.10" on my server it is ok. (means my ptr records is ok on my server)

    but when i type "nslookup 92.50.56.10" on all other clients it is not ok.

     

    i set  4.2.2.4 and 4.2.2.2 as a forwarder. and remove these two from my my server tcpip ---> properties ---> dns

    but my problem is still exists.

    **********************************************************************************************

     

    I ran an nslookup to find who is authoritive for your akanhost.com domain, and it returned as ns.akanhost.com, as you can see here:

    > set q=ns
    > akanhost.com
    Server:  vnsc-bak.sys.gtei.net
    Address:  4.2.2.2

    Non-authoritative answer:
    akanhost.com    nameserver = ns.akanhost.com

    Then I set the query for all records, and here's what I got:

    > set q=all
    > ns.akanhost.com
    Server:  vnsc-bak.sys.gtei.net
    Address:  4.2.2.2

    Non-authoritative answer:
    ns.akanhost.com internet address = 92.50.56.10

    It shows that your server is apparently the hostname server for akanhost.com. So if you are not getting a reverse lookup for 92.50.56.10, please check your Reverse Lookup Zones for the 92.50.56.x zone, and make sure there is an entry for 92.50.56.10 that is pointing to www.akanhost.com.

    Ace


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    viernes, 15 de abril de 2011 15:06
  • i set reverse dns on my server. and works on itself.

    nslookup 92.50.56.10 92.50.56.10 is ok

     

    but it doesn't work using root server

    nslookup 92.50.56.10 4.2.2.4 is failed.

    nslookup 92.50.56.10 8.8.8.8 is failed.


    I saw your other thread about this same exact problem. Apparently two threads on this? After reviewing the scenario in the other thread and understanding your setup, for your convenience, I am reposting what I posted in the other thread to what may appear to be the problem:

    ================================================================================

    I ran an nslookup to find who is authoritive for your akanhost.com domain, and it returned as ns.akanhost.com, as you can see here:

    > set q=ns
    > akanhost.com
    Server:  vnsc-bak.sys.gtei.net
    Address:  4.2.2.2

    Non-authoritative answer:
    akanhost.com    nameserver = ns.akanhost.com

     

    Then I set the query for all records, and here's what I got:

    > set q=all
    > ns.akanhost.com
    Server:  vnsc-bak.sys.gtei.net
    Address:  4.2.2.2

    Non-authoritative answer:
    ns.akanhost.com internet address = 92.50.56.10

     

    It shows that your server is apparently the registered hostname server for akanhost.com. So if you are not receiving the proper answer for a reverse lookup for 92.50.56.10, as I didn't receive one, then it says the problem is in the way the reverse entry was created on your DNS server.

    Please check your Reverse Lookup Zones on your DNS server for the 92.50.56.x zone, and make sure there is a PTR entry for 92.50.56.10 that is pointing to www.akanhost.com. For assistance, the following links may help you out:

    Add a pointer (PTR) resource record to a reverse zone: Domain Name ...Jan 21, 2005 ... When creating a new A resource record, there is an option ...
    http://technet.microsoft.com/en-us/library/cc775703(WS.10).aspx

    Managing DNS RecordsThe A record maps a host name to an IP address and the PTR record creates a pointer to the host for reverse lookups. You can create address and pointer ...
    http://technet.microsoft.com/en-us/library/bb727018.aspx

     

    Regards,
    Ace

     


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

     

     

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.


    • Editado Ace Fekay [MCT]MVP viernes, 15 de abril de 2011 15:12 Provided clarification in 2nd sentence.
    viernes, 15 de abril de 2011 15:11
  • oh god, i explain my problem 20 times. but anybody doesn't read carefully.

    1- you check only my forward nslookup. that how i said from first that my forward zone has no problem.

    2- you say that i should check my reverse zone and ptr records. but all of my configuration is ok. because reverse dns is working locally on my server.

    3- the problem is the reverse using another client or external server.

     

                               |   Nslookup On My Server      |      Nslookup From Other Clients  |

                               | ------------------------------- |---------------------------------------|

    Forward Zone:  |                 OK                    |                        OK                     |

                               | ------------------------------- |---------------------------------------|

    reverse zone:    |                 OK                    |                   NOT OK                  |

                              | ------------------------------- |---------------------------------------|

     

    this meanse that my forward and reverse zone set correctly. and i should say it again that reverse dns in this server worked correctly from 2 years ago. this problem accoured since 2 weeks.





    viernes, 15 de abril de 2011 20:46
  • I apologize, I forgot to paste my reverse lookup:

    > 92.50.56.10
    Server:  vnsc-bak.sys.gtei.net
    Address:  4.2.2.2

    *** vnsc-bak.sys.gtei.net can't find 92.50.56.10: Non-existent domain
    >
    >

    So no, it doesn't work from the outside world.

    I tried it using YOUR DNS server and it works:

    > server  92.50.56.10
    Default Server:  [92.50.56.10]
    Address:  92.50.56.10

    > 92.50.56.10
    Server:  [92.50.56.10]
    Address:  92.50.56.10

    Name:    shamusic.in
    Address:  92.50.56.10

     

    According to a lookup at http://dnstree.com/92/50/56/10/, it doesn't appear that your DNS server is delegated to be authoritive for the reverse IP block.

    However, that can be mistaken if the ISP delegated the IP block to your nameserver. Therefore, as As I've previously asked:

    Has your ISP that owns the IP block, delegated your IP block for your DSL line to YOUR DNS server?

     

    Based on another lookup, I believe "SHABAKEH GOSTARE DORNA COOPERATIVE CO" is your ISP for your DSL line. Is that correct? Have you contacted them about this?

     If they have not delegated this IP block to your DNS server, then it will not work from the outside world and will only work inside your network.

    Ace

     


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    viernes, 15 de abril de 2011 22:41