none
Error 0x80072F8F

    Pregunta

  • How can I solve the error 0x80072f8f? My laptop has windows Vista x86.

    Looking online, I found that I can change the date and time, and the time zone as well. I have to set it to the same time as Windows Update server, but they don't say what is the correct time. I'm currently living in Santa Cruz, Bolivia-South America where the time zone is GMT -4:00.

     

    martes, 22 de febrero de 2011 15:52

Respuestas

  • Hi All,

    I have just had an instance of this.....

    The two clients concerned were in a DMZ, consequently they were not able to access the internal DNS. To get around this URLs in the client's registry referencing the WSUS server (HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\WUServer & WUStatusServer) had been configured by IP address rather than FQDN. This caused the attempt to check the time stamp on the SSL certificate to fail producing the above error message.

    The fix was to change the URLs back to using the DNS name which matches the SSL cert and create an entry in the host file so that it could resolve the name to IP.

    End story is that if you are using SSL the URLs in the client registry under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate must match the SSL certificate or you will get this error mesage.

    Julian Little

    miércoles, 11 de abril de 2012 4:14

Todas las respuestas

  • How can I solve the error 0x80072f8f?

    0x80072F8F

    -2147012721 ERROR_INTERNET_SECURE_FAILURE   ErrorClockWrong One or more errors were found in the Secure Sockets Layer (SSL) certificate sent by the server.

    Set the machine to the correct *TIME*!

    I have to set it to the same time as Windows Update server

    You mean a *WSUS* server, or the Microsoft servers hosting Windows Update? Either way, you don't set the time based on another server -- and certainly not the Windows Update servers! -- you set the time based on reality, which is your current Time Zone (GMT-4) and your current time in that Time Zone -- which, at this exact moment, should be 12:56pm.

    but they don't say what is the correct time.

    Uh... the correct time is the correct time. Look at a wall clock. Read the time. Set that time.

    I'm currently living in Santa Cruz, Bolivia-South America where the time zone is GMT -4:00.

    Then you should first ensure that your machine is set to the correct TIME ZONE -- pick the one of your choice from the Time Zone dialog, and then set your machine to the correct time. It really doesn't matter where you are. Configure the machine correctly and it will work.

     


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2011)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    My Blog: http://onsitechsolutions.spaces.live.com
    martes, 22 de febrero de 2011 16:57
  • I already set my computer to the right time zone and whenever I check for updates on Windows Defender still get "The program can't check for definitions  updates" Error found: Code 0x80072F8F.

    Any other advices on how can I solve this?

    Thanks,

    Alejandro Rioja

    martes, 22 de febrero de 2011 18:11
  • What Time Zone and Time is this computer set to right now? (i.e. when you reply to this message).
    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2011)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    My Blog: http://onsitechsolutions.spaces.live.com
    martes, 22 de febrero de 2011 20:25
  • 05:01pm GMT -4:00 Georgetown, Manuas, La Paz
    martes, 22 de febrero de 2011 21:02
  • 05:01pm GMT -4:00 Georgetown, Manuas, La Paz

    So, this message was posted 23 hours and 11 minutes ago.

    The current time is 20:13 GMT, which means this message was posted at 21:02 GMT, which would be 17:02(GMT-4), so your computer is correctly configured.

    Where is the WSUS server to which you are trying to connect?


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2011)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    My Blog: http://onsitechsolutions.spaces.live.com
    miércoles, 23 de febrero de 2011 20:17
  • Hi All,

    I have just had an instance of this.....

    The two clients concerned were in a DMZ, consequently they were not able to access the internal DNS. To get around this URLs in the client's registry referencing the WSUS server (HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\WUServer & WUStatusServer) had been configured by IP address rather than FQDN. This caused the attempt to check the time stamp on the SSL certificate to fail producing the above error message.

    The fix was to change the URLs back to using the DNS name which matches the SSL cert and create an entry in the host file so that it could resolve the name to IP.

    End story is that if you are using SSL the URLs in the client registry under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate must match the SSL certificate or you will get this error mesage.

    Julian Little

    miércoles, 11 de abril de 2012 4:14