none
NLB failing - NIC stops working

    Question

  • Hi,

    I have installed NLB on two Windows 2008 R2 machines, it's been working fine for weeks. Now they cannot communicate due to "RPC server is unavailable", also the NIC cannot communicate out, that is, the Public NIC (not the NLB) cannot ping or communicate out. I can ping it from another machine. Once I remove the NLB the NIC works fine. There is a lot of information on the Internet about this, but I have not found my actual problem. I tried two other newly formatted computers and the same happens. Am also using VMware.

    • server01 (CAS)
    • Nic 1 - 10.10.16.232/24, DG - 10.10.16.1/24
    • Nic 2 - 172.16.1.232/24, No DG
    • server02 (CAS)
    • Nic 1 - 10.10.16.233/24, DG - 10.10.16.1/24
    • Nic 2 - 172.16.1.233/24, No DG
    • VIP - Multicast
    • Nic - 10.10.16.39/24

    Mike

    lundi 19 mars 2012 07:09

Réponses

  • Hi,

    Well I have finally sorted out the issue and I would like to share with others (I hate it when I don't finish a thread).

    I used the following articles to help me:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/0b84bf09-0570-4564-a438-ff7e5a56643d

    http://www.vmware.com/files/pdf/implmenting_ms_network_load_balancing.pdf

    http://social.technet.microsoft.com/Forums/en-US/winserverPN/thread/1369b2cf-627e-4eab-bbf2-c02f4a0e0650/

    http://social.technet.microsoft.com/Forums/en-US/winserverClustering/thread/0afdb0fc-2adf-4864-b164-87e24451f875/

    http://support.microsoft.com/kb/929852

    To summarize the information I gathered:

    2 CAS servers with NLB enabled. Each server has two nic's on different networks 10.0.0.0 and 192.168.0.0. I used Multicast mode.

    When I enabled the NLB on the second server I was unable to use the nic, it became out of operation. I did the following operations to fix the problem:

    1, Disabling IPv6, disable tcp offload and disable chimney:

    Disable TCP Offload
    Open up regedit and change the value DisableTaskOffload to 1:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload


    Disable Chimney
    To see the current status, open up an elevated Command-Prompt and type:
    netsh int tcp show global

    Verify that Chimney Offload state is set to disabled.

    To disable type:
    netsh int ip set chimney=disabled



    2, Disable IPv6
    IPv6 should be disabled on the CAS-servers in order for Outlook Anywhere to operate correctly.

    Disable on each nic

        Start regedit.exe
        Go to the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
        Create the following registry entry:
    Name:        DisabledComponents
    Type:        DWORD (32-bit Value)
    Value (Hexadecimal):    ffffffff
        Close regedit.exe
        Restart the server for the changes to be activated

    3, enable IP forwaring on the Public nic

    netsh interface ipv4 set int "[name of the Cluster NIC]" forwarding=enabled

    4, Add multicast MAC address to router

    Find MAC address of VIP from Properties ==> Cluster Parameters of the NLBMGR

    Add arp command to Cisco switch - arp [VIP] [VIP MAC] ARPA

    I did all of the above, but I would recommend others to apply each step and test. I'm not an expert at this so please read before taking my word for this. It worked for me though.

    Mike







    • Marqué comme réponse Stokie Mike vendredi 13 avril 2012 12:38
    • Modifié Stokie Mike vendredi 20 avril 2012 16:40
    vendredi 13 avril 2012 12:38

Toutes les réponses

  • Since you are using the Multicast Mode, you can simply use a single NIC card.

    If you are using VMs then please sure that MAC spoofing is enabled.

    Also, your cluster should be configured to use NIC1 on server01 and server02. Please check that.

    Please check also that DNS resolution is made correctly for both nodes.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    lundi 19 mars 2012 21:10
  • Hi,

    Apologies for not completing this thread, I have been working hard to get this issue fix but no luck. I have converted to Unicast mode to solve a different issue. I still have two nics and the problem. Once I configure the NLB it works after a reboot the main nic fails, I cannot ping out but can ping in - strange. I was thinking it was a hardware incapability - intel chipset. I have the latest drivers. Stangley the nics works for several weeks then stopped. The machine was not changed in anyway during this time, no one even logged onto the computer.

    Am running in WMware environment.

    Any other suggestions :(

    lundi 2 avril 2012 05:46
  • Hi,

    Well I have finally sorted out the issue and I would like to share with others (I hate it when I don't finish a thread).

    I used the following articles to help me:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/0b84bf09-0570-4564-a438-ff7e5a56643d

    http://www.vmware.com/files/pdf/implmenting_ms_network_load_balancing.pdf

    http://social.technet.microsoft.com/Forums/en-US/winserverPN/thread/1369b2cf-627e-4eab-bbf2-c02f4a0e0650/

    http://social.technet.microsoft.com/Forums/en-US/winserverClustering/thread/0afdb0fc-2adf-4864-b164-87e24451f875/

    http://support.microsoft.com/kb/929852

    To summarize the information I gathered:

    2 CAS servers with NLB enabled. Each server has two nic's on different networks 10.0.0.0 and 192.168.0.0. I used Multicast mode.

    When I enabled the NLB on the second server I was unable to use the nic, it became out of operation. I did the following operations to fix the problem:

    1, Disabling IPv6, disable tcp offload and disable chimney:

    Disable TCP Offload
    Open up regedit and change the value DisableTaskOffload to 1:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload


    Disable Chimney
    To see the current status, open up an elevated Command-Prompt and type:
    netsh int tcp show global

    Verify that Chimney Offload state is set to disabled.

    To disable type:
    netsh int ip set chimney=disabled



    2, Disable IPv6
    IPv6 should be disabled on the CAS-servers in order for Outlook Anywhere to operate correctly.

    Disable on each nic

        Start regedit.exe
        Go to the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
        Create the following registry entry:
    Name:        DisabledComponents
    Type:        DWORD (32-bit Value)
    Value (Hexadecimal):    ffffffff
        Close regedit.exe
        Restart the server for the changes to be activated

    3, enable IP forwaring on the Public nic

    netsh interface ipv4 set int "[name of the Cluster NIC]" forwarding=enabled

    4, Add multicast MAC address to router

    Find MAC address of VIP from Properties ==> Cluster Parameters of the NLBMGR

    Add arp command to Cisco switch - arp [VIP] [VIP MAC] ARPA

    I did all of the above, but I would recommend others to apply each step and test. I'm not an expert at this so please read before taking my word for this. It worked for me though.

    Mike







    • Marqué comme réponse Stokie Mike vendredi 13 avril 2012 12:38
    • Modifié Stokie Mike vendredi 20 avril 2012 16:40
    vendredi 13 avril 2012 12:38