none
Could not find remote SQL Server - what permissions do I need?

    Question

  • Hi,

    I am trying to specify my SQL instance for WSUS on Windows Server 2012 but I keep getting an error staging the SQL Server could not be found (That standard error). The user I am installing/adding this role as, does have SQL permissions on the sql server (dbcreator/security admin). 

    What else does he need?

    mardi 2 avril 2013 23:33

Réponses

  • Hi,

    Pls try to turn off the firewall on your sql server to see whether it works.Also,make sure that the WSUS server computer had the admin privilege on the SQL server.

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    mercredi 3 avril 2013 06:44
  • Hi,

    I am trying to specify my SQL instance for WSUS on Windows Server 2012 but I keep getting an error staging the SQL Server could not be found (That standard error). The user I am installing/adding this role as, does have SQL permissions on the sql server (dbcreator/security admin). 

    What else does he need?

    It also somewhat depends on where/how you installed SQL Server.

    If SQL Server is installed on a named instance on a remote system, then the WSUS server will need to be able to query the SQL Browser service to get the dynamic port that the named instance is bound to. Quite often the SQL Browser service is not running, or port 1434(UDP) is not accessible through a host firewall.

    If you're using a named instance, be sure you are specifying the connection name correctly, e.g. SERVERNAME\INSTANCENAME in the WSUS dialog.

    Regarding role memberships, dbcreator/secadmin are not sufficient role memberships. The install account needs to be a member of the 'sysadmin' server role, or 'dbcreator' and 'diskadmin'. (This information got lost in the recent revision of the documentation. You can find it in Appendix B of the WSUS3SP1 Deployment Guide.)

    Also, both servers must be members of the same domain (or domains with bi-directional trusts), and SQL Server must be configured to use Windows Authentication (not Mixed-Mode). Also verify that SQL Server is configured to listen for TCP/IP connections.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    mercredi 3 avril 2013 22:48

Toutes les réponses

  • Hi,

    Pls try to turn off the firewall on your sql server to see whether it works.Also,make sure that the WSUS server computer had the admin privilege on the SQL server.

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    mercredi 3 avril 2013 06:44
  • Hi,

    I am trying to specify my SQL instance for WSUS on Windows Server 2012 but I keep getting an error staging the SQL Server could not be found (That standard error). The user I am installing/adding this role as, does have SQL permissions on the sql server (dbcreator/security admin). 

    What else does he need?

    It also somewhat depends on where/how you installed SQL Server.

    If SQL Server is installed on a named instance on a remote system, then the WSUS server will need to be able to query the SQL Browser service to get the dynamic port that the named instance is bound to. Quite often the SQL Browser service is not running, or port 1434(UDP) is not accessible through a host firewall.

    If you're using a named instance, be sure you are specifying the connection name correctly, e.g. SERVERNAME\INSTANCENAME in the WSUS dialog.

    Regarding role memberships, dbcreator/secadmin are not sufficient role memberships. The install account needs to be a member of the 'sysadmin' server role, or 'dbcreator' and 'diskadmin'. (This information got lost in the recent revision of the documentation. You can find it in Appendix B of the WSUS3SP1 Deployment Guide.)

    Also, both servers must be members of the same domain (or domains with bi-directional trusts), and SQL Server must be configured to use Windows Authentication (not Mixed-Mode). Also verify that SQL Server is configured to listen for TCP/IP connections.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    mercredi 3 avril 2013 22:48
  • Hi,

    Clarence - firewall was off but I added the computer account as a local admin to the SQL server.

    Lawrence - I will try your suggestions. It's a default instance in the same domain.

    jeudi 4 avril 2013 13:27