locked
Windows Disk Image Burner not working

    Question

  • I am running Windows Server 2008 R2 on my laptop.  When logged on with a domain account that has admin rights and I run Windows Disk Image Burner, it says that I don't have a burner with, "A disc burner wasn't found. Make sure that a burner is installed properly, and you have the appropriate permission to burn a disc."  If I log off and log on locally as THE 'Administrator', it works great so I am guessing that its a permissions thing.

    How do I set 'burn a disc' permissions?  Or is this something else?
    vendredi 23 octobre 2009 18:24

Réponses

  • Mike Poz wrote the following in this link:
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/988dcab2-f8ec-404b-9e11-2f3c0116b8ef
     
    “There are two ways to do this using accounts that are not the LocalSystem\Administrator account and honestly neither are recommended because both greatly reduce security on your server system.
     
    "The first is to kill the Explorer.exe process and then relaunch Explorer fully elevated.  This has the side effecf of making *every* process you launch also fully elevated, including any malware or viruses that you happen to come across in IE when clicking around the internet. You would have to do this after each reboot so this is the lesser of the two evils.
     
    "The second is to turn off UAC.  This is the greater of the two evils because it persists across reboots.
     
    "Again, neither of these things are recommended, however it is your system and if you choose to do either of these things it is the complete knowledge that you are doing this against advice due to the fact that you are compromising the server's security. 
     
    "I cannot stress strongly enough that you should NOT do either of these things if you are intent on maintaining the security of your server system.
     
    "Thanks!
    "Mike Poz [MSFT]”
     
    I tried both and they both work.  I just wish there was a way to always allow a user with administrator rights to burn a CD/DVD without having to crash Explorer or turn off UAC.  It is ridiculous to me that that is not possible.
     
    I do not see how, on a server OS, it is a security risk for a user with administrative rights to burn a disk.
     
    • Marqué comme réponse DrewW NFS mardi 15 décembre 2009 21:27
    mardi 15 décembre 2009 21:27

Toutes les réponses

  •    I guess it needs admin privilege. Only The administrator account has this by default. Can you start the program with "runas administrator" option?

    Bill
    samedi 24 octobre 2009 01:17
  • I tried but I don't know how.  The only place I have found it is by right-clicking on an ISO file and it comes up with Burn Disk Image.  I don't see a application anywhere on which to right-click.  How would I "runas administrator" on a right-click command?
    samedi 24 octobre 2009 20:18
  • Hi

    Here this go link to resolve your issue

    http://social.answers.microsoft.com/Forums/en-US/vistahardware/thread/bbc4b488-9679-4e3f-b40e-bef09de9240a

    Deva --Self-trust is the first secret of success.
    lundi 26 octobre 2009 00:53
  • My disk burner isn't broken...it works just fine.  It works when I log on using the local 'Administrator' account...I can insert a blank CD/DVD, right-click on an ISO file, select 'Burn disk image', 'Windows Disk Image Burner' pops up and I burn the image to disk.  If I log onto the domain using an account with admin rights on the local machine (account is in the Domain Admins group which is in the local Administrators group), and do the same thing, it is as if I didn't have a burner in the machine and I get the following message:

    "A disc burner wasn't found. Make sure that a burner is installed properly, and you have the appropriate permission to burn a disc."

    Since it works just fine if I log on using the local 'Administrator' account, it is installed properly.
    lundi 26 octobre 2009 03:34
  • Same thing happened to me this morning. Do you have Nero installed on your R2 box? I had to toggle the burning rights "off for everyone" then reboot, toggle them back on, reboot, then it worked fine. I had installed the latest windows updates and rebooted right before this problem started.
    jeudi 29 octobre 2009 14:30
  • How do you toggle burning rights?
    jeudi 29 octobre 2009 15:59
  • Does anyone know how to toggle burning rights or set burning rights or set burning permissions?
    vendredi 30 octobre 2009 21:49
  • I found a workaround.
    As we are talking about Windows Server, I opened a remote desktop connection to myself !!!
    I logged with the local administrator and I solved the problem without waiting another hotfix.
    Maybe it will be solved in the future, but for the moment I am pleased.
    • Marqué comme réponse David Shen lundi 2 novembre 2009 08:19
    • Non marqué comme réponse DrewW NFS mercredi 4 novembre 2009 01:51
    dimanche 1 novembre 2009 12:17
  • I tried that and it worked, but that is rediculous.  Certainly, there should be a way to logon to a Windows Server 2008 R2 member server that has a CD/DVD burner with a domain account that is in the 'Domain Admins' global group (which is by default added to the local 'Administrators' group when the member server is added to the domain) so therefore has administrative rights on the local machine to burn a disk using the built-in application, 'Windows Disk Image Burner'.

    If I have to modify permissions or rights or the registry, there has to be a way.  Anyone know?
    mercredi 4 novembre 2009 01:51
  • I posted this in the Microsoft forums for Microsoft Partners...even Microsoft can't figure it out!
    • Proposé comme réponse ls01c jeudi 19 novembre 2009 09:19
    • Non proposé comme réponse DrewW NFS vendredi 11 décembre 2009 15:41
    dimanche 15 novembre 2009 05:01
  • please take a look of this thread http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/988dcab2-f8ec-404b-9e11-2f3c0116b8ef

    hope that helps!!


    i miss clicked the propose as answer of DrewW NFS's reply. Please ignore that.
    Wonder why there isnt any way to undo it.
    • Marqué comme réponse David Shen mardi 24 novembre 2009 08:15
    • Non marqué comme réponse DrewW NFS vendredi 11 décembre 2009 15:40
    jeudi 19 novembre 2009 02:14
  • I finally broke down and installed ImgBurn (http://www.imgburn.com).  If I just run ImgBurn, it exhibits the same behavior as the built-in 'Windows Disk Image Burner'.  But if I right-click ImgBurn and select ‘Run as administrator’, it works just fine.  However, I want to run the built-in 'Windows Disk Image Burner' by right-clicking an ISO file and selecting ‘Burn disk image’.  How do I change a right-click command to run with fully elevated privileges (run as if you right-clicked a process and selected ‘Run as administrator’)?
     
    I would like to use ImgBurn without having to right-click and ‘Run as administrator’.  How do I run a program with  fully elevated privileges without right-clicking and ‘Run as administrator’?  (I would be okay with modifying a shortcut.)
     
    vendredi 11 décembre 2009 15:41
  • With ImgBurn, located at "C:\Program Files (x86)\ImgBurn\ImgBurn.exe", I was able to right-click on the .exe, Compatibility, Run this program as an administrator.  Now when I right-click on an ISO and choose “Burn using ImgBurn”, it works (as does all burning functions in ImgBurn).
     
    With isoburn.exe (the built-in application, 'Windows Disk Image Burner') located at “C:\Windows\System32\isoburn.exe”, I could not set the properties on the .exe due to the tighter default permissions on Windows Server 2008 R2.  So the right-click on an ISO and choosing “Burn disk image” (which is the built-in ‘Windows Disk Image Burner’) does not work.
     
    • Marqué comme réponse DrewW NFS vendredi 11 décembre 2009 21:34
    • Non marqué comme réponse DrewW NFS mardi 15 décembre 2009 21:25
    vendredi 11 décembre 2009 21:34
  • Mike Poz wrote the following in this link:
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/988dcab2-f8ec-404b-9e11-2f3c0116b8ef
     
    “There are two ways to do this using accounts that are not the LocalSystem\Administrator account and honestly neither are recommended because both greatly reduce security on your server system.
     
    "The first is to kill the Explorer.exe process and then relaunch Explorer fully elevated.  This has the side effecf of making *every* process you launch also fully elevated, including any malware or viruses that you happen to come across in IE when clicking around the internet. You would have to do this after each reboot so this is the lesser of the two evils.
     
    "The second is to turn off UAC.  This is the greater of the two evils because it persists across reboots.
     
    "Again, neither of these things are recommended, however it is your system and if you choose to do either of these things it is the complete knowledge that you are doing this against advice due to the fact that you are compromising the server's security. 
     
    "I cannot stress strongly enough that you should NOT do either of these things if you are intent on maintaining the security of your server system.
     
    "Thanks!
    "Mike Poz [MSFT]”
     
    I tried both and they both work.  I just wish there was a way to always allow a user with administrator rights to burn a CD/DVD without having to crash Explorer or turn off UAC.  It is ridiculous to me that that is not possible.
     
    I do not see how, on a server OS, it is a security risk for a user with administrative rights to burn a disk.
     
    • Marqué comme réponse DrewW NFS mardi 15 décembre 2009 21:27
    mardi 15 décembre 2009 21:27