none
RDS logs out immediately after logging in

    Question

  • i have 2  windows 2008 r2 rds servers that are fully patched.

    in the last 10 days ive noticed that any newly created users cannot log in. Well it does login....runs through all the login process and gets through preparing desktop and right before you get a desktop it logs you off.

    An error 1521 is logged.

    Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you log off. This error may be caused by network problems or insufficient security rights.

    DETAIL - Access is denied.

    I am not sure why. Access denied to what? Nothing has changed. This is new users only. Users with a cached profile are fine. They can login.

    IN troubleshooting ive removed any recently installed updates although nothign has been installed in past 10 days when it was working properly.

    Im pretty sure it is related to the default profile on both.

    I have checked the profilelist registry key and this isnt getting populated as expected.

    I am out of ideas. I have checked permissions on the default profile folder on a default load of a 2008 rds server with this one and they are the same

    I have removed all the group policy on the user server and the result is the same.

    is there a way to take the default profile from a fresh load of windows and restore or over write the default profile that doesnt appear to work? I assume the folder has special permssions on it that can just be copied from one server to another across a network.




    • Modifié couch17 vendredi 30 mars 2012 03:46
    vendredi 30 mars 2012 03:36

Réponses

  • Hi,

    This issue may occur if the user profile was corrupted. The cause of this corruption is certainly related to the fact that we use the account to open more than once session in different servers at same time.

    You can try to recreate the profile to see if the same issue still exists.

    Whether you are using roaming profile in your Remote Desktop environments or not? If so, please check if the Mandatory profile configured and also TS "roaming profile" was configured. You can try to disable the roaming profile and create a new user account to login again.


     


    Technology changes life……

    mardi 3 avril 2012 07:12