none
unidentified network

    Question

  • I have a server 2008 r2 enterprise server running hyper-v.  Every reboot the internal nic goes to unidentified network which means i can’t rdp into the machine.  I really don't like having to keep a mouse and whatnot connected.  This machine is the hyper-v host for three vm's..astaro security gateway, astaro command center, and a server 2008 r2 enterprise vm.  After reading tons of posts about this issue i have come to figure out something.  Microsoft once again had a bad design philosophy.  The astaro vm is the gateway for the network.  Since the host machine boots first when it tries to reach out to the internet it can't fin the internet due ot the fact the other vm are still coming up.  I tried putting AD on the host machine but apparently it still is not enough to make it realize it is a domain controller.  The other server 2008 vm is also a domain controller as well as the primary file/print/dns/dhcp server.  The host machine also runs with split dhcp service.  I am curious that if this is setup why can’t windows figure out it is not on a public network and automatically switch back to being a domain network without me having to disable then enable the one offending nic?

    William

    mercredi 22 février 2012 16:55

Réponses

  • If some VM requires that network available services are reachable during the initial stages off boot (such as applications that bind to the NIC, or a database conneciton must happen prior to the OS in the VM being fully loaded) then you must use a "Legacy Network Adapter"

    This Legacy Network Adapter (on the VM) is available during the entire BIOS boot process and is the failback for systems that require networking to be available early in the boot process.

    If you must use the snythetic Network Adapter then your service must be set to delayed start.

    In the case of AD, the services usually come up and the Windows machines eventually connect and all is well.  However, other services that do not have the reconnect logic might not.

    Other issues can be around the Windows Advanced Firewall.  Closed by default.  And it is actively monitoring, so you must set your rules properly.  If you want to guarantee no block on a port, apply your custom rule to all three profiles.


    Brian Ehlert (hopefully you have found this useful) http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    mercredi 22 février 2012 19:29