none
Issue. Install applications from distribution share using WSIM, answer file, and WDS.

    שאלה

  • I have a problem. I'm beginner and I can not figure out, if you can help me plz. I want to install applications and run custom scripts during the installation of Windows 7 (when passing AuditUser or oobe) with WDS server using the Distribution Share and answer file. For example, I want to install Firefox.
    So I create a DS with Firefox installation on the server. D:\Distribution DGMA\$OEM$ Folders\Browser\Firefox\Firefox.exe
    And I create answer file with add synchronous command (do insert the path and pointing to silent install option).

    for auditUser

    for auditUser
    
    - <settings pass="auditUser">
    - <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <RunSynchronous>
    - <RunSynchronousCommand wcm:action="add">
      <Order>1</Order> 
    - <Credentials>
      <Domain>wds.intra.net</Domain> 
      <Password>pass123!</Password> 
      <Username>admin</Username> 
      </Credentials>
      <Path>\\WIN-QLDB7KMTHBT\Distribution DGMA\$OEM$ Folders\Browser\Firefox\Firefox.exe /S</Path> 
      <Description>Firefox setup</Description> 
      </RunSynchronousCommand>
      </RunSynchronous>
      </component>
      </settings>

    for OOBe

    - <OOBE>
      <HideEULAPage>true</HideEULAPage> 
      <NetworkLocation>Work</NetworkLocation> 
      <ProtectYourPC>1</ProtectYourPC> 
      <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE> 
      </OOBE>
      <TimeZone>FLE Standard Time</TimeZone> 
      <RegisteredOrganization>DDMA</RegisteredOrganization> 
      <RegisteredOwner>DDMA</RegisteredOwner> 
    - <FirstLogonCommands>
    - <SynchronousCommand wcm:action="add">
      <Order>1</Order> 
      <CommandLine>\\WIN-QLDB7KMTHBT\Distribution DGMA\$OEM$ Folders\Browser\Firefox\Firefox.exe /S</CommandLine> 
      <Description>firefox</Description> 
      <RequiresUserInput>true</RequiresUserInput> 
      </SynchronousCommand>
      </FirstLogonCommands>
      </component>
      </settings>
    I expect to install firefox but nothing happens. I was guided to help WSIM doc and Technet doc. Tell me please what I am doing wrong and where I resolved to seek, or provide right information link . Thank you very much. Regards!

    יום רביעי 16 מאי 2012 05:47

כל התגובות

  • Hi,

    In the WDS, you need to capture the reference computer that Firefox installed then import the image to the WDS server.

    For the detailed procedures to create an install image, you could refer to the link below:

    Title: Windows Deployment Services Deployment Guide
    URL: http://technet.microsoft.com/en-us/library/cc770667(v=ws.10).aspx

    If you would like install the application during the OS installation processing, you could use Microsoft Deployment Toolkit (MDT) to make it possible. Just like the figure below:

     

    For the detailed information about the MDT, there is a link for your reference:

    Title: Microsoft Deployment Toolkit
    URL: http://technet.microsoft.com/en-us/solutionaccelerators/dd407791.aspx

    Regards,
    James


    James Xiong

    TechNet Community Support

    יום חמישי 17 מאי 2012 07:09
    מנחה דיון
  • Oh thank you James very much.

    But I would like to learn how to use the $OEM$ Folders (in DS ) that would copy the folder and files during of installation.How does it work? For example, I created a folder $OEM$ Folders/$1/setup in my distribution share ,but it is not copied to the disc C after installation.

    Regards!

    שבת 19 מאי 2012 05:15
  • Oh thank you James very much.

    But I would like to learn how to use the $OEM$ Folders (in DS ) that would copy the folder and files during of installation.How does it work? For example, I created a folder $OEM$ Folders/$1/setup in my distribution share ,but it is not copied to the disc C after installation.

    Regards!

    Hi,

    If you would like to add files and folders by using $OEM$ folders, there is a link for your reference:

    Title: Add Files and Folders by Using $OEM$ Folders

    URL: http://technet.microsoft.com/en-us/library/dd744507(v=ws.10).aspx

    If you would like to add an application, you could refer to the link below:

    Title: Add an Application

    URL: http://technet.microsoft.com/en-us/library/dd799249(v=ws.10)

    Regards,

    James


    James Xiong

    TechNet Community Support

    יום שישי 01 יוני 2012 02:34
    מנחה דיון