none
Event ID: 10010 DCOM error

    Pertanyaan

  • When I started my Server Manager in Win2008R2, Application Server Role had an error event logged.

    This event seems to have popped up after SQL Server 2008 R2 post-installation reboot.

    The server {84AC6BE7-8CF2-4E67-A80E-32ACD3D7C381} did not register with DCOM within the required timeout.

    This GUID seems to be for symentic computer security, as I have one installed.

    I checked the registry but could not find this GUID under HKEY_CLASSES_ROOT -> CLSID.

    Any help?

    21 Februari 2012 4:00

Jawaban

  • Hi,

    This issue can be caused by the incorrect permissions.

    I would like to suggest you perform the following suggestions to troubleshoot this issue:

    1. Run Regedit to launch Registry Editor.
    2. Navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{B292921D-AF50-400c-9B75-0C57A7F29BA1}].
    3. Right click on {84AC6BE7-8CF2-4E67-A80E-32ACD3D7C381} and select Permissions.
    4. Click Advanced button and switch to Owner tab.
    5. Highlight Administrators group and click OK
    6. Highlight SYSTEM and Administrators group, check the Full Control boxes under Allow and click OK.
    7. Run dcomcnfg to launch Component Services.
    8. Expand Computers\My Computer\DCOM Config\NAP Agent Service.
    9. Right click NAP Agent Service and choose Properties.
    10. Switch to Security tab, choose Customize in Launch and Activation permissions label.
    11. Highlight SYSTEM, check all the boxes under Allow and click OK to test the issue.

    Does it work?

    If it does not work, please also perform the following troubleshooting suggesstions to troubleshoot the issue:

    1. In the %windir%/registration folder, make sure that the Everyone group has Read permissions.
    2. In the %windir%/registration folder, make sure that the SYSTEM account has Full Control permissions.
    3. In the %windir%/registration folder, make sure that the Administrators group has Full Control permissions.
    4. In the advanced security properties of the .clb files in the %windir%/registration folder, make sure that the Allow inheritable auditing entries from the parent to propagate to this object and all objects. Include these with entries explicitly defined here option is selected.
    5. Make sure that the Everyone group has one of the following permissions:
    •Traverse permissions (“List Folder Contents”) on all parent directories, including %systemdrive%, %windir%, and %windir%\registration
    •The Bypass traverse checking user right
    To assign the Bypass traverse checking user right to the Everyone group, follow these steps:

    1. Click Start, click Run, type gpedit.msc, and then click OK.
    2. Expand Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand User Rights Assignment.
    3. Right-click Bypass traverse checking, and then click Properties.
    4. Click Add User or Group.
    5. Type Everyone, and then click OK.

    Note: If you receive a message that an object named "Users" cannot be found, click Object Types, click to select the Groups check box, and then click OK two times.

    For more troubleshooting suggestions, please also refer to the following links:

    DistributedCOM Error ID 10010 
    http://social.technet.microsoft.com/Forums/en-SG/winservergen/thread/77b1db1d-f186-4515-8f7d-2241942eb9b7

    Event ID 10010 — COM General Functionality
    http://technet.microsoft.com/en-us/library/cc774175(WS.10).aspx

    Event ID: 10010 Source: DCOM
    http://eventid.net/display.asp?eventid=10010&eventno=508&source=DCOM&phase=1

    Regards,


    Arthur Li

    TechNet Community Support

    22 Februari 2012 8:12
    Moderator

Semua Balasan

  • When I started my Server Manager in Win2008R2, Application Server Role had an error event logged.

    This event seems to have popped up after SQL Server 2008 R2 post-installation reboot.

    The server {84AC6BE7-8CF2-4E67-A80E-32ACD3D7C381} did not register with DCOM within the required timeout.

    This GUID seems to be for symentic computer security, as I have one installed.

    I checked the registry but could not find this GUID under HKEY_CLASSES_ROOT -> CLSID.

    Any help?

    21 Februari 2012 4:02
  • A did a little bit of research.. it looks like a DCOM permissions issue.

    This is from the Symantec website:

    1. Go to run and type   Start DCOMCNFG,Computer>My Computer> Sesclu
    2. Click the Security tab.
    3. Click Custom Access permissions, click Edit, and then click OK. The Custom access permissions are registered.
    4. Restart the machine

    http://support.microsoft.com/kb/246054

    Cheers.


    LinkedIn

    21 Februari 2012 4:19
  • Hi,

    This issue can be caused by the incorrect permissions.

    I would like to suggest you perform the following suggestions to troubleshoot this issue:

    1. Run Regedit to launch Registry Editor.
    2. Navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{B292921D-AF50-400c-9B75-0C57A7F29BA1}].
    3. Right click on {84AC6BE7-8CF2-4E67-A80E-32ACD3D7C381} and select Permissions.
    4. Click Advanced button and switch to Owner tab.
    5. Highlight Administrators group and click OK
    6. Highlight SYSTEM and Administrators group, check the Full Control boxes under Allow and click OK.
    7. Run dcomcnfg to launch Component Services.
    8. Expand Computers\My Computer\DCOM Config\NAP Agent Service.
    9. Right click NAP Agent Service and choose Properties.
    10. Switch to Security tab, choose Customize in Launch and Activation permissions label.
    11. Highlight SYSTEM, check all the boxes under Allow and click OK to test the issue.

    Does it work?

    If it does not work, please also perform the following troubleshooting suggesstions to troubleshoot the issue:

    1. In the %windir%/registration folder, make sure that the Everyone group has Read permissions.
    2. In the %windir%/registration folder, make sure that the SYSTEM account has Full Control permissions.
    3. In the %windir%/registration folder, make sure that the Administrators group has Full Control permissions.
    4. In the advanced security properties of the .clb files in the %windir%/registration folder, make sure that the Allow inheritable auditing entries from the parent to propagate to this object and all objects. Include these with entries explicitly defined here option is selected.
    5. Make sure that the Everyone group has one of the following permissions:
    •Traverse permissions (“List Folder Contents”) on all parent directories, including %systemdrive%, %windir%, and %windir%\registration
    •The Bypass traverse checking user right
    To assign the Bypass traverse checking user right to the Everyone group, follow these steps:

    1. Click Start, click Run, type gpedit.msc, and then click OK.
    2. Expand Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand User Rights Assignment.
    3. Right-click Bypass traverse checking, and then click Properties.
    4. Click Add User or Group.
    5. Type Everyone, and then click OK.

    Note: If you receive a message that an object named "Users" cannot be found, click Object Types, click to select the Groups check box, and then click OK two times.

    For more troubleshooting suggestions, please also refer to the following links:

    DistributedCOM Error ID 10010 
    http://social.technet.microsoft.com/Forums/en-SG/winservergen/thread/77b1db1d-f186-4515-8f7d-2241942eb9b7

    Event ID 10010 — COM General Functionality
    http://technet.microsoft.com/en-us/library/cc774175(WS.10).aspx

    Event ID: 10010 Source: DCOM
    http://eventid.net/display.asp?eventid=10010&eventno=508&source=DCOM&phase=1

    Regards,


    Arthur Li

    TechNet Community Support

    22 Februari 2012 8:12
    Moderator