none
Hypev "automatic start action" not retained after live motion

    質問

  • Hi,

    We have a hyper-v cluster of 2 windows 2008 R2SP1 nodes.

    We found that the settings we made in the VMs "automatic start action" were reset to "none" after migration between the nodes .

    We need to have it maintaned

    thanks

    Stefano

    2012年4月15日 11:51

回答

  • Hi Stefano,

    Thanks for your reply. Actually this is a by design in current version of Hyper-V.

    When you say

    "If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host."

    you mean that it is supposed to work this way ?

    A: Yes, this is a by design behavior.

    I mean , If you make a VM HA with clustering is it an accepted behaviour that the setting of " automatic start action " ( not the stop action you posted the picture of ) is not maintaned after a live migration even if such setting is made through the failover cluster manager ?

    A: I post the offline action in my previous email. Actually, you can also set the startup action on Policies tab.

    If you are telling me that this is what it is supposed to work I don't agree.

    A: Actually this is decribed in the following article. Please go through the folloing link:

    Hyper-V: Using Hyper-V and Failover Clustering
    http://technet.microsoft.com/en-us/library/cc732181(v=WS.10).aspx

    Thanks for your understanding. Please let me know if anything is unclear.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2012年5月2日 10:25

すべての返信

  • Where did you Change this setting?

    If you have changed the setting in the Hyper-V Manager Console and not in the Failover Cluster Manager you have to make sure you have refreshed the Virtual Machine in the Failover Cluster Manager. Otherwise Settings can be lost after a Live Migration.

    http://technet.microsoft.com/en-us/library/dd759135.aspx


    http://www.thomasmaurer.ch

    2012年4月15日 12:26
  • I changed the setting directly from the cluster manager

    Thanks

    SC

    2012年4月15日 12:56
  • Anyway I did also make the change from Hyper-v manager and refreshing it from the cluster manager

    2012年4月15日 13:02
  • Hello ,

    anyone can help with this ?

    thanks

    2012年4月17日 3:17
  • Hi,
     
    Please try to set the auto start option on the cluster resource group. See the following blog post:
     
     

    Vincent Hu

    TechNet Community Support

    2012年4月17日 7:43
  • Hello Vincent ,

    We already set that option , but it does not enable us to set a different start timeout for each VM Group.

    thanks

    SC

    2012年4月17日 9:12
  • Hi ,

    Automatic actions let you automatically manage the state of the virtual machine when the Hyper-V Virtual Machine Management service starts or stops. However, when you make a virtual machine highly available, the management of virtual machine state should be controlled through the Cluster service. In this step, you reconfigure the automatic start action for the virtual machine.

    To reconfigure automatic start action for the virtual machine
    In Hyper-V Manager, under Virtual Machines, select FailoverTest, the virtual machine that you created, and then in the Action pane, under the virtual machine name, click Settings.

    In the left pane, click Automatic Start Action.

    Under What do you want this virtual machine to do when the physical computer starts, click Nothing and then click Apply.

    Then modify the settings of a virtual machine in Failover Cluster manager.
    If you change the configuration of a virtual machine, we recommend that you use the Failover Cluster Manager snap-in to access the virtual machine settings. When you do this, the cluster is updated automatically with the configuration changes. However, if you make changes to the virtual machine settings from the Hyper-V Manager snap-in, you must update the cluster manually after you make the changes. If the configuration is not refreshed after networking or storage changes are made, a subsequent failover may not succeed or may succeed but result in the virtual machine being configured incorrectly.

    Change the Virtual machine stop action via the Setting Tab of the Virtual Machine Properties.

    More information:

    Hyper-V: Using Hyper-V and Failover Clustering
    http://technet.microsoft.com/en-us/library/cc732181(v=WS.10).aspx 

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2012年4月20日 11:34
  • Hi Aaron ,

    the steps your provided are exactly what I did .

    However as soon as I do a live migration to the other host such settings were reset to "none"

    Have you been able to test it ?

    thanks

    Stefano

    2012年4月20日 12:06
  • Hi ,

    I think there may be something unclear in my previous email. Ok, I will detail it.

    If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host.

    You should set this via the Cluster Manager by the following setting:

    This is what I said:

    If you change the configuration of a virtual machine, we recommend that you use the Failover Cluster Manager snap-in to access the virtual machine settings. When you do this, the cluster is updated automatically with the configuration changes. However, if you make changes to the virtual machine settings from the Hyper-V Manager snap-in, you must update the cluster manually after you make the changes. If the configuration is not refreshed after networking or storage changes are made, a subsequent failover may not succeed or may succeed but result in the virtual machine being configured incorrectly.

    Thanks. Feel free to let me know if anything is unclear.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    2012年4月25日 8:37
  • Hi ,

    I think there may be something unclear in my previous email. Ok, I will detail it.

    If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host.

    You should set this via the Cluster Manager by the following setting:

    This is what I said:

    If you change the configuration of a virtual machine, we recommend that you use the Failover Cluster Manager snap-in to access the virtual machine settings. When you do this, the cluster is updated automatically with the configuration changes. However, if you make changes to the virtual machine settings from the Hyper-V Manager snap-in, you must update the cluster manually after you make the changes. If the configuration is not refreshed after networking or storage changes are made, a subsequent failover may not succeed or may succeed but result in the virtual machine being configured incorrectly.

    Thanks. Feel free to let me know if anything is unclear.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Hi Aaron ,

    yes I think there's a misunderstanding about the question .

    When you say

    "If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host."

    you mean that it is supposed to work this way ?

    I mean , If you make a VM HA with clustering is it an accepted behaviour that the setting of " automatic start action " ( not the stop action you posted the picture of ) is not maintaned after a live migration even if such setting is made through the failover cluster manager ?

    If you are telling me that this is what it is supposed to work I don't agree , because I wish I can have a way to set a priority in VM startup in the case of complete shutdown/reboot .

    Working with vsphere as well this is possible and I thought it was the same with Hyper-v

    To solve this problem I had to create a group policy's startup script for the cluster nodes in which I start the VM in the correct order with some timeout .

    Thanks

    Stefano Colombo

    2012年4月27日 9:21
  • Hi Stefano,

    Thanks for your reply. Actually this is a by design in current version of Hyper-V.

    When you say

    "If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host."

    you mean that it is supposed to work this way ?

    A: Yes, this is a by design behavior.

    I mean , If you make a VM HA with clustering is it an accepted behaviour that the setting of " automatic start action " ( not the stop action you posted the picture of ) is not maintaned after a live migration even if such setting is made through the failover cluster manager ?

    A: I post the offline action in my previous email. Actually, you can also set the startup action on Policies tab.

    If you are telling me that this is what it is supposed to work I don't agree.

    A: Actually this is decribed in the following article. Please go through the folloing link:

    Hyper-V: Using Hyper-V and Failover Clustering
    http://technet.microsoft.com/en-us/library/cc732181(v=WS.10).aspx

    Thanks for your understanding. Please let me know if anything is unclear.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2012年5月2日 10:25
  • Hi Stefano,

    Thanks for your reply. Actually this is a by design in current version of Hyper-V.

    When you say

    "If you make a virtual machine high available, the Automatic Start Action will not work after you perform a live migration. Which means the following setting will not be "failovered" to another host."

    you mean that it is supposed to work this way ?

    A: Yes, this is a by design behavior.

    I mean , If you make a VM HA with clustering is it an accepted behaviour that the setting of " automatic start action " ( not the stop action you posted the picture of ) is not maintaned after a live migration even if such setting is made through the failover cluster manager ?

    A: I post the offline action in my previous email. Actually, you can also set the startup action on Policies tab.

    If you are telling me that this is what it is supposed to work I don't agree.

    A: Actually this is decribed in the following article. Please go through the folloing link:

    Hyper-V: Using Hyper-V and Failover Clustering
    http://technet.microsoft.com/en-us/library/cc732181(v=WS.10).aspx

    Thanks for your understanding. Please let me know if anything is unclear.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2012年5月2日 10:26
  • Thanks Aaron ,

    I understand that such functionality is not yet implemented , the timed start of VM , in current version of clustered Hyperv.

    I really hope the upcoming windows 2012 failover cluster would implement it as it is a serious , in my point of view , flaw compared to the competitor

    thanks

    Stefano Colombo

    2012年5月3日 7:56
  • Hi Stefano,

    Thanks for your understanding. I will try to provide your feedback to production team.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2012年5月3日 12:27
  • I had the unfortunate situation today where I learned this hard way. I previously set up the Automatic Start Action to Always start (partially based on the advice: http://blogs.msdn.com/b/virtual_pc_guy/archive/2009/10/22/setting-up-hyper-v-with-a-ups.aspx). The VMs were probably migrated dozens and dozens of times from that time and it never even crossed my mind that this action does not persist.

    A usual then longer  power outage kicked our UPSes to power down the servers. About 30 or so minutes power was restored and both nodes of our Windows Server 2008 R2 SP1 cluster were brought online...but not a single VM started.

    Am I doing something wrong with my configuration or is this "by design" feature taking its toll. Are there any workarounds, perhaps a PowerShell script that I can run on a daily basis that sets these options? I don't have SC VMM.

    EDIT # 1: a similar thread, where a PowerShell workaround is mentioned: http://social.technet.microsoft.com/Forums/sv/winserverhyperv/thread/bb20a903-e9f8-4144-818e-5f7b1ae2f3f5 . I'd appreciate if someone could share something like this. BTW is this fixed in 2012?

    EDIT #2: Found it: http://pshyperv.codeplex.com/releases/view/38769

    2012年7月12日 20:04
  • BTW - This is not fixed in 2012.  Cluster groups containing VMs do not come on-line after the hosts restart, the autostart settings is still not migrated with the machine config.

    This is, frankly, rubbish.  How are we supposed to automatically start cluster groups on Server 2012?  Powershell?  It should be built-in.


    Matt White
    ( http://systemcenterblog.hardac.co.uk/ - @matthewwhite )

    2013年1月29日 14:28
  • I agree.   I just found this issue a few hours ago testing my 2012 3 node setup.  I need to power the VMs back on after a power outage.   If the setting does not work after migration at least hide the option from me or gray it out.  Don’t let me think I am setting an option only to have it change it on me.  In VMM 2012 SP1 the VM setting for this is missing if it is monitoring a cluster.   (It's there if the host is not in the cluster.)

    On a side note, I have a 8000 APC unit, how do I get my VMs to shutdown then the hosts using the APC software.  Installing the software into each VM is crazy.   Dell and Eaton have ‘VM aware shutdowns.
    I do have VMM 2012 SP1 and am looking at some scripting options.   This power management has to be easier.  What am I missing?   I can't belive this is an oversite.   How are others dealing with this?

    2013年1月29日 19:58
  • I agree.   I just found this issue a few hours ago testing my 2012 3 node setup.  I need to power the VMs back on after a power outage.   If the setting does not work after migration at least hide the option from me or gray it out.  Don’t let me think I am setting an option only to have it change it on me.  In VMM 2012 SP1 the VM setting for this is missing if it is monitoring a cluster.   (It's there if the host is not in the cluster.)

    On a side note, I have a 8000 APC unit, how do I get my VMs to shutdown then the hosts using the APC software.  Installing the software into each VM is crazy.   Dell and Eaton have ‘VM aware shutdowns.
    I do have VMM 2012 SP1 and am looking at some scripting options.   This power management has to be easier.  What am I missing?   I can't belive this is an oversite.   How are others dealing with this?

    What I don't understand is why it IS greyed out, I can understand the auto failback settings being disabled, but why disable the autostart. That means, if one of my hosts crashes as has been the case previously, the host comes back up but the vm's don't auto start which is what you want in most situations!

    2013年3月18日 15:52
  • HI All , Just wanted to say that I previously solved the issue simply implementing a computer startup script , through group policy , which performed a series of "cluster group on " to startup the vm Still waiting for MIcrosoft providing a clever solution ... HTH
    2013年3月18日 19:04
  • Hi, 

    Any news on this? Is Microsoft providing a solution or patch to this problem in 2012 R2?

    Thanks

    2013年8月21日 11:41
  • Hi, 

    Any news on this? Is Microsoft providing a solution or patch to this problem in 2012 R2?

    Thanks

    Still waiting for an answer to this issue as well.
    2014年2月24日 13:48
  • ....still not fixed...any feedback from MS? 
    2014年7月7日 12:46