none
opening PDF with a third party software on RDS server

    질문

  • Hi all,

    I got tired of adobe and found an excellent open source PDf viewer that works very well on our RDS server 2008 R2. it's called SumatraPDF.

    the only problem I am having right now is since windows does not know anything about SumatraPDF, it's having to ask for Open,Save, or cancel prompt. my guess is there's a way to make windows trust this application the same way it trusts adobe so that the files would opening without this prompt.

    of course I could be wrong and the problem might be caused by something enirely different, so I am here asking the experts and hopefully somebody can help.

    any help with this is much appreciated.


    Mohsen Almassud

    2012년 6월 22일 금요일 오후 4:48

답변

  • Robert,

    I was able to resolved this problem. I used Process Monitor and cought the change to the registry and then used a GPP to deploy it and life is good now.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}]
    "SumatraPDF"=hex:00,00,00,00

    Thanks for your help on this.


    Mohsen Almassud

    • 답변으로 표시됨 Mohsen Almassud 2012년 6월 25일 월요일 오후 9:26
    2012년 6월 25일 월요일 오후 9:26

모든 응답

  • Hello,

    To be able to let this work you need to set the file associations for .pdf files. You can do this from Control Panel\Default Programs and select the option "assosciate a file or protocol with a program"

    From there select PDF and select the executable for your program


    regards Robert Maijen

    2012년 6월 22일 금요일 오후 5:15
  • Robert,

    it's already associated with SumatraPDf and it's opening the PDF files, but for non admins they get this prompt.

    Thanks


    Mohsen Almassud

    2012년 6월 22일 금요일 오후 5:26
  • This is probably because it only has been changed for the admin user. You need to change it for all users. You need to set this in registry in the HKLM area. You need to use ftype command to find the correct extension and file type association". Type ftype |more on the command line for help. next you can use the command line tool "assoc" to arrange this for you. Type assoc /? for explanation on how to use assoc.

    Good luck


    regards Robert Maijen


    • 편집됨 Robert Maijen 2012년 6월 22일 금요일 오후 5:44
    2012년 6월 22일 금요일 오후 5:42
  • I used the following commands:

    "C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe" -register-for-pdf
    ftype SumatraPDF.PDFViewer="C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe" %1
    assoc .pdf=SumatraPDF.PDFViewer
    assoc .ashx=SumatraPDF.PDFViewer
    assoc .fdf=SumatraPDF.PDFViewer
    assoc .pdfxml=SumatraPDF.PDFViewer
    assoc .pdx=SumatraPDF.PDFViewer
    assoc .xdp=SumatraPDF.PDFViewer
    assoc .xfdf=SumatraPDF.PDFViewer

    the first one was just for the application to be a replacement for adobe.


    Mohsen Almassud

    2012년 6월 22일 금요일 오후 5:46
  • Please have a look here. It explains it a bit strangly but the outcome is what you are looking for:

    http://www.brianmadden.com/blogs/brianmadden/archive/2004/04/20/creating-custom-file-associations-to-support-side-by-side-applications.aspx


    regards Robert Maijen

    2012년 6월 22일 금요일 오후 6:00
  • Robert,

    I really appreciate you taking the time helping me out with this issue.

    I read through the article and found that I already have the HCKC\software\Classes\.pdf is setup the same way the article mentioned, but of course it's not helping me, because I am still hving this issue.

    I'll read it again to make sure that I didn't miss anything, but I am pretty sure it doesn't apply.

    Thanks


    Mohsen Almassud

    2012년 6월 22일 금요일 오후 6:34
  • Robert,

    I was able to resolved this problem. I used Process Monitor and cought the change to the registry and then used a GPP to deploy it and life is good now.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}]
    "SumatraPDF"=hex:00,00,00,00

    Thanks for your help on this.


    Mohsen Almassud

    • 답변으로 표시됨 Mohsen Almassud 2012년 6월 25일 월요일 오후 9:26
    2012년 6월 25일 월요일 오후 9:26