none
HyperV 2008 Server Core Cluster iSCSI Issue

    질문

  • Hi,

    I have a two node HyperV 2008 Server Core Cluster running with iSCSI connections to an EMC SAN. I have been getting the following error from one host, both are built exactly the same, with the same drivers and same hardware. Although only one is giving the error, when the event is logged the host is slowing down to a standstill, it takes 20 minutes to RDP to any of the VM's on the host and file copy is extremely slow, Server hardware for both Hosts are Dell PowerEdge R515 servers. Does anyone know what might be causing the issue, the event log is listed below:

    The description for Event ID 129 from source iScsiPrt cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.The message has no description.

    This message is logged when the Vista initiator or the Windows Server 2008 initiator sends an iSCSI Task Management command to the target device, and the device (\Device\ScsiPort0) does not respond within the time-out period.

    Thanks,

    Michael.

    2012년 3월 2일 금요일 오후 12:09

답변

모든 응답

  • Are you using an Broadcom NIC? Are you connecting through the same switch? Do the ports in the switch have the same configuration?
    2012년 3월 2일 금요일 오후 7:46
  • Hi,

    Yes the nic that is having the iSCSI issues is a broadcom, however there is a second mpio path configured on an Intel nic. All the switch and port configuration is idential for both paths over two switches. It seems that the faulty Broadcom port causes issues with both paths to the SAN though.

    Is there a known issue with the broadcom switches?

    2012년 3월 2일 금요일 오후 10:08
  • Well there have been several issues with broadcom and server 2008 (R2) in the past with some of them still beeing unsolved. You should make sure that the latest firmware and driver for the nic is installed. Furthermore you should make sure that you are using the iscsi virtual port for mpio and not the nic port itself. Teaming should be disabled when mpio and / or iscsi is used. There are some other points which could affect your system, too.

    Just to give you some hints for problems with broadcom nics:

    http://www.petri.co.il/network-issues-with-windows-server-2008-rdp-on-dell-servers.htm

    http://blog.serverfault.com/2011/03/04/broadcom-die-mutha/

    http://en.community.dell.com/support-forums/servers/f/1466/t/19307750.aspx

    Best advice ever was to take intel nics. We had a lot of troubles with our 11Gen Dell Servers coming with onboard broadcom iscsi nics we finally got a stable iscsi mpio configuration up and running after 3 months of troubleshooting. If you need further information I can send you my sample configuration with the broadcom iscsi and mpio.

    • 답변으로 표시됨 mike_00 2012년 3월 4일 일요일 오후 9:13
    2012년 3월 3일 토요일 오전 8:13
  • Hi Cornelius,

    Thanks for the reply, I will definitely move the iSCSI over to the Intel ports, I think that will resolve the issue. Appreciate the help.

    Michael.

    2012년 3월 4일 일요일 오후 9:14