none
Windows 2008 Task Scheduler Problem

    Întrebare

  • Hi,

    I am using Windows 2008 Std Edition , I have certain number of scheduled task for maintainence activities. whenever i reboot my server all scheduled task stops, means i need to reenter username password to enable scheduled task after reboot. all task are using domain admin account to run all the task. what could be the issue?


    Sunil Pathare System Admin Idealake Information Technologies Pvt.Ltd. www.idealake.com Email:- sunil_pathare@idealake.com
    29 iulie 2009 04:10

Răspunsuri

  • Hello everyone who also have trouble with Win2008 task scheduler VS the need to re-enter the credentials at every reboot.

    This solution is good for me, I don't know if you did the same mistake that I did...

    2 months ago, I created a task with the "hidden" property, thinking that the task is running in "hidden" mode, but it only create a task that I do not see in the task scheduler.

    To delete the task, I went to the registry. (I now know that I could have checked the "show hidden tasks" option)

    It is all configured there:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

    I saw my hidden task in the /Tree folder.  I found the GUID, and I deleted this GUID from the TASKS folder.  But, I forgot to also delete it from the PLAIN zone.  

    What I suppose is that, when the task scheduler is starting, it looks at the tasks in the Plain folder, then try to find the additional configuration (including the credentials) in the Tasks folder.  Because it did not found the key, the task scheduler startup process did an error, and stop from starting the other tasks.

    So, look that EVERY key in the Plain folder (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain) are also present in the Tasks folder (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks).

    Final note to Microsoft:  You can correct your code to continue starting other tasks even if one task is not well configured in the registry.  And, it can be a good idea to send the error to the Event Viewer.

     

    • Propus ca răspuns de Funklet 9 iunie 2010 20:26
    • Marcat ca răspuns de Sunil Pathare 5 mai 2012 04:50
    27 aprilie 2010 19:03

Toate mesajele

  • Hi,

     

    Choose “Run whether user is logged on or not” and “Run with highest privileges”.

     

    Please also verify settings on the Conditions and Settings tabs. Make sure the Task Scheduler service is started and its Startup Type is Automatic.

     

    Related article:

    Troubleshooting Task Scheduler

    http://technet.microsoft.com/en-us/library/cc728001(WS.10).aspx

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    • Propus ca răspuns de iamchenqi 7 iulie 2010 04:52
    30 iulie 2009 06:15
  • I have already done the same steps. but problem occues only when i reboot the server. otherwise it works fime till i reboot the server.
    Sunil Pathare System Admin Idealake Information Technologies Pvt.Ltd. www.idealake.com Email:- sunil_pathare@idealake.com
    31 iulie 2009 09:36
  • Hi,

     

    Thank you for the reply.

     

    Now I suggest trying below:

     

    1. Click Start, type services.msc and press Enter.

    2. Double-click Task Scheduler.

    3. Make sure its Service status is Started and its Startup type is Automatic.

    4. Click OK.

     

    What’s the result now?

     

    Tim Quan - MSFT

    3 august 2009 01:16
  • my problem has not yet resloved.. i have checked all options.


    Sunil Pathare System Admin Idealake Information Technologies Pvt.Ltd. www.idealake.com Email:- sunil_pathare@idealake.com
    10 septembrie 2009 16:14
  • Hello Sunil

    Can u send us the properties of the task that you have ?
    How many task are affecetd ?

    14 septembrie 2009 19:56
  • Have you found a solution to this issue I have the same thing happening.
    23 septembrie 2009 14:55
  • I have exactly the same problem - checked following things:
    - The Service is set to automatically startup
    - The Scheduled Task is set with "Run whether user is loggon on or not"
    - Also I checked the "Run with highest privileges".

    When the server does it's automatic updates and restarts, when it comes back alive, all the scheduled tasks are stopped and stay stopped until I do LOG IN - they suddenly they all start.

    The tasks are set to run "On a Schedule", every day, every 1 minute, indefinetly.

    I'm trying to change them to "At Startup", every 1 minute, indefinetly - I'll let you know if this solved the problem at the next reboot ;-)

    Anyway that's Amazing ... why to complex simple things - it's like italian politics.

    PLEASE Help ...

    BitMSN.
    11 noiembrie 2009 19:13
  • I didn't want to make the server a domain member (What I understood needed to happen to get authentication working) and I scoured to the edge of the earth to try to make it work with no avail.  Workaround, I simply installed bmail command line mailing utility (Free) and scheduled task to run an application.

    bmail script is like this:

    bmail -s smtpserver.tld -t recipent@contsco.com -f sender@domain.com -h -a "Alert Notice Subject" -b "xyz alert has been triggered. Microsoft task alert's via email lick balls."

     

     Thanks,

    -Brian
     

    Brian J. Brandon, CCNP

    Zuit Security Research and Defense

    Http://www.Zuit.net
    9 februarie 2010 12:10
  • Hi,

    Currently having the same issue, did you find a solution to this problem?

    19 februarie 2010 20:55
  • Does the account you're using to schedule the task have the LogonAsBatch user right?
    20 februarie 2010 06:31
  • Oh I finally found some windows 2008 users who had the same trouble.  

    All the same settings than you -

    1. run when user is logged or not
    2. store password
    3. run with highest privileges.

    On every reboot, we must open every task, hit OK, and reenter the password of the selected user who runs the task.

    We think that this trouble began some weeks-months ago and we did not had this trouble before, but we are not sure.

    Hey Microsoft, are you reading this forum? please help us find a solution!

    Thank you.  

    19 aprilie 2010 13:43
  • I found something... I can't test it, because I can't reboot my server "just for fun" :-) but, try remove the "run with hightest privileges" for your tasks...

    I think that on the first login of the user, the UAC ask for password to elevate its rights.  You can also disable the UAC for this user like it is described in this article.

    http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/6db4b661-0904-45af-84d7-7371839b7444 in the local policies configuration.

    I will know if this solution works in about 1 month :-)

    19 aprilie 2010 14:30
  • You can try to run only when user is logged on, untick the run with highest priviledge.

    Under the configure for put: Windows Vista, window server 2008.

    under the trigger tab, click new begin the task on log on.

    under the action tab, click on start a program and the startin put the path name E.g c:\maintainence\runthisfile.exe you put in the startin: c:\maintainence

    Hope it help!

    26 aprilie 2010 03:42
  • Hello everyone who also have trouble with Win2008 task scheduler VS the need to re-enter the credentials at every reboot.

    This solution is good for me, I don't know if you did the same mistake that I did...

    2 months ago, I created a task with the "hidden" property, thinking that the task is running in "hidden" mode, but it only create a task that I do not see in the task scheduler.

    To delete the task, I went to the registry. (I now know that I could have checked the "show hidden tasks" option)

    It is all configured there:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

    I saw my hidden task in the /Tree folder.  I found the GUID, and I deleted this GUID from the TASKS folder.  But, I forgot to also delete it from the PLAIN zone.  

    What I suppose is that, when the task scheduler is starting, it looks at the tasks in the Plain folder, then try to find the additional configuration (including the credentials) in the Tasks folder.  Because it did not found the key, the task scheduler startup process did an error, and stop from starting the other tasks.

    So, look that EVERY key in the Plain folder (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain) are also present in the Tasks folder (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks).

    Final note to Microsoft:  You can correct your code to continue starting other tasks even if one task is not well configured in the registry.  And, it can be a good idea to send the error to the Event Viewer.

     

    • Propus ca răspuns de Funklet 9 iunie 2010 20:26
    • Marcat ca răspuns de Sunil Pathare 5 mai 2012 04:50
    27 aprilie 2010 19:03
  • Hi,

    I had the same problem with the Task Scheduler after reboot. Almost every week Microsoft issue patches that require a reboot, then no scheduled tasks...

    The solution provided by Foxtrott has solved it for me.

    I know that the reason I had a problem was down to somehting that I did (that doesn't excuse Microsoft not fixing this). I think that I deleted a task, the task scheduler hung and I either logged out or killed the task. This was enough to cause a problem.

    I found 2 tasks that had an entry in Plain but not in Tasks. I deleted them from Tasks and now all the tasks are correct after reboot.

    Many thanks for your information about this.

    9 iunie 2010 20:26
  • Thank you for describing your solution as it also solved my problem.  I can only hope that Microsoft fixes this bug, because it's virtually impossible to troubleshoot.  I would not have figured it on my own.  I think more people are running into to this issue than MS imagines.  In my case I had an orphaned entry under the Plain key.
    24 iunie 2010 23:02
  • Make sure the scheduled task startup  type is automatic.
    7 iulie 2010 04:54
  • Hi all.

    After a lot of time being mesmerized by this, me and my co-worker got to understand one of the reasons why this happens.

    It went down like this :

    1 -> Launch Task Scheduler

    2- > Choose the "Actions" tab. Choose the program you want to run.

    3 -> Here is the "fun" part : it's not enough to tell Task Scheduler where the executable is, it seems you also have to fill the "Start In (optional)" field with the correspondent directory path (I guess telling Windows what the executable is just doesn't cut it, maybe it thinks one is trying to run a program on another server... or planet.. ). The user that runs the task has to have full administrator control over the directories, files, etc...

     

    I really hope this helps!

     

    T.

    29 august 2011 12:19
  • Hi all,

     

    the suggestion (point 3) provided by Groove Dev worked with me:

    Filling the "Start In (optional)" field with the correspondent directory path has been successfull.

     

    Thanks.

     

    Massimo

    7 septembrie 2011 10:03
  • Worked for me as well.

     

    It was a simple need of adding the "Start in" field.

    14 decembrie 2011 16:16
  • My situation was different. I can run the executable directly, it didn't work run by schedule task. The job showed ran successfully, but nothing happen. After fill the "Start In (optional)" field with the correspondent directory path. It works. Thanks for the tips.
    29 martie 2012 21:11
  • Solução efetiva:

    Srs, Resolvi.

    O causador do erro era uma opção de segurança que estava HABILITADA:

    Política: not allow storage of passwords and credentials for network authentication

    Para funcionar e conseguir gravar a tarefa com a opção "Run whether use ris logged on or not" marcada é preciso que a política acima esteja DESABILITADA.

    Testei habilitando e desabilitando manualmente e de fato era isso.

    O mais interessante é que por padrão esta opção vem desabilitada, mas no meu caso estava sendo foçada por uma GPO de domínio.

    ESPALHEM A SOLUÇÃO, POIS PERCEBI QUE TEM MUITA GENTE COM ESSE PROBLEMA

    Se possível, qualifiquem. Grato.
    26 aprilie 2012 21:00
  • Thanks for help. It seems like optional but it must. Microsoft is "best"... beer in the world :)
    1 mai 2012 14:21