none
Windows 7 - Power Options Extension - Power Policy is not set as active on the clients...

    คำถาม

  • Hi

    i have a W2008 / R2 only domain with 64Bit Windows7 clients


    i create a new Userconfiguration (!) Power Policy for Vista/Windows7 Pcs named "NWPro".
    i marked the Option "set as the active Power Plan" !
    The Policy got applied to the pcs, if i logg on to a pc i can see the new created Policy "NWPro" - the Problem is - the policy is NOT (!) set active.

    2nd Problem i set "User do not have to enter a password after standby" but if i check the setting on the pc, it is not configurured correctly.
    (all other settings from NWPro are correctly transmitted)

    does anyone know, why "set as active Power Plan" does not work, are there any issues with that?
    19 มกราคม 2553 11:33

ตอบทั้งหมด

  • Hi

    i have a W2008 / R2 only domain with 64Bit Windows7 clients


    i create a new Userconfiguration (!) Power Policy for Vista/Windows7 Pcs named "NWPro".
    i marked the Option "set as the active Power Plan" !
    The Policy got applied to the pcs, if i logg on to a pc i can see the new created Policy "NWPro" - the Problem is - the policy is NOT (!) set active.

    2nd Problem i set "User do not have to enter a password after standby" but if i check the setting on the pc, it is not configurured correctly.
    (all other settings from NWPro are correctly transmitted)

    does anyone know, why "set as active Power Plan" does not work, are there any issues with that?
    I'm experiencing the same exact problem with a power plan GP Preference on Win7.  I created a Computer config power plan, and it does get applied to the machine successfully, however it is not marked as active by default as I have it configured.  I enabled GP Preference logging and the logs indicate that no errors were generated while applying the plan.  I have found that if you force a group policy update manually (gpupdate /force) the power plan *is* set as active in the Control Panel Power Options dialog, however the registry key associated with setting the preferred active power plan is not updated from the default "Balanced" plan.  (This key is HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D\PreferredPlan)
    9 กุมภาพันธ์ 2553 20:40
  • Same issue here.  I can create a new Power Plan in Group Policy that I can see in the control panel of the machines, but even though I specified "Set as the active power plan", the new plan is not active.

    If I Update an existing plan like High Performance, and set that as active, it works and becomes the active plan, but that doesn't happen with the new plans I create.

    Any clues?

    24 มีนาคม 2553 16:00
  • With Action "Create" or "Replace" I can reproduce the behavior you described.
    With "Update" it works fine for me.
    You custom plan will be created by action "Update" if it is not there yet. 
    Patrick
    • เสนอเป็นคำตอบโดย Nathan H 22 ตุลาคม 2553 8:58
    18 พฤษภาคม 2553 7:10
  • The "Set as Active Power Plan" check box sets the power plan selected right above it as active.  If you uncheck it, then the policy you have customized is applied, and not one of the built in policies (ie, Balanced or High Performance).
    • เสนอเป็นคำตอบโดย Nathan H 22 ตุลาคม 2553 8:58
    25 มิถุนายน 2553 1:38
  • mine problem is involve with yours.

    i've created a new power plan. it does show up on the power scheme @ the station , the problem is that it always has the same default settings which turn off the monitor after 1 minute and require password on resume.

    is anyone have an idea?

    9 กุมภาพันธ์ 2554 12:05
  • With Action "Create" or "Replace" I can reproduce the behavior you described.
    With "Update" it works fine for me.
    You custom plan will be created by action "Update" if it is not there yet. 
    Patrick

    The Update option worked for me as well. I often have problems using the Replace function of some policies. Thanks for the help!
    30 มีนาคม 2554 14:18
  • With Action "Create" or "Replace" I can reproduce the behavior you described.
    With "Update" it works fine for me.
    You custom plan will be created by action "Update" if it is not there yet. 
    Patrick

    Thank you Patrick. This solved it for me as well.
    29 กุมภาพันธ์ 2555 6:10
  • I've been messing around with this same issue and found a possible solution. This has been my experience:

    When setting the action to "create" the policy is created, but never set active.

    When setting the action to update the policy is created, but initially not set active. If I run gpupdate a second time it is then set active. I guess this isn't a huge issue, but it would be nice to do it all in one shot without having to wait for group policy to refresh on the machine.

    What worked for me was to create 2 power plans with the same name and set the first one to create and the second to update. This created the plan and set it to active every time. 


    • แก้ไขโดย red888 6 มิถุนายน 2556 16:37
    26 เมษายน 2555 17:00
  • I've been messing around with this same issue and found a possible solution. This has been my experience:

    When setting the action to "create" the policy is created, but never set active.

    When setting the action to update the policy is created, but initially not set active. If I run gpupdate a second time it is then set active. I guess this isn't a huge issue, but it would be nice to do it all in one shot without having to wait for users to log off and on again.

    What worked for me was to create 2 power plans with the same name and set the first one to create and the second to update. This created the plan and set it to active every time. 

    I was in the same boat. It took the second gpudpdate to actually force the plan to become active. Just FYI.
    28 พฤษภาคม 2556 21:06
  • red888 you are correct, the second gpupdate causes the power plan to go active. I also noted that a gpupdate /force along with a single power plan with type Update does set it active right away. But when I change these policies I need them to take effect right away. So I followed you plan and created 2 plans- one Create and one Update. All works great. Thanks for this tip.
    16 ธันวาคม 2556 22:59