none
Problem with Server 2003 restarting after windows update when KVM is not currently on server port

    คำถาม

  • On several occasions over the last couple of months, our Windows Server 2003 Standard has been unavailable in the morning.  The server is on a Belkin F1DS102J Soho KVM switch.  As soon as I switch over to the port where the server is located, I can see it is shutting down. Within a few seconds, the server finishes shutting down and starts up correctly. I'm guessing that a Windows update has requested a restart, but I'm unclear why the server is pausing in the restart process until the KVM port is changed to the server.  Do you have any idea what could be causing this and what we could do to rectify the issue?  

    Thanks,

    Jeff
    14 มิถุนายน 2555 13:50

คำตอบ

ตอบทั้งหมด

  • Cheap KVM, probably not maintaining the electrical signals for the keyboard and mouse when the server is not the focus.  Attach a normal KB and mouse to the server and see if that lets it restart normally.   Personally, I would set automatic updates to just download and notify at the most, that way you have a controlled reboot.
    14 มิถุนายน 2555 14:55
  • Hi,

     

    I would like to confirm what is the current situation? If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

    Regards,

    Arthur Li

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Arthur Li

    TechNet Community Support

    20 มิถุนายน 2555 4:09
    ผู้ดูแล
  • Hi, sorry.  This client only has trouble occassionally, so I've been kind of slow checking on this.  Why would the state of the KVM keep it locked in a forever, "shutting down" mode?  I've had servers with no keyboard and mouse work fine for auto-updates. Also, I have remote rebooted this machine on multiple occassions without issue.  It appears to be only during automatic updates.  If Windows is looking for a keyboard and mouse attached, is there a way to change this behavior?

    Thanks,

    Jeff

    21 มิถุนายน 2555 11:54
  • I know this is an old post but I still get the same thing happening on 2003 servers and Windows XP. After an auto update the server does not auto reboot while the KVM is set on another box. It sits there until I switch to that server port, then it shutsdown and restarts.

    I'm not using a cheap KVM, it works fine with 2008 and 2012.

    The weird thing is I also get the same exact behavior on virtual 2003 servers and windows XP. It will sit there until I open a console then it shutsdown. RPD will not work as terminal services are stopped at the point that it sits at.

    I've been seeing this behaviour for years, I don't have many physical 2003 servers on KVM these days but I still get this issue on VMs, I'm using ESXi 4.1. - very annoying.

     

    6 พฤศจิกายน 2556 18:53
  • Sorry I can't provide any help. We have since upgraded that client to Server 2008 R2 and the problem went away. I agree that this seems to be specific to Server 2003.  Best of luck finding a solution.  If you do, can you please update this post so I will have the information for future reference?

    Thanks,

    Jeff

    12 พฤศจิกายน 2556 18:54