none
Unable to connect to hyperV host once the external virtual network is enabled

    Soru

  • Host is running Windows hyperv r2 sp1. Everything works great until trying to enable external virtual network on host thru' a client running windows 7 with RSAT. Host is on workgroup and client is in domain. All the settings including the anonymous dcom, local user setup/password, disable firewall, lmhost...etc were tried.

    I have enabled the sharing of network card with management O/S when setting up the external virtual network. Once I clicked the apply button on the virtual network setup, the warning about the brief network interruption showed and then I lost connection. On the host, I can see that NIC3 was setup with a local IP address for the virtual network and the host is not accessible anymore. Just wondering if I have missed something simple? I didn't add another NIC for the management as I think this setup should work.

    Right now I used the nvspscrub.js to reset the adapter settings on host to resume connection.

    Thanks in advance.

    Nelson

    18 Haziran 2012 Pazartesi 21:02

Tüm Yanıtlar

  • Hi,

    In order to perform the further research, please help me to collect the following information:
     
    1. Have you configured the Hyper-V computer to be allowed Remote Desktop before you create the External Virtual Network?
    2. Can you ping the Hyper-V host machine after you create the External Virtual Network?
    3. Can you remote desktop into the Hyper-V host machine after you create the External Virtual Network?
    4. If you can login to the Hyper-V host machine locally, please check whether you can connect to outside from that machine.

    19 Haziran 2012 Salı 02:09
    Moderatör
  • Hi,

    First, are you aware about the hyper-v virtual network configuration ? Then, when you create an external virtual network, it must be linked to a physical NIC. Sometimes, when you apply this configuration, the IP address of the physical NIC is changed automatically and another ip address is set.

    So, you have to set the IP address of your hypervisor to the virtual network card (external) and not to the physical NIC.

    tell me if you need any other informations.

    best regards


    Raynald CHAFFAUX Consultant Virtualisation Nelite North Africa

    19 Haziran 2012 Salı 15:34
  • Thanks Vincent.

    Answers to your questions:

    1. Yes, that was setup and remote desktop is fine before creating the external virtual network

    2. No, I couldn't ping the host

    3. I couldn't remote in tothe host

    4. I couldn't connect to outside from the local host, unable to ping or resolve any names

    Below is the error on my windows 7 management PC (with RSAT installed) after I applied the setting to create the external virtual network:

    I'm just wondering, if the external virtual network settings were applied successfully, should I still see the physical network adapter with it's original DHCP assigned IP address listed as one of the adapters under the network settings (option number 8) on the interface? Thanks again.

    21 Haziran 2012 Perşembe 15:49
  • Yes, I did link it to the physical NIC. If it's got changed, shouldn't it be showed somewhere? I even checked our DHCP server but wasn't able to find any new IP assigned to this host.

    I'm not sure what you meant by setting the IP address of the hypervisor to the virtual network card (external)?

    Thanks in advance.

    Nelson

    21 Haziran 2012 Perşembe 15:52
  • Hi!

    When you create an external virtual network and allow it to be shared with the host management OS from remote, you will receive the error you posted. The physical NIC that was previously used to reach the host, will be wiped of all TCP/IP settings and serve as "uplink" to a virtual switch. The hostname IP address registered in DNS is now most likely invalid. That is why you lose connection to the host.

    By checking the box to share adapter with host, a new virtual NIC is presented to the host and connected to the virtual switch. This adapter is considered as a new device to the host, and does not neccessarily contain the IP settings previously used and must be configured from scratch.

    You need to logon the Hyper-V host console and configure the new NIC with a static IP to be able to reach it from a remote computer.

    This is a pain, and it is also one of the many reasons why the official best-practice recommendation is to dedicate separate NIC's for host OS management and VM traffic.

    22 Haziran 2012 Cuma 07:55
  • Thanks, Mike.

    I wasn't able to find my physical NIC settings (index # used to be 0 with a DHCP address) after the new virtual network is created (i.e. index# 3 under network settings with a local IP address). As you said, that could be wiped off by the external virtual network setup.  I did try setting a static IP for index#3 as suggested and restarted the host. However, I still wasn't able to connect to the host thru' remote desktop or hyperv management client, or connect to any other IPs from the host.

    I think I'm going to add a NIC to see how it goes.

    Thanks for all the replies.

    Nelson

    25 Haziran 2012 Pazartesi 17:25
  • Hi,

    Any news of your issue ?

    When you create an External Network Card with the hyper-v console, you can see a new card (virtual card) on the "Network connexions" windows.

    You have to specify an IP Address on this card, and NOT on the physical card, wich is now configured witch the "Virtual network commutation protocol" option only (see the following screenshot)

    Here you can see my virtual card wich as been created when I have add an External virtual network card

    Here you can see the configuration of my physical card after I have linked it to the Hyper-v External virtual network card

    Can you check that your config is agree with this concept and give us a feedback please.

    Best regards


    Raynald CHAFFAUX Consultant Virtualisation Nelite North Africa

    26 Haziran 2012 Salı 10:53
  • Thanks for your reply.

    I wasn't able to see the new card as I lost connection to the host while setting up the external virtual (see error window above). On the host, it's only showing the index#3 from the network connections and nothing else. It seemed like the external virtual network setup was not complete somehow.

    Nelson

    26 Haziran 2012 Salı 13:27
  • More info. Below is the IPCONFIG details on the hyperv host, I assigned a static IP to the card but still wasn't able to connect:

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : HyperV
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 3:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : New Virtual Network
       Physical Address. . . . . . . . . : 3C-D9-2B-54-8F-91
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::89f8:802e:b2d0:156f%21(Preferred)
       IPv4 Address. . . . . . . . . . . : 172.19.4.194(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       Default Gateway . . . . . . . . . : 172.19.4.1
       DHCPv6 IAID . . . . . . . . . . . : 356309291
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-68-3D-F0-3C-D9-2B-54-8F-91
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{0E136555-039A-4B3F-915B-EDBAEDB681E1}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #17
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    26 Haziran 2012 Salı 14:43
  • Can you disable IPV6 on this NIC ? Because I see that the DNS servers are listed with the IPV6 address, I think that you don't use IPV6 on your network.


    Raynald CHAFFAUX Consultant Virtualisation Nelite North Africa

    26 Haziran 2012 Salı 15:10
  • The IPV6 is probably generated by the installation automatically. Can you please let me know how to disable it? I don't see any options in network settings (option #8) from the menu.
    26 Haziran 2012 Salı 15:20
  • You can begin by uncheck the IPV6 option on the NIC properties

    This will disable IPV6 for this NIC.

    Now, to disable all IPV6 component, please follow the procedure :

    Open the registry console (regedit.exe),  Then, navigate through HKEY_LOCAL_MACHINE, SYSTEM > CurrentControlSet > services > TCPIP6 and Parameters.

    Right click on Parameters and select New and then DWORD (32-bit) Value. Name the new value DisabledComponents and hit Enter. Now right click on the new DisabledComponents value you just created and select Modify. Set the value of DisabledComponents to FFFFFFFF and click OK.

    After a reboot IPv6 will be disabled on all interfaces


    Raynald CHAFFAUX Consultant Virtualisation Nelite North Africa

    26 Haziran 2012 Salı 15:30