none
Problem adding BCS mapped attributed in User Profiles Service

    问题

  • Hi all,

    I have been looking around and can't see anybody reporting the same problem as I am having.

    I am trying to manage Profile Properties to map a newly created attribute (Employee ID) to a field in my BCS connection to an external SQL database. When I choose the field I want to map, and press OK, I am returned to the Profile Properties page and when I look at the Employee ID field, there is no mapped attribute! If I use an Active Directory mapping it works, but using my BCS connection it doesn't. 

    Has anyone experienced this behaviour before? I am getting no error messages or any indication that anything is failing. The external content type is working, because I can pull all the data through an External List.

    Any help would be appreciated, I am stumped!

    Thanks,

    Tal

    2012年6月20日 14:28

全部回复

  • *bump*

    Looking at the ULS logs, at the moment I try to set the property, the below errors are logged. I have looked online for other people with this problem but they get the error when creating a new Synchronization connection, and restarting the FIM services fixes their problem. This does not resolve the issue for me. I have also since tried connecting to a different database (same SQL instance) using a different External Content Type and I still get the error.

    LoadConnections failed trying to fill the connections list. Most likely during RetriveResources because of permissions --- {1}.  Available parameters: Microsoft.ResourceManagement.WebServices.Client.PermissionDeniedException: Access to the requested resource(s) is denied     at Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters)     at Microsoft.ResourceManagement.WebServices.ResourceManager.RetrieveResources()     at Microsoft.Office.Server.UserProfiles.ConnectionManager.LoadConnections(Boolean fForUI) .

    2012年6月21日 14:12
  • OK That didnt' work... Error below

    LoadConnections failed trying to fill the connections list. Most likely during RetriveResources because of permissions --- {1}.  Available parameters: Microsoft.ResourceManagement.WebServices.Client.PermissionDeniedException: Access to the requested resource(s) is denied     at Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters)     at Microsoft.ResourceManagement.WebServices.ResourceManager.RetrieveResources()     at Microsoft.Office.Server.UserProfiles.ConnectionManager.LoadConnections(Boolean fForUI) .

    2012年6月21日 14:12
  • I have been looking through these various articles, as well as others, and while they all have you create a new managed property, when I try to create the sync connection, the only two fields that are present are SPS-DisplauOrder and SPS-Emailoptin. The new properties are not there to select. Any ideas?
    <object height="0" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="0"><param name="tabId" value="ff-tab-11" /><param name="counter" value="216" /></object>

    Imagine what we could be...if we could just imagine. | Daniel A. Galant | Sr. SharePoint Solutions Architect EPC Group.net

    2012年10月25日 16:45