none
user profile sync service started but unknown error when trying to manage user profile service

    问题

  • Hi there

    I have SP2010 SP1 Feb 2012 CU running on a w2k8 R2 box with SQL 2008 R2 - all one box and everything running under admin account - it's a Dev box I'm running at home and I really need to get the User profile service app up and running

    Started managed metadata service, state service and created web app for mysites and mysites host and followed the steps in the Harbar article to set up UPSA - all goes well and after 10mins the User profile sync service finally displays started - both FIM services running fine and iisreset done- but when I try to open the service app by highlighting and clicking manage - I just get an unknown error - nothing in the event logs.

    Has this happened to anyone esle - I've deleted all the old FIM certs and tried setting the FIM services to run under the local system account, even rebuilt the entire farm this morning but still can't actually open the service app even though both services and the FIM services are started and I've given delegate permissions to the account 

    If anyone can help - much, much appreciated

    Jonj

    2012年6月30日 13:43

答案

  • Breakthrough at last! - after days of rebuilds, updates, restarts etc - I rebuilt the farm with SP1 and Aug 2011 CUs and the User Profile sync service started and I was able at last to mange the service by selecting it in service apps and clicking mange - woohoo -

    This makes me very nervous about the planned update from Aug 2011 to Feb 2012 CUs at our company - has anyone had any problems doing this - I may start a discussion thread about this as possibly going off topic now

    2012年7月3日 7:06

全部回复

  • You can do one of two things after the UPSS service has started:

    Recycle the Central Administration Application Pool

    iisreset

    You'll find MS documentation saying iisreset is the proper route, but recycling Central Admin App Pool also functions correctly (it is reloading a cached DLL); this information came from the product group and I used it successfully for quite some time.

    The issue stems from running Central Admin on the same server as the User Profile Sync Service.  If they're running on separate boxes, this is not an issue.


    http://sharepoint.nauplius.net

    2012年6月30日 16:22
    版主
  • Thanks but I've done numerous iisresets and even server restarts and this hasn't resolved the issue -

    All I can find in ULS is this:

    UserProfileServiceImportStatisticsWebPart:LoadControl failed, Exception: System.MissingMethodException: Method not found: 'Boolean Microsoft.Office.Server.UserProfiles.UserProfileImportJob.get_IsSynchronizationRunning()'.     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPart._LoadStatusAndSettings()     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceStatisticsWebPartBase.LoadControl(Object sender, EventArgs e)

    System.MissingMethodException: Method not found: 'System.String Microsoft.Office.Server.UserProfiles.SynchronizationRunStatus.get_ConnectionName()'.   
     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPart.RenderSectionContents(HtmlTextWriter writer)    
     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPart.RenderWebPart(HtmlTextWriter writer)    
     at Microsoft.SharePoint.WebPartPages.WebPart.Render(HtmlTextWriter writer)    
     at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)    
     at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)    
     at System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer)    
     at System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output)    
     at System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer)    
     at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)    
     at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer)    
     at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)    
     at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)    
     at Microsoft.SharePoint.WebControls.UnsecuredLayoutsPageBase.RenderChildren(HtmlTextWriter writer)    
     at System.Web.UI.Page.Render(HtmlTextWriter writer)    
     at Microsoft.SharePoint.WebControls.UnsecuredLayoutsPageBase.Render(HtmlTextWriter writer)    
     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Any ideas?


    • 已编辑 jonjames 2012年7月2日 19:14
    2012年7月2日 7:05
  • Breakthrough at last! - after days of rebuilds, updates, restarts etc - I rebuilt the farm with SP1 and Aug 2011 CUs and the User Profile sync service started and I was able at last to mange the service by selecting it in service apps and clicking mange - woohoo -

    This makes me very nervous about the planned update from Aug 2011 to Feb 2012 CUs at our company - has anyone had any problems doing this - I may start a discussion thread about this as possibly going off topic now

    2012年7月3日 7:06