none
Explorer View not working for some users - Specific Web Application

    问题

  • We have had some end users run into this problem recently and having exhausted all possible troubleshooting I figured I would post on here to see if anyone has encountered this before or knows what's going on.

    For certain users we have an issue where Explorer View does not work for them.  When they try to access it they get the error below:

    Documents in this folder are not available. The folder may have been moved or deleted, or network problems may be preventing a connection to the server.<o:p></o:p>

    Server error: The URL https://[site]/_vti_bin/_vti_aut/author.dll is not contained within a Windows SharePoint Services site.

    I have tried numerous solutions to try and resolve the error but nothing seems to work.  Some more info:

    • SharePoint 2010 (recently upgraded from SharePoint 2007 – Same SQL server, new WFEs)
    • WebDAV Publishing is NOT enabled on any of the WFEs
    • WebClient service on client PC is not the issue (Started on all client machines for both users that have an issue and users that do not)
    • Worked previously in SharePoint 2007 prior to upgrading
    • Does not affect all users, only some users have this issue
    • They only have this issue on this specific web application.  Tried other sites within different web apps and it works correctly.
    • The web application contains only a single site collection which is the root site collection so having no root site collection existing is not the issue.
    • Managed Paths are not used
    • Some users also have an issue where rather than the error above they get the “Your client does not support opening this list with Windows Explorer” intermittently (Only difference for these users being they are using Windows 7 instead of Windows XP)
    • The only end users having these issues exist in a different DNS then where SharePoint 2010 is hosted (firewall to firewall trust).       However it is still not all end users in this group having issues.
    • Could not find anything in the logs that references this

    If any additional info is needed just let me know and I'd be happy to provide it.  Thanks in advance for the help!

    2012年6月29日 14:42

答案

  • So we finally got this issue figured out so I thought I would post back here on what we had to do to get it resolved.

    Turns out the issue was with the settings of the ISA server.  While all other web applications were setup on the ISA server using the SharePoint wizard the one that we were having issues with was done manually.  So when it was added it was created as the wildcard [sitename]/* to include everything.  However when we checked the other web applications we noticed that they were slightly different in that they had the entries [sitename]/* as well as [sitename]/_vti_bin/* which wass kind of confusing since we thought that the first wildcard should include everything under the site name.  We tried to add it manually but it refused saying that the additional address was already covered under the lone wildcard inclusion.  So instead we ran the wizard for the web application and sure enough it added the two wild card entries of [sitename]/* as well as [sitename]/_vti_bin/* which it was previously missing (this is where the author.dll file was located which it could not access).  Sure enough after doing this explorer view started to work for everyone as well as a random issue people were having with uploading or checking in documents.  Seems that the single wildcard does not include the _vti_bin folder as you would expect.  If anyone else runs into this issue and have tried everything to solve it in vain this would definitely be worth checking if you have requests going through an ISA server.  Hope it helps someone else avoid the pains we have experienced this week :)

    2012年7月4日 17:42

全部回复

  • Did you try resetting IE?  Take a look at this support article:

    http://support.microsoft.com/kb/923737

    We find that this works sometimes for random errors like this that pop up.

    Let me know if it works!

    Brian


    blog: http://brianhochgurtel.blogspot.com MCTS SharePoint 2007 Administration and Development

    2012年7月1日 15:57
  • Thanks Brian, that's definitely something I haven't tried before.  Unfortunately though it didn't work to resolve the issue.
    2012年7月3日 11:11
  • Hi,

    have you try IE 8.

    thx


    iffi

    2012年7月4日 6:29
  • So we finally got this issue figured out so I thought I would post back here on what we had to do to get it resolved.

    Turns out the issue was with the settings of the ISA server.  While all other web applications were setup on the ISA server using the SharePoint wizard the one that we were having issues with was done manually.  So when it was added it was created as the wildcard [sitename]/* to include everything.  However when we checked the other web applications we noticed that they were slightly different in that they had the entries [sitename]/* as well as [sitename]/_vti_bin/* which wass kind of confusing since we thought that the first wildcard should include everything under the site name.  We tried to add it manually but it refused saying that the additional address was already covered under the lone wildcard inclusion.  So instead we ran the wizard for the web application and sure enough it added the two wild card entries of [sitename]/* as well as [sitename]/_vti_bin/* which it was previously missing (this is where the author.dll file was located which it could not access).  Sure enough after doing this explorer view started to work for everyone as well as a random issue people were having with uploading or checking in documents.  Seems that the single wildcard does not include the _vti_bin folder as you would expect.  If anyone else runs into this issue and have tried everything to solve it in vain this would definitely be worth checking if you have requests going through an ISA server.  Hope it helps someone else avoid the pains we have experienced this week :)

    2012年7月4日 17:42