none
Search Service Application not applying changes made in Thesaurus files - Sharepoint 2010

    常规讨论

  • Hi All,

    I was trying to make use of Thesaurus files  to make some group of synonyms which can improvise search results in the web application.

    But I did not want other Web Applications to get affected because of changes made in thesaurus files, So I created a New Search Service Application with Application Pool for Search Admin Web Service : Sharepoint Web Services Default and

    Application Pool for Search Query and Site Settings Web Service: Sharepoint Web Services Default

    The default Search Service and the new search service had same properties just that name was different.

    I created a new web application and used the new search service application , but found that results were affected because of changes made in thesaurus  files  . There are two separate GUIDS created under the path C:\Program Files\Microsoft Office Servers\14.0\Data\Office Server\Applications and separate copy of thesaurus files … But I am not able figure out how the new web application is also getting affected by the old search service .I have chked the  thesaurus files at both locations .

    Thanks,

    Pallavi

    2012年6月7日 11:33

全部回复

  • THe GUIDs are the right way to determine whay Application files to change. After you make the changes tothe Thesaurus files you have to stop and start the SharePoint 14 Search Service.

    Matthew


    Matthew McDermott, MVP SharePoint

    2012年6月10日 20:14
  • Hi Pallavi,

    Which files did you amend? Basically, if you amend the files in C:\Program Files\Microsoft office servers\14.0\Data\Office Server\Config, then these files are applied to every NEW search service application that you create from that point on.

    If you want to affect only the new one that you built, then you'll need the GUID of the newest search service application as Matthew points out. Then if you look in C:program files\microsoft office servers\14.0\Data\Office Server\Applications\##GUID##-query-0\config, this is where you should be amending your TSxxx.xml file to affect search results for that query server.

    If that isn't the one you've amended, do that, then stop/start the SharePoint Server Search Service.

    The last thing you need to do is make sure that your web application is using the right search service application. You will need to amend the service application group of your web application to use a new custom service application group. This will enable you to choose the new search service application to handle your queries, not the old one.

    Paul.


    Please ensure that you mark a question as Answered once you receive a satisfactory response. This helps people in future when searching and prevents the same questions being asked multiple times.


    • 已编辑 Cimares 2012年6月10日 20:49
    2012年6月10日 20:48
  • Hi Paul,

    I have edited the files which are under C:\Program Files\Microsoft Office Servers\14.0\Data\Office Server\Applications\**GUID**\Config\tsenu.xml file .

    When i created a new webapplication i had selected the the new search service app and unchecked the default search service app .

    I have restarted the sharepiont search service .

    But Still changes made in the old (initial app) search service app affects the new web application.

    How can find out details about which serach service application is used by the  web application through commands ?

    Thanks,

    Pallavi


    2012年6月11日 4:24
  • Hi Pallavi,

    Ok, can I check that your language on the server is set to English (US) as this is the Thesaurus file that you're editing. if it's not, then try editing TSNEU.xml. This is the Neutral language Thesaurus and is applied to EVERY search regardless of language settings.

    Also the location should be ##GUID##-query-0/config not ##GUID##/config

    I'm just working out which Powershell commands should give you this GUID and will psot them shortly.

    Paul


    Please ensure that you mark a question as Answered once you receive a satisfactory response. This helps people in future when searching and prevents the same questions being asked multiple times.



    • 已编辑 Cimares 2012年6月11日 8:39
    2012年6月11日 8:38
  • Ok, the best way to confirm exactly which Search Service application is running with your Web Application through powershell is:-

    $wa = get-spwebapplication "YourURL"
    
    $wa.ServiceApplicationProxyGroup

    That will confirm whether the default is being used or not. Then use the following commands to verify the GUID.

    $wadp = $wa.serviceapplicationproxygroup
    $wadp.proxies
    

    You should see the defined search service proxy listed here.. (Note it's the proxy, not the search service so this still isn't the GUID we need, but copy that .)

    $ssproxy = get-spserviceapplicationproxy -id ###GUIDhere##
    
    $ssproxy.GetSearchServiceApplicationInfo()
    

    This lists the Search Service application ID in use by this proxy, now we can get a reference to the search service itself.

    $ss = get-spserviceapplication -id ##GuidfromSearchServiceInfo##

    get-spenterprisesearchquerytopology -searchapplication $ss

    Outputs:

    Id              : df0ee95e-3803-4dd5-9ae4-6a075178e514
    IndexPartitions : {2ce69f99-fced-4054-b73a-a594b94a421a}
    QueryComponents : {}
    State           : Inactive
    ActivationError :
    
    Id              : 8d01d38a-27cc-479d-8f0f-a2d1b1e932e8
    IndexPartitions : {3414a897-3fda-4e02-8373-84d1e761d50e}
    QueryComponents : {4d3f3db8-a11f-48c6-9d99-201bd52994e5-query-1, 4d3f3db8-a11f-
                      48c6-9d99-201bd52994e5-query-0}
    State           : Active
    ActivationError :

    That should confirm which GUID you should be editing the Config files for to affect it in the section marked QueryComponents

    Good luck.

    Paul.


    Please ensure that you mark a question as Answered once you receive a satisfactory response. This helps people in future when searching and prevents the same questions being asked multiple times.

    2012年6月11日 9:01
  • Hi Paul ,

    Thanks a lot for the knowledge share . :)

    1. My server has a Standalone Installation of Sharepoint 2010

    2.In my server machine at the follwong path C:\Program Files\Microsoft Office Servers\14.0\Data\Office Server\Applications .....i have only folders with GUID no folders with GUID-query-0 .

    3. I followed the steps which you had shared in powershell ,Output which i get after the last command is as follows:

    Id              : 90aa098b-0f7b-43da-9eea-8e564d3dc211
    IndexPartitions : {04db9196-7a5b-4bdd-a974-4c668817dcdc}
    QueryComponents : {}
    State           : Active
    ActivationError :

    I dont have any query components in it .

    I was just going thru about query componenst .Itis mentioned that one can not create query components in a standalone installation.

    Can u plz guide me on this .Is it bcoz my server has standalone installation it is affecting all the webapplications ?

    Thanks in Advance .

    Pallavi


    2012年6月12日 4:25
  • Hi Pallavi,

    I'm afraid I've not worked with standalone installs to that depth as they're quite restricted for future expansion so not really sure where you should look next I'm afraid.

    If I get a chance today I'll stand up a new VM and check it out.

    Paul.


    Please ensure that you mark a question as Answered once you receive a satisfactory response. This helps people in future when searching and prevents the same questions being asked multiple times.

    2012年6月12日 8:51
  • Hi Paul,
     
    I have tried the same in a diffrent Server , it did not have stand alone installation.
     
    But Still the changes made in Thesaurus file in one search service application file affects the other.
     
    In the new server which i am working on ...I could get folder with name \GUID-query-0\ and i verifed the GUID using the method which u had mentioned above using power shell.
     
    But one thing which i noticed is :
    I have created two web applications and two search service applications.
    Example : WebApp 1 --> Search Service App1
              WebApp 2 -->Search Service App2
    I have made changes in both the thesaurus file.
    When i Restart the SharePoint 14 Search Service one set of changes hets applied to both the web applications . Again if i restart the service another set . It keeps Toggling between both the Thesaurus file .
    I really dont undersatnd this weird behaviour.
     
    Thanks,
    Pallavi
    2012年6月12日 15:51