none
Installting new Sharepoint Farm - LanguagePacks issue

    问题

  • Hey guys,

    currently we're trying to install our new Sharepoint Farm. (2 WFE 1 ApplicationServer).

    • Installted 2008 R2 SP1 EN-US and LanguagePack DE-DE.
    • Installed Sharepoint Prerequisites
    • Windows Updates
    • Installed Sharepoint Enterprise with SP1 EN-US
    • Installed Office Web Apps with SP1 EN-US
    • Installed LanguagePack DE-DE (First Foundation, then Server)
    • Trying to install LanguagePack DE-DE SP1 but its not working (Installer says not applicable)
    • Next steps would be: Install CU Apr 2012 and finally run the Wizard

    So whats wrong? Why is it not applicable? We haven't executed the wizard.

    Regards

    Marcel

    2012年7月2日 8:21

答案

  • Thats true, you cannot slipsream lang pack into the installation itself.

    But you can slipstream langpack SP1 into langpack installation.


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    • 已标记为答案 Xeroxxx 2012年7月9日 7:46
    2012年7月2日 9:56

全部回复

  • If you have already installed SharePoint with SP1 I would install languagepacks with slipstreamed SP1. Extract the language pack package and into the Updates folder extract the SP1 for the language pack.

    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    2012年7月2日 9:18
  • Acutally I'vent tried this becuase last sentence of this blog post says "Language packs installation cannot be slipstreamed into the install of SharePoint itself. Separate installers must be run."

    http://blogs.msdn.com/b/ronalg/archive/2011/07/11/slipstream-sharepoint-2010-sp1-and-language-packs-w-sp1-into-rtm.aspx

    2012年7月2日 9:55
  • Thats true, you cannot slipsream lang pack into the installation itself.

    But you can slipstream langpack SP1 into langpack installation.


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    • 已标记为答案 Xeroxxx 2012年7月9日 7:46
    2012年7月2日 9:56
  • I tried slipstreaming SP1. Foundation installer says everything is fine but the server installer already says at the end "some updates could not be installed, blablabla"

    I think I should try installing Sharepoint without SP1 and install everything step by step :/

    or do you have any other suggestions?


    Detecting patch C:\Temp\3_LanguagePack - DE-DE\2\updates\xsmuisp1-de-de.msp
    Detecting patch C:\Temp\3_LanguagePack - DE-DE\2\updates\xsmuisp1-de-de.msp
    Failed to apply patch C:\Temp\3_LanguagePack - DE-DE\2\updates\svrproofsp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\svrproofsp1-it-it.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\spsmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\osrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\pjsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\ifsmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wdsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\ppsmamuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\vsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\xlsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\osrchmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\dlcmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\lpsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\osmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\xsmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\acsrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wasrvmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wosrvmuisp1-de-de.msp
    Failed to apply patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wacproofsp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wacproofsp1-it-it.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\xlwacmuisp1-de-de.msp
    Successfully applied patch C:\Temp\3_LanguagePack - DE-DE\2\updates\wacmuisp1-de-de.msp
    Error applying patch: <Properties><Property name="Description">Compound error encountered.</Property><Property name="Hresult">-2147467259</Property></Properties>
    Error: Type: . PatchApplicationFailure ErrorCode: -2147467259(0x80004005). Unspecified error
    
    
    Executing command path: 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe', args: 'updateproductinfo'
    Start C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe updateproductinfo
    Command 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe' returned: 0
    Not running post install command from install job.  Install: yes, Before chain: FALSE, UI Level: 2
    Showing completion dialog.
    Showing post install command option.
    Reboot requested if needed.
    No reboot is needed.
    Catalyst execution finished: 07/02/2012 12:16:07.  Return code: 0.
    PERF: TickCount=6375792 Name=RunSetup Description=End function
    
    Setup temp folder set to [C:\Users\User\AppData\Local\Temp\Setup00000edc].


    • 已编辑 Xeroxxx 2012年7月2日 10:23
    2012年7月2日 10:18
  • Thats true, you cannot slipsream lang pack into the installation itself.

    But you can slipstream langpack SP1 into langpack installation.


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    Seems to be the solution.

    Thank you.


    • 已编辑 Xeroxxx 2012年7月9日 7:47
    2012年7月9日 7:46