none
Workflow, versionning ang doc template issue

    問題

  • Hello,

    I've got an issue with Sharepoint 2010 (Server Std), workflows, versionning and quickpart: I created docx document templates, stored in a library dedicated to templates. This library has a specific content type with few fields (lets say type mydocument: a number and a text...).
    I'm able to map my quickparts in each template, it's ok. I've got a workflow (manual start) that let you choose a template to create a new document in a library. This library uses descendants of the template content type (mydocumentwithtemplate), with a template docx from the template lib.

    I initiate my content type fields in the workflow and everything works perfectly, my new doc uses the template and when open, is well populated.

    The problem happens when I start the workflow to re-generate the same document (versionning is activated and I want to overwrite the old document). The workflow works well but it seems that after the document is generated (with mapped field) in a new version, it is overwritten by an empty template with default field values, generating another new version. I can see it in the history and select the previous version. But I can't ask my users to get the previous version each time they re generate a doc, and i don't want to create a doc with a new name (i want to use SP versionning feature).

    Somebody has ever seen this? Is this a bug? How can I solve this problem?

    Thanks by advance

    Stef

    2012年6月5日 上午 09:30

解答

  • Hi Stef,

    Thank you for your forum posting. I have read over the forum posting and I would recommend using our paid support option. I recommend this for a few reasons, one of which will allow us to use your document template you created and verify there are no issues with it. I would also like to recommend paid support for this as it would let us see firsthand the steps to reproduce this and clarify any misunderstanding in the post.

    As always any member of the forum community can reply to this thread and assist you as well.

    Gregg


    MSFT

    2012年6月15日 下午 05:06
    版主

所有回覆

  • Hi,

    Thank you for your post.

    I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    2012年6月7日 下午 12:01
  • Hi all, Emir,

    Have you any new idea on this case?

    Thank you!

    Stef

    2012年6月12日 下午 02:12
  • Hi Stef,

    Thank you for your forum posting. I have read over the forum posting and I would recommend using our paid support option. I recommend this for a few reasons, one of which will allow us to use your document template you created and verify there are no issues with it. I would also like to recommend paid support for this as it would let us see firsthand the steps to reproduce this and clarify any misunderstanding in the post.

    As always any member of the forum community can reply to this thread and assist you as well.

    Gregg


    MSFT

    2012年6月15日 下午 05:06
    版主