none
The document is a duplicate. Contact the sender.

    問題

  • Fuind the error I am getting while processing the EDI message

    I am using Biztalk server 2006 and Covast for EDI processing.

    An output message of the component "Covast EDI Disassembler" in receive pipeline "Covast.BizTalk.Pipeline.EDI.CovastEDIReceivePipeline, Covast.BizTalk.Pipeline.EDI.Default, Version=5.0.0.0, Culture=neutral, PublicKeyToken=68bef120a46b49ad" is suspended due to the following error:
         Message translation failed:
    (80) The document is a duplicate. Contact the sender.
    source format: [3 3  3  ]
    Interchange with format=[3 3  3  ] reference=[1170476] sender=[SENDER][14][] and recipient=[65757][14][] already arrived as interchange with intnr=[18833] on date=[2012/05/25] time=[13:21:05]
    .
     The sequence number of the suspended message is 1.

    PLease help me for the solution

    2012年5月28日 上午 10:39

解答

  • I found the answer you just need to do following steps:

    1. go to the covast Admin Console

    2.Click + of Covast EDI ASccelerator 2006 Administration

    3.Covast Group

    4.Parties select your Party f.ex. Party1

    5.Click + of Party1

    6.Then Click + of EDI:///

    7. select General .There you will find an option Allow duplicates click on YES(No acknowledgement)

    thats it it will help you

    Note: Dont forget to restart the BT Service.

    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    • 已標示為解答 har 2012年8月1日 上午 08:01
    2012年8月1日 上午 08:01

所有回覆

  • Hi,

    Change the UNB 5 interchange control number and submit.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月28日 上午 10:46
  • How to do that
    2012年5月28日 上午 10:48
  • Taking this sample from you other post. If that issue is resolved pls mark the post accordingly.

    You can the control number 000581

    UNB+UNOC:3+5790000016839:14+5790001865757:14+120518:1510+000581'


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月28日 上午 10:53
  • No that issue is not resolved yet

    yuo have not given any resolution yet

    please guide me

    atlest help me accordingly

    2012年5月28日 上午 10:57
  • Hi,

    Well doesn't make sense .. did you change the control number and resubmit .. does it work now ..


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月28日 上午 10:59
  • that's what am asking you to guid me the steps to do that

    Do we have something in EDI property to allow Duplicate something

    2012年5月28日 上午 11:02
  • There is no allowing duplicate something . I would recommend do some readup on the covast EDI documentation the interchange control number can be reset in the party properties but dont remember where. So look at the documentation as this is pretty basic.

    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月28日 上午 11:08
  • If I will change the control number will it affect the other parties

    I dont find any Control number properties in the Party Property

    2012年5月28日 上午 11:28
  • Hi,

    Do you see any check for duplicate UB5 check box in EDIFACT property settings. Uncheck that. And I meant change the control number in your file manually to see if that works on resubmit.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.


    • 已編輯 DPS Bali 2012年5月28日 上午 11:51
    2012年5月28日 上午 11:51
  • I am not able to find any UB 5 itself

    Its not possible to change the control number everytime dont we have any settings to allow the message more than once

    2012年5月28日 上午 11:56
  • You should be able to reset the control number, this is usually a unique sequence and is not expected to be same everytime.

    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月28日 下午 12:01
  • I found the answer you just need to do following steps:

    1. go to the covast Admin Console

    2.Click + of Covast EDI ASccelerator 2006 Administration

    3.Covast Group

    4.Parties select your Party f.ex. Party1

    5.Click + of Party1

    6.Then Click + of EDI:///

    7. select General .There you will find an option Allow duplicates click on YES(No acknowledgement)

    thats it it will help you

    Note: Dont forget to restart the BT Service.

    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    • 已標示為解答 har 2012年8月1日 上午 08:01
    2012年8月1日 上午 08:01
  • The solution which you implemented is good to resolve the issue, however do understand that by doing this you are actually allowing processing of duplicate message by BizTalk. You can easily ignore this error. I don't know whats your business requirement but avoid doing this.

    Just understand why this error is coming

    1) Your partner send message to you

    2) Covast accept this message and acknowlege it back

    3) Due to some reason your partner send the same message again (Network glitch, ack not received in time)

    4) Covast detect this message as duplicate based on interchange id and reject it.

    SO  what now Covast is going to do even though it received the same interchange previously if it get same message again it is going to process it again.

    Now decide based on your buisness

    2012年8月1日 上午 10:03
  • How can I easily ignore such error .Could you please guide me?

    2012年8月1日 上午 10:58
  • Hi Har,

    When i said you can easily ignore this error, what i mean is don't care about this. Its not going to affect anything. Just consider this error as information/warning.

    Regards

    2012年8月1日 下午 12:07
  • No its not just warning its not allowing message to go to the out folder

    Its getting stuck at BT itsself

    thats why I asked how can I allow duplicate values.

    Thank you

    2012年8月1日 下午 01:17