none
HYPER-V上的Windows Server 2008網路速度慢的問題

    一般討論

  • 您好:

    我有兩部實體的Server,上面都有8G的RAM,作業系統分別為Windows Server 2008 R2(SERVER A)與Windows Server 2008(SERVER B),都是64位元,都啟用了Hyper-V,也啟用兩張網卡,一張給SERVER,一張給VM使用:

    SERVER A上有三個VM,兩個VM的OS為Windows Server 2003,另一個VM為Windows Server 2008(整合服務已經安裝無誤),前兩個分別為Print Server與Web Server,運作十分正常,第三個VM(Windows Server 2008)的現象非常奇怪,網路速度非常的慢,我Ping IP的結果發現,回應速度都小於1ms,但是只要有Client向此VM提出Request(例如:遠端桌面連線或是瀏覽器的Web服務),網路的回應立刻高達3000ms,甚至time out,於是我將VM的VHD檔案,複製到SERVER B,結果網路運作非常順暢,看來似乎不是我VHD的問題,可是如果是網卡的問題的話,SERVER A上另外兩個VM卻又很正常,請問大家,問題所在的地方是什麼呢?

     

    • 已變更類型 Vincent Lin 2010年6月21日 上午 05:14
    2010年6月14日 上午 06:17

所有回覆

  • 如果Server 2008 的VM再移回到Server A 上,
    還是會有同樣狀況發生嗎?
    Host OS 是否有安裝了防毒軟體或網卡管理軟體?
    有的話,請先試著反安裝移除看有無改善。
    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    2010年6月14日 上午 06:41
    版主
  • 我嘗試過把VM移到SERVER A,很正常,再移回SERVER B又不行了

    HOST OS上面沒有防毒軟體,也沒有網卡管理軟體

    2010年6月14日 上午 07:27
  • 兩台Host主機所接的網路設備(Switch)是否為同一台呢?
    是一般的集線器還是具有L2或L3網管功能?
    VM 移動到另一台後,可以試試看重新啟動該設備,
    觀察是否有改善,因為小弟猜測是不是網路設備造成的狀況。
    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    2010年6月14日 上午 08:40
    版主
  • 兩台接到相同的一台Switch,而且是一般普通的Switch,沒有網管功能

    2010年6月14日 上午 08:42
  • 那要不要試著切換使用另一張網卡

    或者換一張新的網路卡試看看

    並將網路卡的驅動程式更新到最新看看


    分享工作上的經驗,Windows歡迎提出討論,Jerry_IT資訊技術手札 - 無名小站http://www.wretch.cc/blog/jerry0822 10/26影音教學(有聲音)Jerry_IT資訊教學影片技術手札(http://kili92.myweb.hinet.net/index.htm)
    2010年6月14日 上午 08:45
  • 我的SERVER共有四張網卡

    我都更新最新驅動程式了

    而且也換過不同的網卡PORT,但是還是不行

    怪異的是,我另外兩個VM(SERVER 2003)都很正常

    2010年6月15日 上午 12:54
  • 那個有問題的VM是在Server 2008 R2上面從安裝的呢? 還是從Server 2008上面安裝的然後轉移過來的?

    可以試試看在Server 2008 R2上面重新建立一個相同系統的VM看看是否有類似情況產生

    另外可以檢查看看有問題的VM裡面事件檢視器是否有什麼錯誤訊息

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年6月17日 上午 02:38
  • 都不是上述這些問題造成的,後來我直接問了微軟,他們說是小BUG,目前已經解決,謝謝大家的幫忙
    2010年6月25日 上午 03:28
  • 如果可以的話可以把解決的方法貼上來給之後遇到問題的人參考囉 :)

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年6月25日 上午 03:46
  • 都不是上述這些問題造成的,後來我直接問了微軟,他們說是小BUG,目前已經解決,謝謝大家的幫忙
    怎麼解決的?我現在也是有這個問題,可以說一下解決方法嗎?非常感謝!!
    2012年6月14日 上午 02:04