none
failure executing the receive pipeline

    問題

  • Hi,

    Partner is trying to send me a message through AS2, i have configured all needed to receive and send. everything is ok with sending to partner. but when Partner send a message to us we get the following error:

    There was a failure executing the receive pipeline: "XXXXXXXXX.ReceiveAS2" Source: "Unknown " Receive Port: "ReceiveFromPartner" URI: "/BTSHTTPReceive.dll" Reason: Failed to get pipeline: XXXXXXXXX. Please verify that the pipeline strong name is correct and that the pipeline assembly is in the GAC.

    Please note that the assembly exists in the GAC and signed. the pipeline is just a standard pipeline and no custom pipelines used.

    Just to provide more details. I am using BizTalk 2010 on a windows 2008 R2 64 bit.

    I have two applications in BizTalk MGMT DB. Application A  and Application B.

    Application B references Application A.

    The recieve port is configured in application B. but the receive pipeline is installed in application A.

    Please help?

    Mazin


    Regards, Mazin - MCTS BizTalk Server 2006


    2012年5月30日 上午 10:27

解答

  • this could be issue with the app pool, check if its running under 4.0 if not change and restart IIS

    KiranMP

    2012年5月30日 上午 11:41
  • Hi Kiran,

    I had to configure the handler mapping for btshttpreceive.dll  again and it solved the problem of 405 error.

    Thanks for your help!


    Regards, Mazin - MCTS BizTalk Server 2006

    2012年5月30日 下午 12:29

所有回覆

  • Hi,

    Not sure why you have the pipeline in app A when the port is in B. However, this error suggests that the pipeline is not available. Can you redeploy the project containing the pipeline and restart the host instance.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    2012年5月30日 上午 11:01
  • this could be issue with the app pool, check if its running under 4.0 if not change and restart IIS

    KiranMP

    2012年5月30日 上午 11:41
  • Hi Kiran,

    Thanks for your response. i changed the application pool to 4.0 and YES THAT WORKED!! BUTTTTTT... i am getting another error now :

    There was a failure executing the receive pipeline: "XXXXXXXXXXXX.ReceiveAS2" Source: "Unknown " Receive Port: "ReceiveFromPartner" URI: "/BTSHTTPReceive.dll" Reason: Retrieving the COM class factory for component with CLSID {254B4004-2AA7-4C82-BB2E-18BA7F22DCD2} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    Any ideas?


    Regards, Mazin - MCTS BizTalk Server 2006

    2012年5月30日 上午 11:49
  • IIS should run on 32 bit to fix this error

    to run 32-bit applications on 64-bit Windows

    1.

    Open a command prompt and navigate to the %systemdrive%\Inetpub\AdminScripts directory.

    2.

    Type the following command:

    cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 “true”

    3.

    Press ENTER.


    KiranMP


    2012年5月30日 上午 11:53
  • Thanks Kiran,

    but there is no Adminscripts directory in inetpub.

    However, i went to advanced settings in the application pool and changed the property to allow 32 bit application.

    But this caused another issue, 405 method not allowed


    Regards, Mazin - MCTS BizTalk Server 2006

    2012年5月30日 下午 12:04
  • not sure of this error

    but did you run this command?

    <%windir%>Microsoft.NET/Framework/v2.0.50727/aspnet_regiis -i -enable


    KiranMP

    2012年5月30日 下午 12:19
  • Hi Kiran,

    I had to configure the handler mapping for btshttpreceive.dll  again and it solved the problem of 405 error.

    Thanks for your help!


    Regards, Mazin - MCTS BizTalk Server 2006

    2012年5月30日 下午 12:29