none
iPhone 4s cannot get mail - the connection to the server failed.

    Question

  • Hello Everyone (well those that read)

    I need help desperately - I am trying to setup a new iPhone 4s with Microsoft Exchange Emails for my managing director. I have gone through the setup time and time again with no avail - all i keep getting is "Cannot get Mail - The connection to the server failed" its driving me crazy. I did run through the active sync test with the following results:

    ExRCA is testing Exchange ActiveSync.
      The Exchange ActiveSync test failed.
     
    Test Steps
     
    Attempting the Autodiscover and Exchange ActiveSync test (if requested).
      Testing of Autodiscover for Exchange ActiveSync failed.
     
    Test Steps
     
    Attempting each method of contacting the Autodiscover service.
      The Autodiscover service couldn't be contacted successfully by any method.
     
    Test Steps
     
    Attempting to test potential Autodiscover URL https:// manually deleted AutoDiscover/AutoDiscover.xml
      Testing of this potential Autodiscover URL failed.
     
    Test Steps
     
    Attempting to resolve the host name manually deleted in DNS.
      The host name couldn't be resolved.
       <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl00_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      Host manaually deleted couldn't be resolved in DNS InfoNoRecords.
    Attempting to test potential Autodiscover URL https://autodiscover.manually deleted/AutoDiscover/AutoDiscover.xml
      Testing of this potential Autodiscover URL failed.
     
    Test Steps
     
    Attempting to resolve the host name autodiscover.manually deleted in DNS.
      The host name couldn't be resolved.
       <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl01_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      Host autodiscover.manually deleted couldn't be resolved in DNS InfoDomainNonexistent.
    Attempting to contact the Autodiscover service using the HTTP redirect method.
      The attempt to contact Autodiscover using the HTTP Redirect method failed.
     
    Test Steps
     
    Attempting to resolve the host name autodiscover.manually deleted.com in DNS.
      The host name couldn't be resolved.
       <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl02_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      Host autodiscover.manually deleted couldn't be resolved in DNS InfoDomainNonexistent.
    Attempting to contact the Autodiscover service using the DNS SRV redirect method.
      ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
     
    Test Steps
     
    Attempting to locate SRV record _autodiscover._tcp.manually deleted in DNS.
      The Autodiscover SRV record wasn't found in DNS.
       <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl03_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>

    where it says manually deleted is where i have taken out myself due to confidenality of my company. I work with this companies IT department and havent been here for many years, so i have no idea where to start. If someone could help it would be greatly appreciated.

    Many thanks in advance

    Emma

    Tuesday, August 21, 2012 9:14 AM

All replies

  • Hi,

    The active sync virtual directory needs to be published to the internet - port 443 from the internet to the Exchange server.

    You can ignore the autodiscover errors as seen in the test if you configure the mail profile on the iPhone manually.

    Leif

    Tuesday, August 21, 2012 11:40 AM
  • Hi,

    Some companies uses a TMG server or similar to publish the exchange services:

    http://blogs.technet.com/b/exchange/archive/2010/07/16/publishing-exchange-server-2010-with-forefront-uag-and-tmg.aspx

    Other companies just forwards port 443 from the internet to the exchange server in the firewall (this port might already be forwarded to something else). This has to be acknowledged by the security people in your company

    Leif

    Tuesday, August 21, 2012 12:03 PM
  • Hello Sorry ive been told that ours doesnt block any ports they are all open.....?
    Tuesday, August 21, 2012 12:04 PM
  • Hi,

    I don't believe that - all ports open from the internet. If true that would be dangerous.

    I am talking from the internet to the exchange server

    Leif

    Tuesday, August 21, 2012 3:01 PM
  • This issue may due to missing the "Include inheritable permissions from this object's parent" option.

    Firstly, please go to Active Directory Users and Computers – View, and check the Advanced Features.

    Then, go to Properties of the mailbox account – Security tab – Advanced, and select the "Include inheritable permissions from this object's parent" option.

    Now you can test the Exchange ActiveSync again. Hope helps.


    Noya Lau

    TechNet Community Support

    • Proposed as answer by Noya Lau Tuesday, September 04, 2012 9:30 AM
    Wednesday, August 22, 2012 8:31 AM