none
Reboot and select a proper boot device

    Question

  • I successfully installed Windows 7 64 bits on to a new Seagate SATA3  2TB hard drive attached to an ASUS P6X58D Premium motherboard with an Intel i7 950 processor and 8 Gigabytes of memory. The Seagate hard drive is attached to a SATA 3 port.

    After the initial installation Windows 7 applied 3 updates and then rebooted, but failed with the error:

    Reboot and select a proper boot device.

    The only devices attached to the motherboard are the hard drive and the DVD drive.

    The BIOS recognizes both devices, which are set to IDE.

    I rebooted the Windows 7 installation DVD and selected the repair option, but my hard drive was not “visible” to the software. In command more I was able to view all the windows directories.

    I then switched the hard drive to a SATA2 port which received the same error message.

    I checked the ASUS site for software/BIOS updates and found my BIOS to be several levels behind so I downloaded and installed the latest BIOS which produced the same error message.

    Does anyone have a resolution to my problem?

    Monday, November 15, 2010 3:25 PM

Answers

  • Hi Jimmy,

    There are several reason will cause the error “Reboot and select a roper boot device”

    1 Haven’t installed  operation system

    2 HD broken

    3 The battery  of BIOS is no power

    4 The cable of IDE connect on motherboard is loosen or broken.

     

    I suggest checking BIOS, make sure the setting of first boot is HD. And make sure the Seagate SATA3 can be recognized by BIOS. Confirm that your IDE/ATA/SATA cable is firmly and correctly connected to your hard drive and motherboard.

     

    Furthermore, it’s possible that some sectors of you HD are broken, you can format whole HD and reinstall new operation system for test. Also you can change another HD to see if the same issue occurs.

     

    If any SATA driver is available, copy it to a removable media and load it from the Windows 7 setup media. You can refer to:

     

    http://www.ehow.com/how_5556846_install-sata-drivers-using-usb.html

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by JimmyDuke Wednesday, November 17, 2010 1:37 PM
    Wednesday, November 17, 2010 6:08 AM
    Moderator

All replies

  • Hi Jimmy,

    There are several reason will cause the error “Reboot and select a roper boot device”

    1 Haven’t installed  operation system

    2 HD broken

    3 The battery  of BIOS is no power

    4 The cable of IDE connect on motherboard is loosen or broken.

     

    I suggest checking BIOS, make sure the setting of first boot is HD. And make sure the Seagate SATA3 can be recognized by BIOS. Confirm that your IDE/ATA/SATA cable is firmly and correctly connected to your hard drive and motherboard.

     

    Furthermore, it’s possible that some sectors of you HD are broken, you can format whole HD and reinstall new operation system for test. Also you can change another HD to see if the same issue occurs.

     

    If any SATA driver is available, copy it to a removable media and load it from the Windows 7 setup media. You can refer to:

     

    http://www.ehow.com/how_5556846_install-sata-drivers-using-usb.html

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by JimmyDuke Wednesday, November 17, 2010 1:37 PM
    Wednesday, November 17, 2010 6:08 AM
    Moderator
  • You definitely want to select AHCI sata mode in the BIOS , save and exit, begin the installation process and add the drivers during the installation from Asus support , the driver disk that accompanied the motherboard or Intel. Using IDE will reduce the performance of the Sata 3 drive.
    Wednesday, November 17, 2010 12:52 PM